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Audience 

These release notes are for general SmartCare™ users trained in the basic workflow and use of 
SmartCare™.  

Applicable Releases 

The functionality documented these release notes supports SC.CORE.6.0_1.38.000.2509.001 and later.  

Permissions 

You can only access screens/items granted per your user login referred to as Permissions. Depending on 
your current level of permissions, you may need to contact your system administrator to have your 
permissions changed.  

Global Codes, Recodes, and Configuration Keys 

Refer to the Global Codes, Recodes, and Configuration Keys sections of these release notes for a list 
and definition of each code or key.  
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TASKS LIST-‘DEFECT FIXES’ (77) 
Note: Defect fixes address issues or errors in the system to restore expected functionality and improve 
overall performance. 

Sl. 
No 

Task No Summary Module Name 

2 Core Bugs # 
132995 

Users can still continue and successfully log into 
their account even when the account is set to 
"Can't Login" 

Authentication/Authorization 
(Login, Logout) 

3 Core Bugs # 
133078 

Service Detail: The billing rule was incorrectly 
applied to date of services. 

Authorizations 

4 Core Bugs # 
133047 

In Service Detail, proper conversion was not 
happening even when the unit types were 
different, for example, between minutes and 
hours. 

Authorizations 

5 Core Bugs # 
123711 

Authorizations: The system does not show an 
error when the ‘PM authorization units’ used 
exceed the authorized limit. 

Authorizations 

6 Core Bugs # 
133070 

The Batch Eligibility Change Review report 
incorrectly displays a plan as active, even though 
it is inactive on the Medicaid website. 

Batch Eligibility 

7 Core Bugs # 
132908 

Batch Service Import Failing Batch Service Import 

10 Core Bugs # 
132968 

Bed Census screen: when the user clicks the 
‘Status’ dropdown, the ‘Status’ dropdown 
disappears as soon as the mouse is moved. 

Bed Census 

11 Core Bugs # 
132530 

Bundle Code Units incorrectly calculated Bundle Services 

12 Core Bugs # 
132987 

ISERV2 Numerator, Denominator, and Average 
Time are displayed in hours. 

CCBHC 

19 Core Bugs # 
132902 

Claims data missing for void claims - Claims 
generation error 

Charges/Claims 

20 Core Bugs # 
129565 

Charge Status for voided charges was not 
correctly updated to “Void” in the Revenue Work 
Queue Management section’s Charge Status 
dropdown 

Charges/Claims 

22 Core Bugs # 
132937 

Segment count mismatch in void claim file. Charges/Claims 

28 Core Bugs # 
133043 

Performance issue in Client ‘Documents’ screen Client Document List Page 

29 Core Bugs # 
133063 

Client MAR: Administration Events not functioning 
as expected for MAT Take home medications. 

Client eMAR 

31 Core Bugs # 
133039 

‘Client Flag Details’ screen: Level Global Code 
drop-down is not honoring SortOrder. 

Client Flags 
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33 Core Bugs # 
132921 

Duplicate Lab Results are displayed in the ‘Lab 
Results Review’ screen. 

Client Orders 

34 Core Bugs # 
132745 

Client Orders: In the ‘Discontinued Titration 
Orders’ PDF, the end time is not displayed. 

Client Orders 

35 Core Bugs # 
132746 

Client Orders: Inconsistent display of A/F/I next to 
the medication name and in grid. 

Client Orders 

36 Core Bugs # 
132963 

The Order Name Display Format on Client Order 
List Page is updated. 

Client Orders 

37 Core Bugs # 
132988 

Services: Service Not Being Created from Lab 
Order 

Client Orders 

38 Core Bugs # 
133009 

Medications List Page: When the user clicks the 
‘Export’ icon, the data is not being exported. 

Client Orders 

39 Core Bugs # 
133121 

Allergy Flag (A/F/I) not displaying next to the 
medication name in the Order Set tab of the Client 
Order Screen, even if the medication was marked 
as an allergy. 

Client Orders 

40 Core Bugs # 
132912 

All Client Search - The Staff is able to see 
restricted clients for ‘Broad search’ but once after 
‘All Client Search’ button is clicked. 

Client Search Popup 

42 Core Bugs # 
130046 

Initialization Editor: On Save the Validation 
message for 'Generate Query' is not displayed 
consistently. 

Clinical Documentation 

44 Core Bugs # 
132723 

Enrollment Form Event: Saving twice on the 
Upload Image Details screen deletes the Event 
records. 

CM Events 

45 Core Bugs # 
133186 

Psychosocial Adult/Child List Medication field 
length 

Core Assessment 

47 Core Bugs # 
133029 

Crisis Call Log screen: when the status is 
completed, users are unable to read the entire 
contents from Text area. 

Crisis Call Log Details 

48 Core Bugs # 
132520 

CAFAS standalone connection issues with FAS Documents 

50 Core Bugs # 
132938 

ISP document: Initialization issue Documents 

51 Core Bugs # 
132586 

Spellcheck not working in Standard Mental Status 
Exam 

Documents 

52 Core Bugs # 
132878 

Incorrect Signature Details Displayed for Version 
Author 

Documents 

54 Core Bugs # 
133008 

When right-clicking a misspelled word, the 
previously typed text disappears. 

Documents 

56 Core Bugs # 
133046 

Significant Issue with the ‘Individualized Service 
Plan’ document. 

Documents 

57 Core Bugs # 
133156 Goals/Objectives tab - Objective text boxes cut off 

Documents 
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59 Core Bugs # 
132438 Getting an error while clicking on “Go to Online 

Cafas" and "Import CAFAS Scores" in the ‘CAFAS 
Standalone’. 

Documents 

60 Core Bugs # 
132804 

Error message displayed in Services/Notes 
screen when ‘DLA - SUD’ document has been 
incorporated as associated note. 

Documents 

61 Core Bugs # 
133060 

Performance issue in ‘Agency/Program 
Discharge’ document when client with more than 
10 enrolled programs. 

Documents 

62 Core Bugs # 
132960 

Medications being discontinued Documents 

63 Core Bugs # 
133143 

Issues with “Medication Reconciliation” Document 
Functionality 

Documents 

64 Core Bugs # 
132807 Hided the form names on the DFA screen tabs 

that are associated with a Non-DFA screen. 

Dynamic Forms (DFA) 

65 Core Bugs # 
132956 

Client MAR: Additional Schedules were created 
when the Dispense Time is changed in the Order 
Template Frequency. 

e(MAR) 

66 Core Bugs # 
133114 

Client MAR: Editing Administration Times 
removes the current scheduled dose from screen. 

e(MAR) 

67 Core Bugs # 
133059 An incorrect ‘Document Name’ displayed when 

opening ‘Linked Document’ from ‘Flag Alert’ Pop-
Up window. 

Flag Alert Popup 

68 Core Bugs # 
132919 Flow Sheet screen – Slowness issues in loading 

the data. 

Flow Sheet 

70 Core Bugs # 
133013 The ‘Code Name’ of ‘MARITALSTATUS’ global 

code category is not sorted based on the value of 
‘Sort Order’. 

Global Code Category 

71 Core Bugs # 
132863 In the PDF of ‘Government Performance and 

Results Act Outcome Measure’ document, the 
‘Opioid’ section items were displayed in ‘Alcohol’ 
section. 

Government Performance and 
Results Act (GPRA) Document 

72 Core Bugs # 
132879 Group Service - Dropdown cuts off selections 

Group Details 

73 Core Bugs # 
133086 

Custom Fields dropdowns in Group Notes carry 
over the selected value between clients. 

Group Services 
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74 Core Bugs # 
133038 

When the ‘Primary Clinician’ is changed in the 
‘Groups’, the update did not reflected in the 
‘Future Group service Documents’. 

Group Services 

75 Core Bugs # 
132661 

Group Services – Implemented a new Information 
message when Group Services with a balance are 
set to Error. 

Group Services 

76 Core Bugs # 
133093 Group Services – In the Client Note tab for the 

dropdown fields, the tab off was not working. 

Group Services 

77 Core Bugs # 
132914 

Added an index to the Inquiries table. Inquiry Details 

78 Core Bugs # 
132612 

Performance issue observed while opening 
Inquiry Details screen from unsaved changes 

Inquiry Details 

79 Core Bugs # 
132901 

Staff's Licenses / Degrees tab inconsistent 
response from system 

Manage Staff 

80 Core Bugs # 
132981 

Client Search option disappeared when clicking 
on ‘Client search’ icon after merging two clients. 

Manage Clients 

81 Core Bugs # 
133064 

Navigating to Messages screen through unsaved 
changes affected the Reply functionality. 

Message (My Office) 

82 Core Bugs # 
132780 

MAT: When the Frequency Time was changed, 
duplicate MAT records were created. 

Methadone 

83 Core Bugs # 
132774 MAT Management list page - Unable to Place a 

Backdated Client Order for MAT Dispensing. 

Methadone 

84 Core Bugs # 
132979 

MAT Management Details: MAR Details Popup is 
not displayed on click of ‘Dispensed Date & Time’ 
hyperlink from the ‘Dispense and No Show History 
grid’. 

Methadone 

89 Cire Bugs # 
132753 MAT: The Patient Safety Acknowledgement 

popup message is displayed only once for the re-
dispense. 

Methadone 

92 Core Bugs # 
133024 

Updates to Appointments made through Service 
Detail are not reflected on Staff Calendar. 

My Calendar 

94 Core Bugs # 
133019 

Documents cannot be added from the Associate 
Documents pop-up if the associated Program 
code contains single quotes ('). 

My Documents List Page 

95 Core Bugs # 
132953 ER Claim Lines: Duplicate Payment Rows 

My Reports 
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97 Core Bugs # 
132933 The Aging Report is loaded without displaying the 

relevant data. 

My Reports 

98 Core Bugs # 
133030 

My Reports: users are unable to filter reports for 
specific clients. 

My Reports 

99 Core Bugs # 
133096 

UDS Section E - BMI Output Label Change My Reports 

105 Core Bugs # 
133025 

Unable to run ‘Staff Client Access Tracking’ 
report. 

My Reports 

108 Core Bugs # 
132998 

The results of Peer Record Reviews always 
shows 'Acceptable', despite the user's selection of 
'No'. 

Peer Record Reviews 

110 Core Bugs # 
133050 

The ‘Primary Care Appointments’ continued to 
appear in ‘SmartView’ even after being cancelled 
or marked as errors. 

Primary Care 

112 Core Bugs # 
132959 

The ‘Assigned Staff’ name displaying issue on the 
‘Program Assignment Details’ page. 

Programs 

113 Core Bugs # 
131611 

Program Assignments: SmartCare allows 
Discharge dates to be removed from prior Client 
Program Enrollments when there is an existing 
enrollment for the same program 

Programs 

118 Core Bugs # 
132894 

Misspelling in the ‘Free- Text Sig’ Pop up for 
Patches and Suppositories 

Rx Application 

119 Core Bugs # 
133099 

‘ServiceUnits' column is missing in exported excel. Services 

120 Core Bugs # 
132954 

New configuration is added to show or hide 
‘ServiceUnits’ column in Export excel file. 

Services 

134 Core Bugs # 
133054 

System Not Validating Expired Passwords 
Correctly 

SmartCare Improvements 

135 Core Bugs # 
133098 

Users cannot login to the application SmartCare Improvements 

136 Core Bugs # 
133018 Programs in Staff Calendar are not sorting 

alphabetically 

Staff Calendar 
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Functionality Task Details 

Authentication/Authorization (Login, Logout) 

Reference No Task No Description 

2 Core Bugs # 132995 
Users can still continue and successfully log into their account 
even when the account is set to "Can't Login" 

Core Bugs # 132995: Users can still continue and successfully log into their account 
even when the account is set to "Can't Login" 

What’s Fixed: 

We resolved an issue that allowed users to log in even after their account was marked as “Can’t Login” 
due to incorrect answers to security questions. 

With this fix, the system now takes the following actions when a user provides incorrect answers on their 
third attempt: 

• Logs the user out immediately 

• Displays the message: 
“Your account is disabled. Please contact the system administrator.” 

• Locks (disables) the account to prevent further access 
 

Where to Find It: 
SmartCare Login page 

Authorizations 

Reference No Task No Description 

3 Core Bugs # 133078 
Service Detail: The billing rule was incorrectly applied to date of 
services. 

4 Core Bugs # 133047 In Service Detail, proper conversion was not happening even 
when the unit types were different, for example, between 
minutes and hours 

5 Core Bugs # 132711 Authorizations: The system does not show an error when the 
‘PM authorization units’ used exceed the authorized limit. 

Core Bugs # 133078: Service Detail: The billing rule was incorrectly applied to date of 
services 

What’s Fixed: 

We fixed an issue where the system incorrectly applied billing rules to service dates outside the 
configured StartDate and EndDate range on the Service Detail page. This caused inaccurate billing 
validation and processing. 
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With this update, the system now applies billing rules only when the service date falls within the defined 
date range, ensuring accurate and reliable billing behavior. 

Where to Find It: 

Path: 

1. Select Client 
2. Go to Services (Client) 
3. On the Services list page, click New or select any Date of Service (DOS) hyperlink 

• This opens the Service Detail page 

Prerequisite: 

• The plan must exist with both StartDate and EndDate defined for the rule 

• These programs require authorization for the specified codes 

 

Core Bugs # 133047: In Service Detail, proper conversion was not happening even when 
the unit types were different, for example, between minutes and hours 

What’s Fixed: 

We fixed an issue where the system failed to convert units correctly on the Service Detail page when 
services and authorization codes used different unit types—such as hours versus minutes. This mismatch 
caused incorrect or failed authorization attachments, even when valid units were entered. 

With this update, the system now accurately converts between unit types (e.g., minutes to hours), 
ensuring proper authorization matching and improving billing reliability. 

Where to Find It: 

Path: 

1. Select any Client 
2. Go to Services (Client) 
3. On the Services list page, click New or select any Date of Service (DOS) hyperlink 

• This opens the Service Detail page 

Prerequisite: 

Ensure that services and authorization codes use the same unit type (either hours or minutes) 

Core Bugs # 132711: Authorizations: The system does not show an error when the ‘PM 
authorization units’ used exceed the authorized limit 

What’s Fixed: 

We fixed an issue in the Authorizations module that allowed users to attach services even when the PM 
authorization units exceeded the allowed limit. The system didn’t show any warnings, and it didn’t adjust 
unit balances correctly when services were removed or their status changed. 

Now, the system checks authorization units before attaching services. If the units aren’t available, it 
shows an error message. It also automatically updates unit balances when a service is removed or its 
status changes to anything other than Scheduled, Show, or Completed—ensuring accurate tracking. 

Where to Find It: 

Pre-requisite: 
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Ensure valid service and authorization records exist with defined unit values. 

Path 1: 

1. Client → Search → Select any client 
2. Services → Services list page → Click New or select any DOS hyperlink 
3. Service Detail page 

Path 2: 

1. My Office → Authorizations → Authorizations list page → Click on ID hyperlink 

Path 3: 

1. Client → Search → Select client 
2. Authorizations → Click New or click on ID hyperlink → Authorization Detail page 

Validation Messages: 

• Authorization Details Screen → Services sub-tab → Associate Auth with Other Services... 

Message: 

"Unable to attach service(s) to the authorization as the service units for selected service(s) exceeds the 
authorization units available." 

• Service Details Page → Authorization(s) sub-tab → Attach button 

Message: 

"Unable to attach selected authorization to the service as service units exceeds the authorization units 
available." 
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Batch Eligibility 

Reference No Task No Description 

6 Core Bugs #133070 The Batch Eligibility Change Review report incorrectly displays 
a plan as active, even though it is inactive on the Medicaid 
website. 

Core Bugs # 133070: The Batch Eligibility Change Review report incorrectly displays a 
plan as active, even though it is inactive on the Medicaid website 

What’s Fixed: 

We fixed an issue in the Batch Eligibility Change Review report that incorrectly showed a plan as 
active, even though it was inactive according to the Medicaid website. The system was using service 
dates from the wrong ID (291) in the 271 response, which caused inaccurate plan status reporting. 

Now, the updated stored procedure 
ssp_SCUpdateElectronicEligibilityData_ResponseCoveragePlans ignores dates from ID 291. This 

ensures the report uses only valid service dates and correctly shows whether a plan is active or inactive. 

Where to Find It: 

My Reports → Batch Eligibility Change Review Report 

Batch Service Import 

Reference No Task No Description 

7 Core Bugs # 132908 
Batch Service Import Failing 

Core Bugs # 132908: Batch Service Import Failing 

What’s Fixed: 

We fixed an issue in the Batch Service Scheduler where the system failed to process services correctly 
if the procedure codes used units other than Minutes, Hours, or Days. This caused file imports to fail and 
prevented service records from being created. 

Now, the system properly handles non-standard units during batch imports. It processes files 
successfully and creates service records as expected, regardless of the unit type. 

Where to Find It: 

Path: 

1. My Office → Batch Service Import file 
2. Click Upload Import File 
3. Select the file to upload → Click Upload 

 

Bed Census 
Reference No Task No Description 
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10 Core Bugs # 132968 
Bed Census screen: when the user clicks the ‘Status’ 
dropdown, the ‘Status’ dropdown disappears as soon as the 
mouse is moved. 

Core Bugs # 132968: Bed Census screen: when the user clicks the ‘Status’ dropdown, 
the ‘Status’ dropdown disappears as soon as the mouse is moved 

What’s Fixed: 

We fixed an issue in the Bed Census screen that caused the Status dropdown to disappear as soon as 
users moved their mouse, preventing them from selecting the Admit option and disrupting the client 
admission workflow. 

Now, the Status dropdown stays visible, allowing users to select a value and complete the admission 
process without interruption. 

Where to Find It: 
My Office → Bed Census (Quicklinks) → Bed Census List page → Status dropdown → Select 
“Admit” → Client Search popup → Select Client → Census Management → Admit screen → Admit 
Client → Save and Close 

Bundle Services 

Reference No Task No Description 

11 Core Bugs # 132530 Bundle Code Units incorrectly calculated 

 

Core Bugs # 132530: Bundle Code Units incorrectly calculated 

What’s Fixed: 

We fixed an issue where the system incorrectly calculated Bundle Code service units during the bundle 
service job. The units didn’t align with the primary service units, which led to inaccurate tracking. 

Now, the system correctly calculates Bundle Code service units in sync with the primary service units 
whenever the bundle service job runs, ensuring accurate and consistent unit allocation.  

Where to Find It: 

Pre-requisite: 

• Set the configuration key EnableJobToAutomateBundledServices = Yes 

Path 1: 

• Procedure/Rates quick link → Administration → Click New 

• Procedure Code Detail page → Enter required details → Save 

• Click Bundle Codes tab → Select “Daily” from Frequency dropdown 

• Select required Procedure from list → Save 

Path 2: 

• My Office → Services quick link → Click New 
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• Service Detail page → Enter required details → Save 

 

CCBHC 

Reference No Task No Description 

12 Core Bugs # 132987 
ISERV2 Numerator, Denominator, and Average Time are 
displayed in hours. 

Core Bugs # 132987: ISERV2 Numerator, Denominator, and Average Time are displayed 
in hours 

What’s Fixed: 

We fixed an issue in the ISERV2 Clinical Quality Measure Results section where the system incorrectly 
displayed the Numerator, Denominator, and Average Time fields in hours instead of days, which 
caused confusion when interpreting results. 

Now, the system correctly displays these fields in days, ensuring accurate and clear representation of 
ISERV2 metrics on the Clinical Quality Measure Results Detail screen. 

Where to Find It: 

Pre-requisite: 

A new batch must be created, including a batch for ISERV2. 

Path: 

1. My Office → Clinical Quality Measure Batch Results 
2. Click on Measure Name hyperlink for ISERV2 
3. ISERV Clinical Quality Measure Results Detail screen → ISERV2 Clinical Quality Measure 

Results section 

 

Charges/Claims 

Reference No Task No Description 

19 Core Bugs # 132902 
Claims data missing for void claims - Claims generation error 

20 Core Bugs # 129565 Charge Status for voided charges was not correctly updated to 
“Void” in the Revenue Work Queue Management section’s 
Charge Status dropdown 

22 Core Bugs # 132937 Segment count mismatch in void claim file. 

Core Bugs # 132902: Claims data missing for void claims - Claims generation error 

What’s Fixed: 
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Previously, when users attempted to generate void claims using the 837 Professional format, the system 
We fixed an issue that prevented users from generating void claims using the 837 Professional format. 
The system previously displayed the error message: 

 “To Be Voided claim missing claim data. Please contact system administrator.” 

 This disrupted billing workflows and blocked claim creation. 

Now, the system correctly processes void claims without triggering errors. Users can follow the standard 
steps to bill voided claims, and the necessary claim data is included as expected. 

Note: This fix applies only to 837 Professional claim files. 

Where to Find It: 

Path 1: 

1. My Office → Charges/Claims quick link 
2. Select Charge ID → Click E-Claim icon → Bill the charge 
3. Close Claim Processing popup → Select billed Charge ID 
4. Select Action dropdown → Mark Claim Line To Be Voided → Click OK 
5. Click ClaimLine Item ID hyperlink → Claim Line Item Detail screen 
6. Enter Payer Claim Number in Claim Details tab → Save 
7. Go to Charges/Claims → Select same Charge ID → Click E-Claim 
8. Click Process Now → Create Claim File → Save As 
9. Uncheck “Created Correctly” checkbox → Close popups 
10. Select same Charge ID → Click E-Claim → Process Now → Create Claim File → Save As 

Path 2 (Alternate): 

1. Follow steps 1–8 from Path 1 
2. Uncheck “Created Correctly” checkbox → Close Claim File Creation popup 
3. Select batch from dropdown → Click Delete Batch → Close popup 
4. Select same Charge ID → Click E-Claim → Process Now 

 

Core Bugs # 129565: Charge Status for voided charges was not correctly updated to 
“Void” in the Revenue Work Queue Management section’s Charge Status dropdown 

What’s Fixed: 

We fixed an issue where the system didn’t update the Charge Status to “Void” in the Revenue Work 
Queue Management section when users voided a claim using the Mark Claim Line To Be Voided 
option. This made it hard to track the true status of voided charges and caused confusion during billing 
follow-up. 

Now, the system correctly updates the Charge Status to “Void” when a claim is marked as voided. It also 
updates the status appropriately if the charge is re-billed or partially paid, ensuring accurate tracking. 

Where to Find It: 

Path:  

1. My Office → Charges/Claims → Select a charge → Click the E-Claim icon → Bill the charge 
2. In the Charges/Claims list, select the same charge → Use Select Action → Choose Mark 

Claim Line To Be Voided → Confirm 
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3. Click the Claim Line Item ID hyperlink → Enter the Payer Claim Number in the Claim Details 
tab → Save 

4. Return to Charges/Claims → Select the charge again → Click E-Claim to re-bill if needed 
5. Open the Charge Details screen → In the Revenue Work Queue Management section, verify 

the Charge Status dropdown reflects the correct status (e.g., Void, Claim Sent, Partially Paid) 

Example Status Flow: 

• Service Created → Status: Charge Created 

• Billed → Status: Claim Sent 

• Marked as Voided → Status: Void 

• Re-billed → Status: Claim Sent 

• Partial Payment Applied → Status: Partially Paid 

• Marked as Voided Again → Status: Void 

• Re-billed Again → Status: Partially Paid 

Note: This logic applies only to Void 837P and HCFA 1500 claims. 

Core Bugs # 132937: Segment count mismatch in void claim file 

What’s Fixed: 

We fixed an issue where the system incorrectly calculated the segment count in the SE segment when 
generating a void claim file. It added +1 to the actual count, causing a mismatch that could lead to 
validation or submission errors. 

Now, the system calculates the SE segment count correctly when creating a void claim file, ensuring 
accurate and compliant claim file generation. 

Where to Find It: 

Pre-requisite: 

Select a client, complete a service, and create a claim file. 

Path: 

1. My Office → Charges and Claims → Select Charge 
2. Click on Claim Line Item ID → Claim Line Item Detail screen 
3. Check “To be voided” checkbox → Add Payer Claim Number under Claim Details tab 
4. Navigate back to My Office → Charges and Claims → Select Charge 
5. Click Electronic Claim button → Claims Processing popup → Click Process Now to create the 

claim file 

 

Client Document List Page 

Reference No Task No Description 

28 Core Bugs # 133043 
Performance issue in Client ‘Documents’ screen 

Core Bugs # 133043: Performance issue in Client ‘Documents’ screen 

We improved the Documents screen in the Client module to resolve performance issues. Previously, the 
page took longer than expected to load, which slowed down workflows and impacted usability. 
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Now, the system loads data efficiently without delays, providing a smoother and faster user experience. 

Where to Find It: 

Path: 

Client → Documents → Documents list page 

Client eMAR 

Reference No Task No Description 

29 Core Bugs # 133063 Client MAR: Administration Events not functioning as expected 
for MAT Take home medications 

Core Bugs # 133063: Client MAR: Administration Events not functioning as expected for 
MAT Take home medications 

What’s Fixed: 

We resolved a critical issue in the Client MAR screen where MAT Take Home medications didn’t 
display split doses for Face-to-Face and Take Home administrations as separate entries. Icons were 
also missing, making it hard to track and manage these doses. 

With this fix, the system now: 

Adds Validation Messages: 

• When signing an MAT order with a question at administration or a Standing Administered Once 
schedule: 

•  “[Order Name] - MAT orders are not allowed to have questions that need to be answered during 
the administration. Please modify the Order Setup or choose a different order.” 

• When signing an MAT order with a Standing Administered Once schedule: 

  “[Order Name] - Standing Administered Once is not allowed for MAT Orders.” 

• When DualSignRequired is enabled for an MAT order: 

  “[Order Name] - MAT orders are not allowed to have DualSignRequired option enabled. 
Please modify in the Order Setup or choose a different order.” 

Improves Visual Tracking: 

• Displays the capsule icon for MAT medications both inside and outside the administration 
window 

• Adds a new status: “Received Take Home” in the administration popup dropdown for MAT 
medications 

 

Where to Find It: 

Path 1: 

1. Go to Administration → Orders 
2. Click New → Fill required fields 
3. Select Medication Order Type 
4. Choose Standing Administered Once under Schedule 
5. Set MAT, Machine Connection Required, and Take Home Allowed to Yes 
6. Enable DualSignRequired 
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7. Select Administration under Questions → Save 

Path 2: 

1. Go to My Office → Medication/Lot/Bottle list page 
2. Click New → Fill required fields → Enter Location → Insert → Save 

Path 3: 

1. Go to Client → Client Orders 
2. Click New → Select the created order 
3. Fill required fields → Select Take Home days → Choose Program → Insert → Save → Sign 

Path 4: 

1. Go to Search → MAT Management (My Office) 
2. Click Dispense icon for required medication 
3. Dispense Face-to-Face and Take Home doses 

Path 5: 

Go to Client → Client MAR 

Client Flags 

Reference No Task No Description 

62 Core Bugs # 133039 ‘Client Flag Details’ screen: Level Global Code drop-down is not 
honoring SortOrder. 

Core Bugs #133039: ‘Client Flag Details’ screen: Level Global Code drop-down is not 
honoring SortOrder 

What’s Fixed: 

The system previously displayed the “Level” drop-down options on the Client Flag Details and Flag Type 
Details screens in alphabetical order, ignoring the custom SortOrder defined in the Global Codes under 
the category CLIENTNOTELEVEL. 

Now, the system correctly displays the Level drop-down options according to the defined SortOrder in the 
Global Codes. 

Where to Find It: 

• Administration → Global Codes → Global Codes list page 

 Select category: CLIENTNOTELEVEL → Modify/Add SortOrder → Save 

• Client → Client Flags → Client Flags list page 

 Click on New → Client Flag Details screen → Level drop-down 

• My Office → Client Flags → Client Flags list page 

 Click on New → Client Flag Details screen → Level drop-down 

• My Office → Patient Lists/Reminders 

 Select client → Action Dropdown: Create Client Flag → Flag Details Popup → Level 
drop-down 

• Administration → Flag Types 

 Select existing flag or click New → Flag Type Details screen → Level drop-down 

 

Client Orders 
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Reference No Task No Description 

33 Core Bugs # 132921 
Duplicate Lab Results are displayed in the ‘Lab Results Review’ 
screen. 

34 Core Bugs # 132745 Client Orders: In the ‘Discontinued Titration Orders’ PDF, the 
end time is not displayed. 

35 Core Bugs # 132746 Client Orders: Inconsistent display of A/F/I next to the 
medication name and in grid. 

36 Core Bugs # 132963 The Order Name Display Format on Client Order List Page is 
updated. 

37 Core Bugs # 132988 Services: Service Not Being Created from Lab Order 

38 Core Bugs # 133009 Medications List Page: When the user clicks the ‘Export’ icon, 
the data is not being exported. 

39 Core Bugs # 133121 Allergy Flag (A/F/I) not displaying next to the medication name 
in the Order Set tab of the Client Order Screen, even if the 
medication was marked as an allergy. 

Core Bugs # 132921: Duplicate Lab Results are displayed in the ‘Lab Results Review’ 
screen 

What’s Fixed: 

The Lab Results Review screen previously displayed duplicate lab results when users added multiple 
attachments to a lab order in the Attachments tab of the Client Order Details screen. Now, the screen 
correctly displays each lab result only once, even if users add multiple attachments to the order. 

Where to Find It: 

Path 1: 

Administration → Orders → Orders list → New → Select "Lab" from Order Type → Enter required 
fields → Save 

Path 2: 

Client → Client Orders → New → Select the Lab Order created in Path 1 → Enter required fields 
 → Insert → Save/Sign 

Path 3: 

Client → Client Orders → Select the Lab Order → Lab Results tab → Add lab results → Save 

Path 4: 

Client → Client Orders → Select the Lab Order → Attachment tab → Add attachments → Save 

Path 5: 

Client → Lab Results Review → Lab Results Review screen 
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Core Bugs # 132745: Client Orders: In the ‘Discontinued Titration Orders’ PDF, the end 
time is not displayed 

What’s Fixed: 

We resolved an issue where the PDF for Discontinued Titration Orders did not display the End Time. 
Previously, the End Date Time appeared correctly for the first step, but only the End Date was shown for 
the second step, resulting in incomplete documentation. 

With this fix, the PDF now correctly displays the End Date Time for all steps when a Titration Order is 
discontinued, ensuring complete and accurate time tracking. 

Where to Find It: 

Path 1: 

1. Go to Search → Client Orders (Client) 
2. Click on New icon 
3. Fill in required details → Sign 

Path 2: 

1. Go to My Client → Client Orders (Client) 
2. Click on New icon 
3. Select the created order → Discontinue → PDF 

 

Core Bugs # 132746: Client Orders: Inconsistent display of A/F/I next to the medication 
name and in grid 

What’s Fixed: 

We corrected an issue in the Client Order Details screen where the flags for Allergy (A), Intolerance (I), 
and Failed Trial (F) were not consistently displayed next to medication names or within the grid across the 
Order, Order Set, and Preference tabs. This inconsistency impacted visibility and acknowledgment 
workflows. 

With this update, the A/I/F flags now reliably appear next to the corresponding medications and within the 
grid upon insertion. For medications marked as Complete or Discontinued, the flags no longer appear 
under the Interaction column, and acknowledgment validations are no longer triggered. 

Pre-requisites: 

1. Add Allergy, Intolerance, and Failed Trial medications to the Order Sets. 
2. Add the same medications to the client via Client Allergies. 

Where to Find It: 

Path: 

1. Client → Go Search → Client Orders → New 
2. Client Order Details → Order Set tab → Search and select Allergy Medication Order Set 
3. Enter all required fields → Insert → Save → Sign 

 

Core Bugs # 132963: The Order Name Display Format on Client Order List Page is 
updated 
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What’s Fixed: 

We updated the medication order naming format to resolve confusion that occurred when the strength 
was a number and the dosage description was set to Tablet or Capsule. Previously, the order name 
appeared in a format like: 

Acetylcysteine CAP 500*30 MG 

This format combined strength and dose in a way that could be misinterpreted. 

With this update, the order name now displays clearly and consistently as: 

Acetylcysteine CAP 30MG 

Where to Find It: 

Path 1: 

Administration → Orders → Orders list → New → Select "Medication" as Order Type → Enter 
numeric strength and select Tablet/Capsule → Save 

Path 2: 

Client → Client Orders → New → Select the order created in Path 1 → Enter required fields →  Insert 
→ Save/Sign 

Path 3: 

Client → Client Orders → Client Orders list → View updated order name in the Name column 

Path 4: 

Client → Client Orders → New icon → Client Order Selection popup → View updated format  in the 
Order column 

Path 5: 

Client → Orders (My Office) → View updated format in the Order column 

Core Bugs # 132988: Services: Service Not Being Created from Lab Order 

What’s Fixed: 

We fixed an issue where the system failed to create services from Lab Orders, even after users signed 
the Client Order. This problem disrupted workflows and prevented expected service records from being 
generated for lab-related procedures. 

With this fix, the system now correctly creates services for signed Client Orders where the Order Type is 
set to Lab, ensuring proper linkage between lab orders and service records. 

Where to Find It: 

Path 1: 

1. Administration → Procedure/Rates → Procedure/Rates list page → New 
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2. Procedure Code Details screen → Select “Order Procedure Code” checkbox 
3. Uncheck “This code is not billable” → Enter required fields → Save 

Path 2: 

1. Administration → Orders → Orders list page → New 
2. Order Details screen → Select “Lab” as Order Type 
3. Enter Procedure Code → Select “Yes” for Billable and Display Program → Enter required 

fields → Save 

Path 3: 

1. Client → Client Orders → Client Orders list page → New 
2. Client Order Details screen → Select the Lab Order created above 
3. Enter required fields → Insert → Save → Sign 

Path 4: 

Client → Services → Services list page 

Core Bugs # 133009: Medications List Page: When the user clicks the ‘Export’ icon, the 
data is not being exported 

What’s Fixed: 

We fixed an issue where clicking the Export icon on the Medications List page did not trigger a download, 
preventing users from saving or sharing medication records outside the system. 

With this update, clicking the Export icon now successfully generates and downloads the medication data 
in Excel format, as expected. 

Where to Find It: 

Path: 
Client → Search and select a client → Medication → Medications List page → Click the Export icon 
 

Core Bugs # 133121: Allergy Flag (A/F/I) not displaying next to the medication name in 
the Order Set tab of the Client Order Screen, even if the medication was marked as an 
allergy 

What’s Fixed: 

We resolved an issue where the Allergy Flag (A/F/I) did not appear next to the medication name in the 
Order Set tab of the Client Order screen, even when the medication was marked as an allergy. 

With this fix, the Allergy Flag now correctly appears when users select the Set Default button and enable 
the Enable Default checkbox, or when they modify medication attributes with Enable Default enabled 
during Order Set creation. 

Where to Find It: 

Path 1: 
Client → Client Allergies → Enter medication in Current Medication section → Save → Open Rx → 
Prescribe medication → Medication Reconciliation → Sign 

Path 2: 
Search → Order Sets → Search medication → Save → Select Enable Default checkbox → Click 
Default → Enter required details → Save 



SmartCare Release Notes  

      

 

Path 3: 
Client → Client Orders → New → Client Orders Details → Order Set tab → Search for created Order 
Set 

 

Client Search Popup 

Reference No Task No Description 

40 Core Bugs # 132912 
All Client Search - The Staff is able to see restricted clients for 
‘Broad search’ but once after ‘All Client Search’ button is 
clicked. 

Core Bugs #132912: All Client Search - The Staff is able to see restricted clients for 
‘Broad search’ but once after ‘All Client Search’ button is clicked 

What’s Fixed: 

We fixed an issue that allowed staff with restricted client access permissions to view restricted clients 
during a Broad Search after clicking the All Client Search button. This behavior violated access control 
rules and exposed sensitive client data to unauthorized staff. 

With this update, the system now consistently enforces access restrictions. Staff can no longer view 
restricted clients during Broad Search, regardless of whether they click the All Client Search button. Only 
clients permitted under the configured access rules are visible. 

Where to Find It: 

Pre-requisite: 

1. Go Search → Administration → Staff/User → Select required staff 
2. Staff Details screen → Roles/Permissions tab 
3. Select “Client Access Rules” in Permission Type dropdown 
4. Grant permission only for “Clinician in Program which Shares the Client” 
5. Deny all other Client Access Rule permission items 

Path: 

1. Client → Client Search popup 
2. Enter First Name, Last Name, SSN, DOB → Click All Client Search button 
3. Click Broad Search button 

 

Clinical Documentation 

Reference No Task No Description 

42 Core Bugs # 130046 
Initialization Editor: On Save the Validation message for 
'Generate Query' is not displayed consistently. 

Core Bugs # 130046: Initialization Editor: On Save the Validation message for 'Generate 
Query' is not displayed consistently 



SmartCare Release Notes  

      

 

What’s Fixed: 

We resolved an issue where the 'Generate Query' validation message did not consistently appear on the 
Initialization Editor screen after users clicked Save. This inconsistency prevented the system from 
generating the query in the Preview tab, even when users completed the required table and column 
mappings. 

With this fix, once users complete the necessary mappings and click Save, the system reliably generates 
the query in the Preview tab. If users make no changes to the mappings, the system displays the 
previously saved or generated query without regenerating it. 

Where to Find It: 

Path: 

1. Go to Administrator 
2. Search for Initialization 
3. On the Initialization list page, click the New icon 

• This opens the Initialization Editor screen 

 

CM Events 

Reference No Task No Description 

44 Core Bugs # 132723 Enrollment Form Event: Saving twice on the Upload Image 
Details screen deletes the Event records. 

Core Bugs # 132723: Enrollment Form Event: Saving twice on the Upload Image Details 
screen deletes the Event records 

What’s Fixed: 

We resolved a customer-specific issue where saving twice on the Upload Image Details screen within an 
Enrollment Form Event caused the system to soft delete the associated Document and Document 
Version records from the database. This deletion made the event inaccessible from the list page. 

With this fix, saving twice no longer deletes event records. The system now correctly passes the 
DocumentCodeId to the Record Type field when users navigate from the Enrollment Form Event. The 
field remains disabled to ensure the correct value is used automatically, preventing manual errors and 
preserving event accessibility. 

Where to Find It: 

Path: 

1. Go to Client → CM Events 
2. Select event type: Enrollment Form Event 
3. Set status to In-Progress, Insurer, or Provider 
4. Click on Note tab → Save 
5. Click on Attachments tab → Upload → Image Upload → Select → Upload → Save twice 

Note: 

This issue was customer-specific 

Core Assessment 
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Reference No Task No Description 

45 Core Bugs # 133186 
Psychosocial Adult/Child List Medication field length 

Core Bugs # 133186: Psychosocial Adult/Child List Medication field length 

What’s Fixed: 

We resolved an issue in the Assessments (C) document under the Psychosocial Adult/Child tab where 
the Medication Name field in the List of Medications section was limited to 11 characters. This 
restriction prevented users from entering full medication names, which impacted documentation accuracy. 

With this fix, users can now enter more than 11 characters in the Medication Name field, allowing for 
complete and accurate medication entries. 

Where to Find It: 

Path: 

1. Client → Assessments (C) document 
2. Select required input to display Psychosocial Adult/Child tab 
3. Medication section → Select List of Medication radio button 
4. Add required details → Save → Sign 

 

Crisis Call Log Details 

Reference No Task No Description 

47 Core Bugs # 133029 
Crisis Call Log screen: when the status is completed, users are 
unable to read the entire contents from Text area. 

Core Bugs # 133029: Crisis Call Log screen: when the status is completed, users are 
unable to read the entire contents from Text area 

What’s Fixed: 

We resolved an issue on the Crisis Call Log screen where users couldn’t view the full contents of the 
Crisis Information text area after setting the status to Complete. The system disabled all fields upon 
completion, which restricted visibility of the entered text. 

With this fix, users can now view the entire text in the Crisis Information section, even when the status is 
marked as Complete. 

Where to Find It: 
My Office → Crisis Call Log (My Office) → New → Crisis Call Log Details → Client Information 
(Potential) 

Documents 

Reference No Task No Description 
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48 Core Bugs # 132520 
CAFAS standalone connection issues with FAS 

50 Core Bugs # 132938 ISP document: Initialization issue 

51 Core Bugs # 132586 Spellcheck not working in Standard Mental Status Exam 

52 Core Bugs # 132878 Incorrect Signature Details Displayed for Version Author 

54 Core Bugs # 133008 When right-clicking a misspelled word, the previously typed text 
disappears. 

56 Core Bugs # 133046 Significant Issue with the ‘Individualized Service Plan’ 
document. 

57 Core Bugs # 133156 Goals/Objectives tab - Objective text boxes cut off 

59 Core Bugs # 132438 Getting an error while clicking on “Go to Online Cafas" and 
"Import CAFAS Scores" in the ‘CAFAS Standalone’. 

60 Core Bugs # 132804 Error message displayed in Services/Notes screen when ‘DLA - 
SUD’ document has been incorporated as associated note. 

61 Core Bugs # 133060 Performance issue in ‘Agency/Program Discharge’ document 
when client with more than 10 enrolled programs. 

62 Core Bugs # 132960 Medications being discontinued 

63 Core Bugs # 133143 Issues with “Medication Reconciliation” Document Functionality 

Core Bugs # 132520: CAFAS standalone connection issues with FAS  

We resolved an issue that caused connection errors when users tried to access CAFAS Online or import 
scores from FAS within a standalone CAFAS document. The system displayed the following error 
message: 

"Unable to find CAFAS for the current client; please go to online CAFAS." 

This disrupted workflows and prevented users from completing CAFAS assessments efficiently. 

With this fix, users can now successfully access Online CAFAS and import scores without encountering 
error messages, ensuring a smoother and more reliable experience. 

Where to Find It: 

Path: 

1. Open Client 
2. Create or open a New CAFAS document 
3. Click on Go to Online CAFAS or Import CAFAS Scores 

 

Core Bugs # 132938: ISP document: Initialization issue 

What’s Fixed: 
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We resolved an issue in the Individualized Service Plan (ISP) document where certain fields failed to 
initialize correctly when users created a new ISP based on a previously signed one. This occurred when a 
DFA tab was mapped to the ISP document, resulting in missing data across multiple tabs. 

With this fix, the system now correctly initializes the following fields from the previously signed ISP into 
the new document: 

• General Tab  
o Strength 
o Transition/Level of Care/Discharge Plan section 

• Needs Tab  
o Deferral Reason 

• Interventions Tab  
o Details within each checked intervention 

• Supports/Treatment Program Tab  
o Review Dates Comments 

This update ensures continuity and accuracy when users create new ISP documents. 

Pre-requisite: 

Ensure a DFA tab is mapped to the ISP document. 

Where to Find It: 

Path: 

1. Create a Client 
2. Navigate to Individualized Service Plan (Client) 
3. Enter all required fields across tabs → Sign the document 
4. Click New → Verify data initialization from the previously signed ISP document 

 

Core Bugs # 132586: Spellcheck not working in Standard Mental Status Exam 

We fixed an issue on the Mental Status Exam screen where the spell checker pop-up failed to appear, 
making it difficult for users to catch and correct spelling errors during documentation. 

With this update, the spell checker now displays correctly and functions as intended. 

Where to Find It: 

Path: 
Login → Quick Search → Select Client → Mental Status Exam 

Core Bugs # 132878: Incorrect Signature Details Displayed for Version Author 

What’s Fixed: 

We resolved an issue where the system incorrectly displayed the original author's name in the signature 
details when users edited and signed a new version of a document. This occurred when the configuration 
DocumentSignaturesNoPassword = "Yes" and the database setting AllowVersionAuthortoSign = 
"Y" were enabled, resulting in inaccurate attribution. 
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With this fix, the system now correctly displays the current version author's name in the signature details. 
A conditional check ensures that when AllowVersionAuthortoSign = "Y", the system assigns the 
LoggedInUser as the SignerId during the signature update process. 

Pre-requisites: 

1. Set system configuration key: 

Login to SmartCare → Administration → Configuration Keys → 
DocumentSignaturesNoPassword = "Yes" 

2. Set database value: 

DocumentCode → AllowVersionAuthortoSign = "Y" 

Where to Find It: 

Path: 

1. Login to SmartCare application 
2. Client → Search for any document via Go Search 
3. Fill in all required details → Sign the document 
4. Login with a different author → Edit the signed document → Create a new version 

 

Core Bugs # 133008: When right-clicking a misspelled word, the previously typed text 
disappears 

What’s Fixed: 

Previously, when users entered text in the Goals/Objectives section of the Individual Service Plan 
(ISP) and used Microsoft Edge’s built-in spell check to correct a word, the entire text area would 
unexpectedly clear. This caused users to lose their typed content and revert to previously saved text. 

Users can now safely use Edge’s spell check feature without losing any of their work. The Objective text 
area retains all entered content, even after correcting spelling errors. 

Where to Find It: 

Path: 
Client → Search and select a client → Individual Service Plan → Goals/Objectives tab → Enter text → 
Save → Sign 

Core Bugs # 133046: Significant Issue with the ‘Individualized Service Plan’ document 

What’s Fixed: 

We fixed an issue where the DFA tab mapped to the Individualized Service Plan document was 
incorrectly replaced by the Cost tab. This happened because the system hid Tab IDs 6 (Medication) and 
7 (Cost) by default. Since the DFA tab was also assigned Tab ID 6, it was unintentionally hidden along 
with the Medication tab, leaving only the Cost tab visible. 

With this release, the system now uses Tab control names instead of hardcoded Tab IDs to manage 
visibility. This change ensures the DFA tab displays correctly when mapped to the Individualized Service 
Plan document, while the Medication and Cost tabs are shown or hidden based on their configuration. 

Prerequisite: 

The DFA tab must be mapped to the Individualized Service Plan document. 
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Where to Find It: 

• Administration → Document Codes → Search for ‘Care Plan’ → Apply Filter → 
Individualized Service Plan Details → Configurable Tabs → Uncheck ‘Medication’ and 
‘Cost’ 

• Create a Client → Navigate to Individualized Service Plan (Client) → Verify DFA tab is 
displayed correctly 

 

Core Bugs # 133156: Goals/Objectives tab - Objective text boxes cut off 

What’s Fixed: 

We fixed an issue in the Individualized Service Plan where the text boxes for Staff Supports / Service 
Details, Interventions, Client Actions, and Use of Natural Supports were cut off in the UI after users 
added an objective to a goal. The lack of a horizontal scroll option prevented users from viewing or 
entering the full text. 

With this update, all relevant text boxes in the Goals/Objectives tab are now fully visible, allowing users 
to view and enter complete information without any cutoff. 

Where to Find It: 

• Client Search → Individualized Service Plan (Client) → Goals/Objectives tab 

 

Core Bugs # 132438: Getting an error while clicking on “Go to Online Cafas" and "Import 
CAFAS Scores" in the ‘CAFAS Standalone’ 

What’s Fixed: 

We fixed an issue in the CAFAS Standalone document that caused an error when users clicked the Go 
to Online CAFAS or Import CAFAS Scores buttons. The system displayed the message: 

"Unable to find CAFAS for the current client, please go to online CAFAS." 

This error prevented users from accessing or importing CAFAS scores as intended. 

With this update, users can now successfully navigate to Online CAFAS and import scores without 
encountering any error messages. 

Where to Find It: 

Path: 

1. Client → CAFAS Standalone → CAFAS Standalone document 
2. Click Go to Online CAFAS button 
3. Click Import CAFAS Scores button 

 

Core Bugs # 132804: Error message displayed in Services/Notes screen when ‘DLA - 
SUD’ document has been incorporated as associated note 

What’s Fixed: 
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We resolved an issue on the Services/Notes screen where the system displayed an error message when 
users incorporated the DLA - SUD document as an Associated Note through a selected procedure 
code. This error prevented users from saving or signing the note successfully. 

With this fix, users can now Save, Validate, and Sign the Services/Notes screen without encountering 
errors when using the DLA - SUD document as an associated note. The system now correctly handles 
the dataset merge process, ensuring a smooth workflow and successful PDF generation. 

Where to Find It: 

Path: 

1. Go to Client → Services/Notes list page 
2. Click New 
3. Select a Program from the dropdown 
4. Choose a Procedure mapped to DLA - SUD as an Associated Note 
5. Select a Location 
6. Go to the Note tab → Fill required details → Click Save 
7. Complete remaining fields → Sign → PDF is generated 

 

Core Bugs # 133060: Performance issue in ‘Agency/Program Discharge’ document when 
client with more than 10 enrolled programs 

What’s Fixed: 

We fixed a performance issue in the Agency/Program Discharge document that occurred when users 
attempted to discharge clients enrolled in more than 10 programs. The screen loaded slowly and often 
displayed a “Page Unresponsive” popup, making it difficult to complete the discharge process. 

With this update, the document is now optimized for better performance. Users can successfully perform 
Program Discharge actions for clients with multiple program enrollments, sign the document, and 
generate the Agency/Program Discharge PDF without delays or system interruptions. 

Pre-requisite: 

Client must be enrolled in more than 10 programs via the Program Assignment screen. 

Where to Find It: 

Path: 

1. Client → Agency/Program Discharge → Agency/Program Discharge document 
2. Select Program Discharge radio button → Select Discharge for applicable programs 
3. Click Save → Click Validate 

 

Core Bugs # 132960: Medications being discontinued 

What’s Fixed: 

We resolved an issue in the Medication Reconciliation workflow that caused newly prescribed 
medications to be incorrectly discontinued when users failed to click the Refresh button before signing the 
document. These medications also did not appear in the Discontinued Medications section of the PDF. 

With this fix, the system now retains newly prescribed medications via Open Rx and correctly displays 
them in the PDF—even if users do not click the Refresh button before signing. 
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Where to Find It: 
Client → Medication Reconciliation → New → Select checkbox for required medication in Current 
Medication section → Save → Click Open Rx → Prescribe medication → Return to Medication 
Reconciliation → Sign 

Core Bugs # 133143: Issues with “Medication Reconciliation” Document Functionality 

What’s Fixed: 

We resolved an issue in the Medication Reconciliation document that caused incorrect behavior when 
users selected medications for discontinuation. The system was: 

• Automatically deselecting medications that users had selected 

• Automatically selecting medications that users had not chosen 

With this fix, users can now accurately select medications for discontinuation, and they can sign the 
document without encountering errors. 

Where to Find It: 
Client → Medication Reconciliation → New → Select checkbox for required medication in Current 
Medication section → Sign 
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Dynamic Forms (DFA) 

Reference No Task No Description 

64 Core Bugs # 132807 Hided the form names on the DFA screen tabs that are 
associated with a Non-DFA screen. 

Core Bugs # 132807: Hided the form names on the DFA screen tabs that are associated 
with a Non-DFA screen 

What’s Fixed: 

We resolved an issue where the system incorrectly displayed form names from Non-DFA Document 
screens on DFA form tabs. This caused confusion for users navigating documents that weren’t intended 
to show DFA-related forms. 

With this fix, the system now hides form names linked to Non-DFA screens from DFA form tabs, providing 
a cleaner and more accurate user interface. 

Where to Find It: 

Path: 

1. Login to SmartCare application 
2. Go to Client → Documents 
3. Select any document associated with a DFA form tab 

 

e(MAR) 

Reference No Task No Description 

65 Core Bugs # 132956 
Client MAR: Additional Schedules were created when the 
Dispense Time is changed in the Order Template Frequency. 

66 Core Bugs # 133114 Client MAR: Editing Administration Times removes the current 
scheduled dose from screen. 

Core Bugs # 132956: Client MAR: Additional Schedules were created when the Dispense 
Time is changed in the Order Template Frequency 

What’s Fixed: 

We resolved an issue where modifying the dispense time in the Order Template Frequency caused the 
nightly job ssp_CreateMARDetails to create additional MAR schedules in the Client MAR screen. This 
duplication occurred whether the change was made through the UI or via the primary synchronization 
process. 

The ssp_CreateMARDetails procedure now behaves as follows: 

• It updates MAR schedules to reflect the new dispense time from the Order Template Frequency. 

• It removes and recreates only future MAR dispenses using the updated time, ensuring accuracy 
and preventing duplication. 
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Prerequisites: 

1. Create a Non-PRN Frequency in the Order Template Frequency Details screen. 
2. Sign Client Orders using the frequency created in step 1. 

 

Where to Find It: 

• Client → Client MAR 

 

Core Bugs # 133114: Client MAR: Editing Administration Times removes the current 
scheduled dose from screen 

What’s Fixed: 

We resolved an issue where editing administration times in the Client MAR screen caused the current 
scheduled dose—indicated by the pill icon—to disappear. This happened even when users reverted to 
the default administration times, disrupting medication tracking. 

With this fix, the scheduled dose remains visible after users edit administration times, including when they 
revert to default settings. Additionally, we added a new information icon to the Dispense Time popup. 
When hovered over, it displays the message: 

"MAR Only: Past dispense times cannot be updated for today. Changes apply to future dispense times 
only." 

Prerequisites: 

1. A Non-PRN Frequency must be created in the Order Template Frequency Details screen 
2. Client Orders must be signed using the frequency created in step 1 

Where to Find It: 

Path: 

1. Go to Client 
2. Select Client MAR 

 

Flag Alert Popup 

Reference No Task No Description 

67 Core Bugs # 133059 An incorrect ‘Document Name’ displayed when opening ‘Linked 
Document’ from ‘Flag Alert’ Pop-Up window. 

Core Bugs # 133059: An incorrect ‘Document Name’ displayed when opening ‘Linked 
Document’ from ‘Flag Alert’ Pop-Up window 

What’s Fixed: 

We resolved an issue where the system displayed an incorrect Document Name when users opened a 
Linked Document from the Flag Alert pop-up window. This occurred when users selected a client via 
search, leading to confusion and misidentification of the associated document. 
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With this fix, the system now displays the correct Document Name when users click the Open hyperlink in 
the Linked Document column of the Flag Alert pop-up, ensuring accurate document identification and an 
improved user experience. 

Where to Find It: 

Path 1: 

1. Go to Client → My Preferences 
2. Under General Settings, set Client Page Preferences to Documents 

Path 2: 

1. Perform a Client Search → Select a client 
2. In the Flag Alert pop-up window, click Open in the Linked Document column 
3. The correct document will open with the proper Document Name displayed 

 

Flow Sheet 

Reference No Task No Description 

68 Core Bugs #132919  
Flow Sheet screen – Slowness issues in loading the data. 

Core Bugs # 132919: Flow Sheet screen – Slowness issues in loading the data 

What’s Fixed: 

We resolved a performance issue in the Flow Sheet screen that caused significant delays when loading 
data—especially after users navigated through the Vital History tab and selected templates like 
Meaningful Use or Vitals. These delays impacted user efficiency and overall system performance. 

With this fix, the Flow Sheet screen now loads data promptly without lag, improving the user experience 
during data entry and review. 

Where to Find It: 

Path: 

1. Perform Client Search 
2. Select Client 
3. Navigate to Flow Sheet Quick Link 
4. Client Menu → Flow Sheet List Page 
5. Vital History tab → Select Meaningful Use/Vitals template 
6. Add Flow Sheet dropdown filter → Click New Icon 
7. New Entry Flow Sheet Detail page → Enter required fields → Click Save Icon 

 

Global Code Category 

Reference No Task No Description 
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70 Core Bugs # 133013 The ‘Code Name’ of ‘MARITALSTATUS’ global code category 
is not sorted based on the value of ‘Sort Order’. 

Core Bugs #133013: The ‘Code Name’ of ‘MARITALSTATUS’ global code category is not 
sorted based on the value of ‘Sort Order’ 

What’s Fixed: 

We resolved an issue where the system displayed Code Names in the MARITALSTATUS global code 
category alphabetically instead of using the configured Sort Order. This caused inconsistencies in 
dropdown selections across multiple screens. 

With this fix, the Marital Status dropdown now follows a two-level sorting logic: 

• Primary Sorting by Sort Order – The system orders Code Names based on the value in the 
Sort Order field. 

• Secondary Sorting Alphabetically – If multiple Code Names share the same Sort Order value, 
the system sorts them alphabetically. 

This update ensures a consistent and logical display of marital status options across all relevant screens. 

Where to Find It: 

Path 1: 

1. Go to My Office → Inquiries 
2. Click New → Navigate to Inquiry Details → Demographics tab → Marital Status dropdown 

Path 2: 

1. Go to Client → Client Information (C) 
2. Navigate to Demographics tab → Marital Status dropdown 

Path 3: 

1. Go to Client → Registration Document (C) 
2. Navigate to Demographics tab → Marital Status dropdown 

Path 4: 

1. Go to Client → Agency/Program Discharge Document 
2. Navigate to Demographics tab → Marital Status dropdown 

 

Government Performance and Results Act (GPRA) Document 

Reference No Task No Description 

71 Core Bugs # 132863 
In the PDF of ‘Government Performance and Results Act 
Outcome Measure’ document, the ‘Opioid’ section items were 
displayed in ‘Alcohol’ section. 

Core Bugs # 132863: In the PDF of ‘Government Performance and Results Act Outcome 
Measure’ document, the ‘Opioid’ section items were displayed in ‘Alcohol’ section 

What’s Fixed: 
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We resolved an issue in the PDF generated from the Government Performance and Results Act Outcome 
Measure document where the system incorrectly displayed items from the Opioid section under the 
Alcohol section. This misplacement affected the document’s accuracy and could lead to misinterpretation 
of client data. 

With this fix, the PDF now correctly categorizes and displays Opioid and Alcohol entries in their respective 
sections, ensuring the document reflects accurate and reliable information. 

Where to Find It: 

Path: 

1. Client → Government Performance and Results Act Outcome Measure Document 
2. Fill in the required details → Sign the document 
3. PDF will generate 

 

Group Details 

Reference No Task No Description 

72 Core Bugs # 132879 Group Service - Dropdown cuts off selections 

Core Bugs # 132879: Group Service - Dropdown cuts off selections 

What’s Fixed: 

We resolved an issue where the Evidence Based Practices dropdown on the Group Service Detail page 
was cut off and didn’t display the full list of options. This made it difficult for users to view or select all 
available choices. 

With this fix, the dropdown now displays the complete list without any visual cutoff, ensuring a smooth 
and accurate selection experience. 

Where to Find It: 

• My Office → Groups → Groups list page → New → Group Details page → Save → Schedule 
tab → New Group Service → Group Service Client Popup → Select → Group Service Detail 
page → Evidence Based Practices dropdown 

 

Group Services 

Reference No Task No Description 

73 Core Bugs # 133086 
Custom Fields dropdowns in Group Notes carry over the 
selected value between clients. 

74 Core Bugs # 133038 When the ‘Primary Clinician’ is changed in the ‘Groups’, the 
update did not reflected in the ‘Future Group service 
Documents’. 

75 Core Bugs # 132661 Group Services – Implemented a new Information message 
when Group Services with a balance are set to Error. 
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76 Core Bugs # 133093 Group Services – In the Client Note tab for the dropdown fields, 
the tab off was not working. 

Core Bugs # 133086: Custom Fields dropdowns in Group Notes carry over the selected 
value between clients 

What’s Fixed: 

We resolved an issue where selecting a value from a custom dropdown field in the Group Services 
section incorrectly carried that value over to the next client selected in the session. This behavior caused 
confusion and potential data entry errors, as selections intended for one client appeared under another. 

With this fix, the system now correctly ties dropdown selections in the Custom tab only to the currently 
selected client. 

Where to Find It: 

Path: 
My Office → Group → Select a group → Schedule tab → New Group Service → Enter date and select 
a client → Services tab → Custom tab → Select dropdown value → Switch to another client → Custom 
tab 
 

Core Bugs # 133038: When the ‘Primary Clinician’ is changed in the ‘Groups’, the update 
did not reflected in the ‘Future Group service Documents’ 

What’s Fixed: 

We resolved an issue where updates to the Primary Clinician in a Group were not reflected in future 
Group Service documents. This caused inconsistencies in documentation and staff assignments for 
scheduled group services. 

With this fix, the system now correctly applies changes to the Primary Clinician across all future Group 
Service documents, ensuring accurate clinician assignment and improved continuity of care. 

Where to Find It: 

Path 1:  
My Office → Groups → Groups List page → Click New → Group Detail page → Fill out 
General tab → Click Save → Go to Schedule tab → Click New Group Service → Select Date 
of Service and Clients → Click Select 

Path 2:  
Group Service Detail screen → Group tab → Group Details tab → Confirm Group and Staff 
details → Click Recurrence icon → Set recurrence pattern → Click Create Immediately → Click 
OK 

 Follow the steps above → Change the Primary Clinician → Click Save 
Path 3: 

My Office → My Documents → My Documents List page → Filter by appropriate dates → Click 
Apply Filter 

 

Core Bugs # 132661: Group Services – Implemented a new Information message when 
Group Services with a balance are set to Error 

What’s Fixed: 
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We resolved an issue where users could mark a Group Service as having an Error status even when a 
payment balance remained on the service. The lack of validation led to inconsistencies in service and 
billing records. 

With this release, we implemented an Information Message popup on the Group Service Detail screen. If 
a user attempts to mark a Completed Service as Error while the payment balance is not zero, the system 
displays the following message: 

Error Message: 

 Service ID: XXXX – Service cannot be deleted since the balance of the payment is not zero. 

This validation is triggered only when the system configuration key 
ALLOWSERVICEERRORWITHPAYMENT is set to N. 

Where to Find It: 

• My Office → Groups → Groups list page → New → Group Detail page → Save → Schedule 
tab → New Group Service → Group Service Clients popup → Select Date of Service and 
Clients → Select 

• Group Service Detail Screen → Group tab → Group Details tab → Services tab → Service 
Information tab → Save → Note tab → Client Note → Save → Sign 

• Client from Group → Services Quick Link → Client Menu → New → Service Detail Page → 
Enter required fields → Save → Complete Service → Make Payment 

• Group Service Detail Screen → Group tab → Top menu icons → Mark As Error → 
Confirmation Message popup → Information Icon displays 

 

Core Bugs # 133093: Group Services – In the Client Note tab for the dropdown fields, the 
tab off was not working 

What’s Fixed: 

We resolved a usability issue in the Client Note tab of Group Services where Tab key navigation skipped 
over dropdown fields. This prevented users from efficiently moving through the form using keyboard input. 

With this fix, Tab key navigation now works correctly for all dropdown fields in the Client Note tab, 
allowing users to move through the form seamlessly and improving overall accessibility and user 
experience. 

Where to Find It: 

Path 1: 

1. My Office → Groups → Groups List page → Click New icon 
2. Group Detail page → Enter required fields in General tab → Save 
3. Navigate to Schedule tab → Click New Group Service button 
4. Group Service Clients popup → Select Date of Service and Clients → Click Select 

Path 2: 

1. Navigate to Group Service Detail screen → Group tab → Group Details tab 
2. Ensure Group section is initialized → Navigate to Services tab 
3. Enter required fields in Service Information tab → Select Mode of Delivery → Save 
4. Navigate to Note tab → Client Note tab 
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Inquiry Details 

Reference No Task No Description 

77 Core Bugs #132914  
Added an index to the Inquiries table. 

78 Core Bugs # 132612 Performance issue observed while opening Inquiry Details 
screen from unsaved changes 

Core Bugs # 132914: Added an index to the Inquiries table 

What’s Fixed: 

We resolved an issue where the Inquiries table lacked foreign key constraints and indexing on key 
columns, which could lead to data integrity issues and slow query performance. 

With this fix, we added foreign keys and indexes to the following columns in the Inquiries table: 

• CrisisAssociatedServiceId 

• CrisisAssociatedDocumentId 

• CrisisAssociatedFormId 

This update improves data consistency and enhances system performance when accessing or managing 
inquiry records. 

Where to Find It: 

Not applicable (backend database change) 

Core Bugs # 132612: Performance issue observed while opening Inquiry Details screen 
from unsaved changes 

What’s Fixed: 

We resolved an issue where the system loaded a large dataset from the CoveragePlans table—including 
both Active and Inactive plans—when users accessed the Inquiry Details screen through unsaved 
changes. This behavior caused performance issues and slowed down screen load time. Additionally, the 
system added duplicate coverage plans to the dataset. 

With this fix, we optimized the CoveragePlans table to load only Active coverage plans. The Inquiry 
Details screen now performs efficiently, and the system no longer adds duplicate entries to the dataset. 

Pre-requisite: 

Create unsaved changes by entering details in the Inquiry screen. 

Where to Find It: 

Path: 

1. Client → Search → Select Client 
2. Inquiry (Client) → Enter details (unsaved changes created) 
3. Open any other screen → Navigate back to Inquiry Details screen via unsaved changes 
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Manage Staff  

Reference No Task No Description 

79 Core Bugs # 132901 
Staff's Licenses / Degrees tab inconsistent response from 
system 

Core Bugs # 132901: Staff's Licenses / Degrees tab inconsistent response from system 

What’s Fixed: 

We resolved an issue where the system intermittently displayed a red error message—"Object reference 
not set to an instance of an object."—when users accessed the Licenses/Degrees tab on the Staff 
Details page. This error prevented users from viewing or updating license and degree information for staff 
members. 

With this fix, the Licenses/Degrees tab now loads consistently without interruptions or error messages, 
allowing users to manage staff credentials smoothly. 

Where to Find It: 

Path: 

1. Administration → Staff/Users 
2. Staff/Users list page → Click on required Staff Name hyperlink 
3. Staff Details page → Click on Licenses/Degrees tab 

 

Merge Clients 

Reference No Task No Description 

80 Core Bugs # 132981 
Client Search option disappeared when clicking on ‘Client 
search’ icon after merging two clients. 

Core Bugs # 132981: Client Search option disappeared when clicking on ‘Client search’ 
icon after merging two clients 

We resolved an issue where the Client Search option disappeared after users merged two clients. On 
the Merge Clients screen, clicking the Client Search icon after completing a merge failed to display the 
search functionality, preventing users from initiating new client searches. 

With this fix, the system now correctly displays the Client Search option when users click the icon after 
merging clients, restoring full search capability. 

Where to Find It: 

Administration → Merge Clients → Select Clients → Click on Merge Clients icon 

Message (My Office) 
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Reference No Task No Description 

81 Core Bugs # 133064 
Navigating to Messages screen through unsaved changes 
affected the Reply functionality 

Core Bugs # 133064: Navigating to Messages screen through unsaved changes affected 
the Reply functionality 

What’s Fixed: 

We resolved an issue in Messages (My Office) where the system incorrectly displayed the contents of 
one message in the reply window for another. This occurred when users had multiple messages and 
created unsaved changes in one (e.g., Message 1), then attempted to reply to another (e.g., Message 2), 
leading to potential data breaches and confusion in message handling. 

With this fix, the system now prompts users with a confirmation message when they switch between 
messages with unsaved changes. If users click OK, the system discards the unsaved changes from the 
first message and correctly displays the content for the second message. 

Where to Find It: 

Path 1: 

1. SmartCare → Messages (My Office) → New 
2. Send two messages to the same staff 

Path 2: 

1. Login to SmartCare as the receiving staff 
2. Client → Messages (My Office) → Select any message → Click Reply 
3. Navigate to another screen (e.g., My Documents) 
4. Return to Messages (My Office) via unsaved changes → Select second message → Click Reply 
5. Confirmation Message appears → Click OK 

Confirmation Message: 

"Do you want to proceed? Clicking 'OK' will clear any unsaved changes in the Message Details for the 
logged-in staff member." 

Methadone 

Reference No Task No Description 

82 Core Bugs # 132780 MAT: When the Frequency Time was changed, duplicate MAT 
records were created. 

83 Core Bugs # 132774 MAT Management list page - Unable to Place a Backdated Client 
Order for MAT Dispensing. 

84 Core Bugs # 132979 MAT Management Details: MAR Details Popup is not displayed 
on click of ‘Dispensed Date & Time’ hyperlink from the ‘Dispense 
and No Show History grid’. 

89 Core Bugs # 132753 MAT: The Patient Safety Acknowledgement popup message is 
displayed only once for the re-dispense. 
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Core Bugs # 132780: MAT: When the Frequency Time was changed, duplicate MAT 
records were created 

What’s Fixed: 

We resolved an issue where updating the Frequency Time in the Order Template Frequencies screen 
caused the stored procedure ssp_CreateMATDetails to create duplicate MAT records for the same date. 
This resulted in inaccurate data in the MAT Management Details screen. 

With this fix, the system now checks for existing records before creating new ones. If a record already 
exists for a given date, the system does not create a duplicate—even if the frequency is updated. The 
updated frequency applies only to newly created records or schedules. 

Where to Find It: 

• Path 1: 
Client → Client Orders → New → Search and select Methadone Medication → Enter required 
data → Insert → Save/Sign 

• Path 2: 
Administration → Order Template Frequencies → Open frequency used in the order → 
Update Frequency Time → Save 

• Path 3: 
My Office → MAT Management → Filter by date → Click Dispense icon → View MAT 
Management Details 

 

Core Bugs # 132774: MAT Management list page - Unable to Place a Backdated Client 
Order for MAT Dispensing 

What’s Fixed: 

We resolved an issue in the MAT Management list page where the system failed to display backdated 
Client Orders. This prevented users from dispensing medications for those orders. 

With this fix, users can now place and dispense backdated orders by adjusting the date filter and 
selecting the No Pump option in the MAT Management workflow. 

Where to Find It: 

Path 1: 
Go Search → Client Orders (Client) → Client Orders list page → New → Enter required details → 
Save/Sign 

Path 2: 
My Office → MAT Management → MAT Management Details → Dispense 

 

Core Bugs # 132979: MAT Management Details: MAR Details Popup is not displayed on 
click of ‘Dispensed Date & Time’ hyperlink from the ‘Dispense and No Show History grid’ 

What’s Fixed: 

We resolved an issue in the MAT Management Details screen where clicking the ‘Dispensed Date & 
Time’ hyperlink in the Dispense and No Show History grid failed to display the MAR Details popup. 
This prevented users from accessing detailed medication administration records directly from the history 
grid. 
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With this release, the system now correctly displays the MAR Details popup when users click the 
‘Dispensed Date & Time’ hyperlink, allowing full visibility into medication administration details. 

Prerequisites: 

1. A MAT Order must be signed for the selected client. 
2. MAT Medication must be dispensed to the selected client. 

Where to Find It: 

• My Office → MAT Management → MAT Management List Page → Dispense Icon → MAT 
Management Details → Sign → Face-to-Face/Take Home Dispense 

 

Core Bugs # 132753: MAT: The Patient Safety Acknowledgement popup message is 
displayed only once for the re-dispense 

What’s Fixed: 

We resolved an issue in MAT Management where the Patient Safety Acknowledgement popup 
appeared only once per day, even if users performed multiple qualifying actions. The popup was triggered 
during Dispense, Re-dispense, or Edit Dosage actions—but only if the dispensed quantity differed from 
the previous dose and exceeded the configured threshold. However, it did not reappear for subsequent 
qualifying actions on the same day. 

With this release, the system now displays the Patient Safety Acknowledgement popup every time a 
qualifying action is performed—Dispense, Re-dispense, or Edit Dosage—if the dispensed quantity 
differs from the last and exceeds the configured threshold (either increase or decrease). 

Prerequisite: 

• The system configuration key ALLOWSERVICEERRORWITHPAYMENT must be set to N. 

Where to Find It: 

• Administration → Orders → Orders list page → New → Order Details → Select Medication 
Order Type → Enable MAT settings → Save 

• My Office → Medication/Lot/Bottle list page → New → Medication/Lot/Bottle Details → 
Save 

• Client → Client Orders → New → Client Order Details → Select MAT Order → Enter Take 
Home Days → Save and Sign 

• My Office → MAT Management → Connect User → Connection Details → Connect 
Machine/Inventory 

• My Office → MAT Management → Select Order → Dispense icon → Dispense Dose 
 

 

My Calendar 
Reference No Task No Description 

92 Core Bugs # 133024 
Updates to Appointments made through Service Detail are not 
reflected on Staff Calendar. 

Core Bugs # 133024: Updates to Appointments made through Service Detail are not 
reflected on Staff Calendar 
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What’s Fixed: 

We resolved an issue where updating the Start Time or End Time of a service through the Service 
Detail or Service Note screens did not update the Staff Calendar. The calendar continued to display the 
original time values, causing scheduling discrepancies. 

With this fix, the system now accurately reflects any changes made to the Start Time or End Time of a 
service on the My Calendar screen, ensuring staff calendars stay synchronized with service details. 

Where to Find It: 

Path 1: 

1. Client → Services → Services list page → Click New icon 
2. Service Detail page → Enter required data → Save 

Path 2: 

1. Client → Services/Notes → Service Note list page → Click New icon 
2. Service Note page → Enter required data → Save 

Path 3: 

1. Client → Services → Services list page → Click on created DOS hyperlink 
2. Service Detail page → Update Start/End Time → Save 

Path 4: 

1. Client → Services/Notes → Services/Notes list page → Click on created DOS hyperlink 
2. Service Note page → Update Start/End Time → Save 

Path 5: 

My Office → My Calendar → Filter for the updated service → Click Apply Filter 

My Documents List Page 

Reference No Task No Description 

94 Core Bugs # 133019 
Documents cannot be added from the Associate Documents 
pop-up if the associated Program code contains single quotes 
('). 

Core Bugs # 133019: Documents cannot be added from the Associate Documents pop-up 
if the associated Program code contains single quotes (') 

What’s Fixed: 

We resolved an issue where users couldn’t add documents from the Associated Documents pop-up if 
the associated Program Name contained single quotes ('). Clicking the Add button failed to insert the 
selected documents into the List of Associated Documents, disrupting document association 
workflows. 

With this fix, the system now correctly handles Program Names that include single quotes. When users 
click the Add button in the Associated Documents pop-up, the system successfully adds the selected 
documents to the List of Associated Documents, regardless of the presence of single quotes in the 
Program Name. 
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Prerequisites: 

• A Program Name that includes single quotes (') 

• A document to be associated with that Program 

Where to Find It: 

Path: 

My Office → My Documents → Associated Documents pop-up 

My Reports 

Reference No Task No Description 

95 Core Bugs # 132953 
ER Claim Lines: Duplicate Payment Rows 

97 Core Bugs # 132933 The Aging Report is loaded without displaying the relevant data. 

98 Core Bugs # 133030 My Reports: users are unable to filter reports for specific clients. 

99 Core Bugs # 133096 UDS Section E - BMI Output Label Change 

105 Core Bugs # 133025 Unable to run ‘Staff Client Access Tracking’ report. 

Core Bugs # 132953: ER Claim Lines: Duplicate Payment Rows 

What’s Fixed: 

We resolved an issue where the ER Claim Line Denials reports displayed duplicate payment rows when 
processing an 835 file containing multiple Remark Codes for a single ClaimLineItemId. The system 
listed the same service multiple times, with each remark code appearing on a separate line. 

With this fix, the system now consolidates multiple remark codes into a single field for each 
ClaimLineItemId. Each service line appears only once in the report, eliminating duplicate entries and 
improving report accuracy. 

Pre-requisite: 

Process an 835 file (ERfileID) that contains multiple Remark Codes and note the corresponding ERfileID. 

Where to Find It: 

Path 1: 

1. My Office → My Reports quick link 
2. Search for “ER Claim Line Denials” report → Click report name hyperlink 
3. Report opens in a new window → Enter ERfileID → Click View Report 

Path 2: 

1. My Office → My Reports quick link 
2. Search for “ER Claim Line Denials CSV” report → Click report name hyperlink 
3. Report opens in a new window → Enter ERfileID → Click View Report 



SmartCare Release Notes  

      

 

 

Core Bugs # 132933: The Aging Report is loaded without displaying the relevant data 

What’s Fixed:  

We resolved an issue where the AR Aging Summary report failed to display relevant data based on 
applied filter parameters. On the My Reports list page, selecting the AR Aging report resulted in a 
persistently blank output, even when users applied valid filters. 

With this release, we removed CDAG changes from the AR Aging Reports to improve performance. The 
report now loads faster and accurately reflects filtered data, restoring full reporting functionality. 

Where to Find It: 

My Office → Reporting → My Reports → My Reports list page → Search for “AR Aging Report” → 
Click on report hyperlink 

Core Bugs # 133030: My Reports: users are unable to filter reports for specific clients 

What’s Fixed: 

We resolved an issue where users couldn’t filter reports by specific clients on the My Reports (My 
Office) page because the ClientID filter was missing. This limitation prevented users from viewing client-
specific report data. 

With this fix, the system now correctly displays the ClientID filter for client-related reports, allowing users 
to efficiently narrow down results and access relevant information. 

Where to Find It: 

Path: 

1. Go to Search 
2. Select My Reports (My Office) 

 

Core Bugs #133096: UDS Section E - BMI Output Label Change 

What’s Fixed: 

We resolved an issue in UDS Section E where the system incorrectly displayed the BMI Output Label 
for the 2025 reporting year. The field name appeared as "BMI Result (kg/m²)", which did not align with 
the intended reporting format. 

With this fix, we updated the field name to "BMI Result (Percent)" for the 2025 reporting year, ensuring 
consistency with reporting standards and improving clarity for users reviewing UDS data. 

Where to Find It: 

Path: 

Go to My Office → UDS Table 6B Details – Section E 

Core Bugs # 133025: Unable to run ‘Staff Client Access Tracking’ report 

What’s Fixed: 
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Users previously couldn’t run the Staff Client Access Tracking report because the system lacked the 
necessary stored procedures. This issue blocked the report from executing and retrieving access tracking 
data as expected. 

The fix restored the missing stored procedures, enabling the Staff Client Access Tracking report to run 
successfully without errors. Users can now view staff access history for clients. 

Where to Find It: 

Path: 

Client → Staff Client Access Tracking Report 

Peer Record Reviews 

Reference No Task No Description 

108 Core Bugs # 132998 The results of Peer Record Reviews always shows 
'Acceptable', despite the user's selection of 'No'. 

Core Bugs # 132998: The results of Peer Record Reviews always shows 'Acceptable', 
despite the user's selection of 'No' 

What’s Fixed: 

We resolved an issue where the Peer Record Reviews list page always showed "Acceptable" in the 
Results column, even when users selected "No" for a questionnaire item during the review process. This 
misrepresentation affected the accuracy of review outcomes. 

The fix ensures that the system now correctly displays "Below Standard" in the Results column when 
users select the "No" radio button in the Peer Record Review Details screen, accurately reflecting the 
responses provided. 

Where to Find It: 

Path: 

1. Go to My Office → Peer Record Reviews list page 
2. Click New 
3. Select Review Type and Clinician Reviewed dropdown value 
4. Click Random in the New Peer Record Review screen 
5. Click Create Peer Record Review 
6. Select No for a questionnaire item → Click Calculate → Click Save 
7. Close the review and return to the Peer Record Reviews list page 

The Results column will now display Below Standard for the respective review 

Primary Care 

Reference No Task No Description 

110 Core Bugs # 133050 
The ‘Primary Care Appointments’ continued to appear in 
‘SmartView’ even after being cancelled or marked as errors. 
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Core Bugs # 133050: The ‘Primary Care Appointments’ continued to appear in 
‘SmartView’ even after being cancelled or marked as errors 

What’s Fixed: 

The team resolved an issue where SmartView continued to display Primary Care Appointments even 
after users marked them as Cancelled or Error. This caused confusion for users relying on SmartView to 
track active appointments. 

The fix ensures that SmartView now correctly excludes cancelled or erroneous Primary Care 
Appointments, displaying only valid and active appointments. 

Where to Find It: 

Path 1:  
My Office → My Calendar → Create a Primary Care Appointment → Enter required fields and status 
→ Click Save 
Path 2: 
Client search → Primary Care Appointments screen → Open appointment → Change status to 
Cancelled or Error → Click Save 

 

Programs 

Reference No Task No Description 

112 Core Bugs # 132959 
The ‘Assigned Staff’ name displaying issue on the ‘Program 
Assignment Details’ page. 

113 Core Bugs # 131611 Program Assignments: SmartCare allows Discharge dates to be 
removed from prior Client Program Enrollments when there is 
an existing enrollment for the same program 

Core Bugs #132959: The ‘Assigned Staff’ name displaying issue on the ‘Program 
Assignment Details’ page 

What’s Fixed: 

The system previously displayed staff names in the Assigned Staff column of the Program Assignment 
Details screen using the format LastName + FirstName, even when a Display As name was configured. 
This caused confusion in clinical and operational workflows where staff are commonly identified by their 
preferred names. 

The update ensures the Assigned Staff column now shows the Display As name when available. If the 
Display As value is null or empty, the system defaults to displaying the staff’s legal name in the LastName 
+ FirstName format. 

Where to Find It: 

• Program → Program Assignments → Program Assignments list page → New or Status 
hyperlink → Program Assignment Details → History section 

• Client → Programs → Programs list page → New or Status hyperlink → Program 
Assignment Details → History section 
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Core Bugs # 131611: Program Assignments: SmartCare allows Discharge dates to be 
removed from prior Client Program Enrollments when there is an existing enrollment for 
the same program 

What’s Fixed: 

We resolved an issue where SmartCare allowed users to remove discharge dates from prior Client 
Program Enrollments, even when an active enrollment for the same program already existed. This led to 
overlapping program records and potential data integrity issues. 

To prevent these conflicts, the system now enforces a new validation that blocks modifications to older 
enrollment records if they overlap with the date range of an existing enrollment for the same program. 
Users can now update only the most recent enrollment record. 

Validation Message: 

 “There is an enrollment record already available during this period. Please check the dates on both 
records as overlaps are not allowed.” 

Additionally, when users select a custom status from the Status dropdown, the system now automatically 
clears the Requested, Enrolled, and Discharged date fields. It also triggers new validations to ensure data 
accuracy and prevent conflicts. 

Where to Find It: 

Path 1:  
Program Assignments → Program Assignments list page → Click on a Discharged status hyperlink 
→ Program Assignment Details → Modify Discharge Date or Current Status → Click Save 
Path 2:  
Client → Programs → Programs list page → Click on a Discharged status hyperlink → Program 
Assignment Details → Modify Discharge Date or Current Status → Click Save 

 

Rx Application 

Reference No Task No Description 

118 Core Bugs # 132894 
Misspelling in the ‘Free- Text Sig’ Pop up for Patches and 
Suppositories 

Core Bugs # 132894: Misspelling in the ‘Free- Text Sig’ Pop up for Patches and 
Suppositories 

What’s Fixed: 

The team resolved an issue where the Free-Text Sig popup displayed incorrect plural forms when users 
prescribed medications with a potency unit of Patch or Suppository. If the calculated dose exceeded 1, 
the system incorrectly added an "s" to the end of the word, resulting in misspellings such as: 

• Place 2.4285714 Patchs (17mg) Onto The Skin Daily 

• Administer 6 Suppositorys (1200mg) Into The Vagina Daily 
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With this update, the system now uses the correct plural forms: 

• Place 2.4285714 Patches (17mg) Onto The Skin Daily 

• Administer 6 Suppositories (1200mg) Into The Vagina Daily 
 

Where to Find It: 

Path: 
My Office → Medications → Rx Application → Start Page → Patient Summary → New Order → 
Select a drug with potency unit as Patch or Suppository → Fill required fields → Insert → Free-Text 
Sig popup → Update & Close → Prescribe 

Services 

Reference No Task No Description 

119 Core Bugs # 133099 
‘ServiceUnits' column is missing in exported excel. 

120 Core Bugs # 132954 New configuration is added to show or hide ‘ServiceUnits’ 
column in Export excel file. 

Core Bugs # 133099: ‘ServiceUnits' column is missing in exported excel 

What’s Fixed: 

The team resolved an issue where exported data from the Services list page excluded the ServiceUnits 
column from the downloaded Excel file. This omission made it difficult for users to review or analyze 
service unit data outside the system. 

With this update, the system now includes the ServiceUnits column in the exported Excel file, allowing 
users to access complete service information for reporting or offline use. 

Where to Find It: 

Path: 
My Office → Services → Services list page → Click the Export icon → Open the downloaded Excel file 

Core Bugs # 132954: New configuration is added to show or hide ‘ServiceUnits’ column 
in Export excel file 

What’s Fixed: 

The team resolved an issue where the system always included the ServiceUnits column in exported Excel 
files from the Services list page, even when it wasn’t needed. This led to confusion and clutter in exported 
reports. 

With this update, the system introduces a new configuration key that gives administrators control over 
whether the ServiceUnits column appears in the export. The system now respects the value of this 
setting: 

• If set to Yes (default), the ServiceUnits column is included in the export. 

• If set to No, the column is excluded. 
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Where to Find It: 

Path 1: 

Administration → Configuration Keys → Open IncludeServiceUnitsInMyOfficeServicesExport 

Path 2: 

My Office → Services → Services list page → Click the Export icon → Open the downloaded Excel file 

Configuration Key Details: 

• Key: IncludeServiceUnitsInMyOfficeServicesExport 

• Read Key As: Include Service Units in My Office Services Export 

• Allowed Values: Yes, No 

• Default Value: Yes 

• Modules Affected: Billing - Regenerate Charges for a Service, SCM Accounts Receivable, SCM 
Admin 2, SCM Financial 1 

Note: If the key is set to any value other than "Yes" or "No", the system will default to Yes. 

SmartCare Improvements 
Reference No Task No Description 

134 Core Bugs # 133054 
System Not Validating Expired Passwords Correctly 

135 Core Bugs # 133098 Users cannot login to the application 

Core Bugs # 133054: System Not Validating Expired Passwords Correctly 

What’s Fixed: 

The system previously failed to prompt users to reset their password during login when their password 
had expired. This occurred because it miscalculated the expiration date and didn’t validate it correctly, 
allowing users with expired passwords to log in without updating their credentials. 

The update ensures the system now properly checks for expired passwords—even when the expiration 
value is missing (NULL)—and prompts users to reset their password before gaining access. 

Where to Find It: 

Path: 
Login → Administration → Staff/Users → Account section → Check expired password → Attempt 
login with that user 

Core Bugs # 133098: Users cannot login to the application 

What’s Fixed: 

We resolved an issue that prevented users from logging in to the SmartCare application. After entering 
valid credentials, the system displayed the error message: 

“Unknown error occurred, please try again later.” 

With this fix, users can now log in successfully without encountering any errors.. 
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Where to Find It: 
SmartCare Login page 

 

Staff Calendar  
Reference No Task No Description 

136 Core Bugs # 133018 
Programs in Staff Calendar are not sorting alphabetically.  

Core Bugs # 133018: Programs in Staff Calendar are not sorting alphabetically 

What’s Fixed: 

The system previously displayed the Program dropdown list in the Scheduler Event popup of the My 
Calendar screen without sorting it alphabetically. This made it difficult for users to quickly locate and 
select the desired program when creating calendar entries. 

The update now sorts the Program dropdown list alphabetically, improving usability and streamlining the 
scheduling process. 

Where to Find It: 

Path: 

1. My Office → My Calendar 
2. Click “Click to Create New Calendar Entry” icon 
3. Scheduler Event popup → Program dropdown 
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Global Codes 
Global Codes are the individual entries or options assigned to a Global Code Category. Global Codes can 
be core or custom. For example, a Global Code Category and the associated Global Codes are the 
options you will select from a dropdown list.  

Review and configure the following Global Code Categories and Global Codes that belong to each 
category before performing the workflows documented in these release notes.  

Ref No. Category Name 

31 CLIENTNOTELEVEL 

70 MARITALSTATUS 

Recodes 
A Recode is a subset of other system codes that populate a list for a specific reporting purpose. Recodes 
create an allowed list of entries from multiple larger lists.  

Review and configure the following before performing the workflows documented in these release notes.  

There are no Recodes for Defects.  

Configuration Keys 
Configuration keys are settings that instruct the system (or a particular module or page) to behave in a 
desired way. Each Key has a set of values that correspond to particular behaviors. The organization 
should determine Configuration Key settings and adjust them as needed.  

Review and configure the following before performing the workflows documented in these release notes.  

Ref No. Key Name 

11 EnableJobToAutomateBundledServices 

52 DocumentSignaturesNoPassword 

52 AllowVersionAuthortoSign 

75 ALLOWSERVICEERRORWITHPAYMENT 

120 IncludeServiceUnitsInMyOfficeServicesExport 

Data Model Changes  
There are no data model changes for Defects.  
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SmartCare Testing Strategy – September 2025 MSP  

Purpose: 
To confirm that key workflows in each module function correctly after the release, focusing on high-impact 
defect fixes (Core Bugs) to ensure resolved issues work as expected. 

How to Use This Strategy 

1. Start with modules you use most often in daily operations. 
2. Within each module, test workflows tied to defect fixes. 
3. Follow the navigation paths in the release notes for each task. 
4. Document: 

a. Pass / Fail outcome 
b. Unexpected behaviors 
c. Follow-up questions or concerns 

These testing workflows may vary depending on your organization’s specific SmartCare configuration, so 
be sure to adjust steps as needed to align with your local settings and processes. 

Testing Workflow by Module – Core Bugs Only 

Documents 

• Defect #129532 – Validate that Document Locking no longer occurs when multiple staff edit 

separate document types simultaneously. 

• Defect #130049 – Confirm that amendment comments correctly display in the Document 

History panel after saving. 

• Defect #130351 – Ensure the signature validation message no longer appears incorrectly 

when using “Sign & Close” on completed documents. 

Dynamic Forms (DFA) 

• Defect #130197 – Verify form field responses retain saved values after reopening the DFA. 

• Defect #130421 – Confirm the validation message no longer triggers incorrectly when required 

fields are already filled. 

Client Search 

• Defect #130693 – Validate that multi-field search (Name/SSN/DOB) operates as expected 

when using new OR logic. 

o Confirm results prioritize exact matches and return clients even when partial matches 

exist. 

Authorizations 

• Defect #130832 – Test variable rate authorizations save correctly and reflect in related billing 

screens when configuration key EnableCMVariableRateConfiguration = “Yes.” 

• Defect #131025 – Validate that voided authorizations no longer appear in active lists and cannot 

be selected for claim creation. 
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Claims / Billing 

• Defect #130901 – Confirm claim resubmission successfully generates corrected claims without 

duplicating header data. 

• Defect #130913 – Validate that Adjustment Reason Codes correctly populate when claim 

corrections are processed. 

• Defect #131746 – Test claim batch file handling over 50,000 records to ensure the system 

processes large volumes without error. 

MAT (Methadone) 

• Defect #131992 – Validate that Prime popups are suppressed correctly during bottle change 

workflows. 

• Defect #132011 – Confirm that the MAT client outcomes evaluation tool properly calculates and 

displays GPRA-based outcome data. 

Reception 

• Defect #131965 – Test the flag icons and count column display accurately in the Front Desk 

screen. 

o Confirm count changes dynamically as flags are added or removed. 

Services / Notes 

• Defect #132325 – Validate new “Create Service Note” option on the Care Coordination screen 

creates service entries successfully. 

• Defect #131811 – Confirm that the Sensitive Information section appears or hides based on 

configuration key and service type. 

RWQM 

• Defect #132020 – Verify select/deselect functionality allows for quick management of large 

charge volumes without system lag. 

• Defect #132017 – Confirm that “Date of Service From/To” filters function properly across 

backend and frontend RWQM workflows. 

Reports 

• Defect #130409 – Confirm data accuracy in UDS Table 9D (Patient Service Revenue). 

• Defect #131691 – Validate updated Table 3B Demographic standards display correct results. 

• Defect #131629 – Verify Evidence-Based Practices Report (IPP T3 Indicator) reflects proper 

logic for reporting indicators. 

Rx Application 

• Defect #132110 – Validate Layman’s Terminology displays correctly in the Controlled 

Substance Audit and Controlled Substance Reports. 
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• Defect #130484 – Confirm diagnosis codes appear under “Dx/Purpose” dropdown in the 

Complete Medication Order page. 

SmartCare Configuration / Permissions 

• Defect #129433 / #130997 / #131004 / #131022 / #131649 / #131668 – Verify System 

Configuration and Column Configuration icons appear only for users with proper permissions. 

• Defect #131020 – Confirm non-configurable list pages correctly hide configuration icons. 

Widgets 

• Defect #131749 – Confirm Service Request and Supervisee Request widgets include new 

“Submitted” and “Re-Submitted” statuses. 

Integration 

• Defect #129768 – Test SmartCare–Patient Portal integration for real-time updates to client 

demographics, refill requests, and secure data sharing. 

If a Test Fails:  
Create a Zendesk ticket with the module name, task number, detailed steps to reproduce, expected vs. 

actual results, and attach any relevant screenshots or error messages. 
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Version Description MSP Version 

1.0 Initial Release September 2025 
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