
 

 

 

 

SmartCare™ August 2025 MSP  
Release Notes (Defects) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



SmartCare Release Notes  

      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This documentation and the information disclosed within, including the structure and contents, 
are confidential and the proprietary property of Streamline Healthcare Solutions, LLC and are 

protected by patent, copyright and other proprietary rights.  

 

 © 2003-2025 Streamline Healthcare Solutions, LLC or its Affiliates. All Rights Reserved.  

 

 

 

510 E. Butler Ct., Kalamazoo, MI 49007 | Phone - (877) GO-SHS-41 | Fax - (877) GO-SHS42 
www.streamlinehealthcare.com

http://www.streamlinehealthcare.com/


SmartCare Release Notes 

iii 

Table of Contents 
TASKS LIST-‘DEFECT FIXES’ (107) ......................................................................................... 2 

Functionality Task Details .......................................................................................................... 8 

Adhoc Reporting ..................................................................................................................... 8 

Core Bugs # 132752: The saved reports are not displayed under the selected catalog 
Report section list. .............................................................................................................. 9 

Alerts ...................................................................................................................................... 9 

Core Bugs # 132561: Error displayed when service note is accessed from Alerts screen 
and signed .......................................................................................................................... 9 

Authorizations ......................................................................................................................... 9 

Core Bugs # 132763: Service Request – Review/Approval Detail: The ‘Review Status’ is 
not updating to ‘Completed’ status. ..................................................................................... 9 

Batch Eligibility ..................................................................................................................... 10 

Core Bugs # 132653: The Batch Eligibility Configuration Id to be mapped with Existing 
Configuration Id of Clearing House. .................................................................................. 10 

Batch Services ..................................................................................................................... 10 

Core Bugs # 132632: Some of the services created from the Batch Service Entry were 
missing. ............................................................................................................................ 10 

Bedboard .............................................................................................................................. 11 

Core Bugs # 132626: Program still appeared on the ‘Programs’ list page even though both 
Bed Assignment Activity and Inpatient Activity records are deleted for a discharged client.
 ......................................................................................................................................... 11 

Core Bugs # 132816: Bedboard: duplicating a bed assignment ........................................ 11 

Core Bugs # 132145: ‘Allowed Amount Adjustment' column field was not defaulted from the 
template plan if not specified. ............................................................................................ 12 

Core Bugs # 132234: Adjustments in 835 process calculate rounding fix incorrectly ......... 12 

Core Bugs # 132548: Qualifying CCBHC Services not in Batch error not generating if one 
of the qualifying services has a Claims Generation Error .................................................. 13 

Core Bugs # 132578: Decimal Claim unit values are rounded off to integer ...................... 13 

Core Bugs # 132589: Decimal Claim unit values are rounded off to integer ...................... 13 

Core Bugs # 132824: The 'Allowed Amount Adjustments' job step encountered a failure 
during the Nightly Billing job due to an issue with the length of the Place of Service value 14 

Client Clinical Problems ........................................................................................................ 14 

Core Bugs # 132501: ‘Problem Details’ diagnoses were not being saved to the ‘Most 
Common Problems’ dropdown .......................................................................................... 14 

Client Education Resource ................................................................................................... 15 

Core Bugs # 130636: Issues in the ‘Client Education Resources’ screen. ......................... 15 

Client Information ................................................................................................................. 15 



SmartCare Release Notes  

      

 

Core Bugs # 132557: ‘Address Type 0’ entries in tables ‘ClientAddresses’ and 
‘ClientAddressHistory’ being generated as Bad Data. ....................................................... 15 

Core Bugs # 132601: Client Information (Admin): in the ‘Contacts’ tab, the phone numbers 
are not appearing .............................................................................................................. 16 

Core Bugs # 132684: Incorrect Screen Name Displayed After Navigating from ‘My 
Documents (My Office)’ via Client Search ......................................................................... 16 

Core Bugs # 132789: The word "Old" is added after the 'MM/DD/YYYY <years/months>' 
format in the 'Date of Birth' field of Client information tooltip .............................................. 16 

Core Bugs # 132736: Client Information C screen: Irrelevant validation message is 
displayed when user tries to insert records into ‘List Of Releases' grid.............................. 16 

Client MAR ........................................................................................................................... 17 

Core Bugs # 132559: The ‘Admin in Last 24 Hours’ field is updated with the dose value in 
the ‘Client MAR’ screen when the Medication is administered with statuses such as 
‘Refuse’, ‘Not Given’, or ‘Initial Refusal - Not Given’. ......................................................... 17 

Core Bugs # 132728: Client Order Details: Error on clicking History of Administration tab 17 

Core Bugs # 132848: Client MAR and Group MAR: Any changes to the dispense time will 
always create additional MAR records, and not remove the original dispense time. .......... 18 

Client Orders ........................................................................................................................ 19 

Core Bugs # 132583: ‘Clinic/Location’ selected from the drop-down in the ‘Order’ tab is not 
correctly displayed in the ‘Preference’ tab of the ‘Client Orders Details’ screen................. 19 

Core Bugs # 132791: Laboratory Details Fetching Logic Changes ................................... 19 

Core Bugs # 132799: Service Not Being Created from Lab Order .................................... 20 

Core Bugs # 132802: MAT: Received an Error on MAT Management when attempting to 
create an order.................................................................................................................. 20 

Core Bugs # 132826: Client Order PDF: Medication Instructions incorrectly showing on the 
Medication row .................................................................................................................. 21 

Core Bugs # 132857: lab results with wrong client information in the Lab Result PDF in the 
SmartCare ........................................................................................................................ 21 

Client Search ........................................................................................................................ 22 

Core Bugs # 132236: To disable the barcode scanning functionality, a new System 
Configuration Key "EnableBarcodeScanning" is implemented. ......................................... 22 

Clinical Data Access Groups ................................................................................................ 22 

Core Bugs # 132213: Selected Program was getting cleared upon Refreshing the Browser
 ......................................................................................................................................... 22 

Core Assessment ................................................................................................................. 23 

Core Bugs # 132792: Assessment (C) : Error: Sub report could not be shown ................. 23 

Core Bugs # 132852: Assessment ( C ): When the document is saved in the CATS tab and 
then navigated to the Needs tab, blank screen is displayed .............................................. 23 

Crisis Call Log ...................................................................................................................... 24 

Core Bugs # 132696: Crisis Call Log list Page: Duplicate records were displayed. ........... 24 



SmartCare Release Notes  

      

 

Core Bugs # 132721: Crisis Call Log Details screen: Treatment team member was blank in 
the Client Information (Potential) section ........................................................................... 24 

Dashboard ............................................................................................................................ 24 

Core Bugs # 132628: Widget column headers showing attribute name instead of display as 
Value ................................................................................................................................ 24 

Core Bugs # 132718: Tracking Widget Radio Buttons Not Working Properly .................... 25 

Documents ........................................................................................................................... 25 

Core Bugs # 132537: Documents: Reviewer Co-signer issue. .......................................... 25 

Core Bugs # 132547: Inactive staff were displayed in Acknowledgements and Comments 
section for “To Acknowledge” status. ................................................................................ 25 

Core Bugs # 132581: PHQ-9 and PHQ-A document – ‘Addition Questions’ section still 
displays even if the system configuration is turned off. ...................................................... 26 

Core Bugs # 132677: The ‘Remain open’ programs are not displayed in the PDF of the 3rd 
and 4th versions of the ‘Agency/Program Discharge’ document. ....................................... 26 

Core Bugs # 132724: All the Documents are not listed in ‘Attach/Review Documents’ and 
‘Associate Documents’ popups. ........................................................................................ 27 

Core Bugs # 132759: When staff tried to add client to cosign, wrong staff name was 
populating in the cosigner list. ........................................................................................... 27 

Dynamic Forms (DFA) .......................................................................................................... 27 

Core Bugs # 132542: The label-type Form Item in the ‘Custom’ tab did not display the ID 
value (ID field appeared blank). ........................................................................................ 28 

Core Bugs # 132555: BQuIP - SUD Screening document radio button display issue. ....... 28 

Error Log .............................................................................................................................. 28 

Core Bugs # 132646: Documents: Errorlog issue .............................................................. 28 

Core Bugs # 132665: Errorlog was getting logged when a user attempted to login to 
SmartCare application....................................................................................................... 28 

Flow Sheet ........................................................................................................................... 29 

Core Bugs # 132692: Flow sheet List Page: Health Data element description name does 
not fit in the column ........................................................................................................... 29 

Group Services ..................................................................................................................... 29 

Core Bugs # 132595: When services are created from ‘Group Services’, the ‘Client was 
Present’ checkbox appears checked on the ‘Service Detail’ screen. ................................. 29 

Core Bugs # 132705: Recurring Group Services have old diagnosis attached to recurring 
services and do not update when diagnosis is updated. .................................................... 30 

Core Bugs # 132715: Groups: Duplicate services are created for the client. ..................... 30 

Core Bugs # 132820: Getting an error message when trying to open services from the 
‘Document To Do’ widget. ................................................................................................. 31 

Core Bugs # 132876: Group Services – Mode of Delivery issues. .................................... 31 

Inquiry .................................................................................................................................. 31 



SmartCare Release Notes  

      

 

Core Bugs # 132350: The ‘Ethnicity’, ‘Race’ and ‘Client declined to Provide’ field code 
names were sorted ‘Alphabetically’ not based on ‘Sort Order’ ........................................... 31 

Core Bugs # 132532: Inquiry Save Restricted: Missing Staff or Workgroup error .............. 32 

Core Bugs # 131825: MAT: System is allowing Pre pour the future Face To Face dose and 
to be dispensed................................................................................................................. 33 

Core Bugs # 132415: MAT: Client Column on ‘MAT Management’ List Page is too Narrow 
and ‘Bottle/Box ID’ Limited to 5 Characters on the ‘Medication/Lot/Bottle Details’ Screen. 33 

Core Bugs # 132488: MAT: Incorrect status is displayed in MAT Management List page 
after a Take Home and Face to Face dispense. ................................................................ 34 

Core Bugs # 132647: Issues in the ‘MAT Management Details’ screen ............................ 34 

Core Bugs # 132685: MAT: ‘Units’ dropdown value is defaulted to 'mg' in the 
‘Medication/Lot/Bottle Details’ screen. ............................................................................... 35 

Core Bugs # 132726: MAT - Dispense History Grid Cutting off Rows of Data ................... 35 

Core Bugs # 132730: MAT: Successful dispense is not displayed on the MAT Management 
list and details pages Core Bugs ....................................................................................... 35 

Core Bugs # 132731: MAT: Stuck in infinite loop after Calibration process when saying 'No' 
to Unprime prompt ............................................................................................................ 36 

Core Bugs # 132755: MAT - MAT Medication Mapping incorrect within Recode 
SetMedicationForMATMultiInventoryDispense .................................................................. 36 

Core Bugs # 132764: MAT: Program Filter on MAT Management List page is not working.
 ......................................................................................................................................... 37 

Core Bugs # 132821: Med/lot/bottle bulk insert ................................................................. 37 

Mobile................................................................................................................................... 37 

Core Bugs # 132707: The PDF incorrectly displayed the clinician’s signing suffix next to the 
client’s name when signed via the mobile WebApp. .......................................................... 37 

My Calendar ......................................................................................................................... 38 

Core Bugs # 132663: Slowness in the Staff Calendar screen. .......................................... 38 

Core Bugs # 132739: My Calendar: Issue with using Quotation Mark in ‘Comments’ section 
while creating a Service .................................................................................................... 38 

Core Bugs # 132811: New Calendar Entry items not synching with Outlook ..................... 38 

My Reports/UDS Reports ..................................................................................................... 38 

Core Bugs # 132321: The ‘ClientWasPresent’ flag is not present in the ‘Services with 
Procedure Rate Errors’ Report .......................................................................................... 39 

Core Bugs # 132572: ‘Payment Receipt Report’ Issue. ..................................................... 39 

Core Bugs # 132709: Getting an error when generating ‘ER Claim Line Details’ or ‘ER 
Claim Line Details CSV’ reports. ....................................................................................... 39 

Core Bugs # 132796: Reports name not displayed correctly in search bar. ....................... 40 

Core Bugs # 132847: Some fields are removed from the XML files for some record types in 
the IPFQR List Page. ........................................................................................................ 40 



SmartCare Release Notes  

      

 

Core Bugs # 132858: Incident Reports list page and widget not showing accurate number 
of incidents. ....................................................................................................................... 40 

Patient Portal ........................................................................................................................ 41 

Core Bugs # 132538: Patient Portal login issue ................................................................ 41 

Plans .................................................................................................................................... 41 

Core Bugs # 132437: Coverage: Leading/trailing spaces are preventing the duplicate 
prevention validation message from triggering correctly. ................................................... 41 

Procedures/Rates ................................................................................................................. 41 

Core Bugs # 132551: expired ProcedureRateId are retrieving when service is created..... 42 

Programs .............................................................................................................................. 42 

Core Bugs # 132617: The ‘Assigned Staff’ dropdown excluded inactive staff for existing 
client program entries in the ‘Program Assignment Details’ page. ..................................... 42 

Provider Contract ................................................................................................................. 42 

Core Bugs # 132717: The Contract Details screen was labeled with the same name in both 
the Provider Contracts and Contracts screens. ................................................................. 43 

Reception ............................................................................................................................. 43 

Core Bugs # 132641: The Appointment is duplicating when attempting to reschedule. ..... 43 

Rx Application ...................................................................................................................... 43 

Core Bugs # 132267: Start page: Outbound Prescribers are displayed as blank when 
filtered by clinicians in the database while running the specific stored procedure. ............. 43 

Core Bugs # 132592: RX - Patient Summary - Medication list is not loading. .................... 44 

Core Bugs # 132625: Rx: duplicate instructions were displayed for existing client order 
under the Medication List section in the Patient Summary page. ...................................... 44 

Core Bugs # 132813: Slowness when navigating from SmartCare to Rx. ......................... 44 

Core Bugs # 132854: The ‘X’ button was visible for SmartCare Orders in the Patient 
Summary screen, despite being non-functional. ................................................................ 44 

Core Bugs # 132855: Inactive allergies are displayed in the ‘Current Allergies’ widget of 
SmartView.. ...................................................................................................................... 45 

Scanning .............................................................................................................................. 45 

Core Bugs # 131096: ‘Acknowledgements’ and ‘Acknowledge with Comments/ Forward 
Acknowledgement’ icons are not showing as intent in Scanned and Uploaded Documents
 ......................................................................................................................................... 45 

Screens ................................................................................................................................ 45 

Core Bugs # 132495: The disabled delete (X)icon in Custom grid was getting activated for 
the restricted Staffs and Roles .......................................................................................... 45 

Services from Claims ............................................................................................................ 46 

Core Bugs # 132476: MCO-PM Transfer: Claim Count Did not match at the different steps 
in the process. .................................................................................................................. 46 

Services ............................................................................................................................... 46 



SmartCare Release Notes  

      

 

Core Bugs # 132282: The calculation of the procedure rate was not correct, when a service 
was created ...................................................................................................................... 47 

Core Bugs # 132385: Services: application allowed the users to change the service’s status 
from Complete to No Show across browsers. ................................................................... 47 

Core Bugs # 132603: Separate Dx code for Add On services in Primary Care ................. 47 

Core Bugs # 132635: Individual services just "popped up" in the last 5 hours. .................. 48 

Core Bugs # 132699: Batch Service Import: Upload New Services pop up is displayed 
blank. ................................................................................................................................ 48 

Core Bugs # 132765: a “Timeout Expired” error is logged in the ‘ErrorLog’ table. ............. 48 

Core Bugs # 132785: ‘Services (My Office) List’ page: Implemented a new ‘Failed Services’ 
pop-up for error and mass complete for services. ............................................................. 48 

Services/Notes ..................................................................................................................... 49 

Core Bugs # 132531: The client name is not displayed when opening a private window from 
the ‘Service Note’ page. .................................................................................................... 49 

Core Bugs # 132582: The client name is not displayed when opening a private window from 
the ‘Service Note’ page. .................................................................................................... 50 

Core Bugs # 132620: JavaScript error is logged on the ‘ErrorLogViewer’. ........................ 50 

Core Bugs # 132706: The ‘GOALOBJECTIVESTATUS’ Global Code Sort Order is not 
being honored in the DFA note. ........................................................................................ 50 

SmartCare improvements ..................................................................................................... 50 

Core Bugs # 132535: list pages: Export Button Fails to Generate Download .................... 51 

Core Bugs # 132834 ......................................................................................................... 51 

Staff/Users ........................................................................................................................... 52 

Core Bugs # 132880: The credentialing grid failed to load all existing details in the 
‘Credentialing’ tab of the ‘Staff Details’ screen. ................................................................. 52 

Work Groups list screen ....................................................................................................... 52 

Core Bugs # 132727: The ‘Export’ Functionality is not working in the ‘Work Groups’ List 
Page ................................................................................................................................. 52 

Global Codes ........................................................................................................................... 53 

Recodes................................................................................................................................... 53 

Configuration Keys ................................................................................................................... 53 

Data Model Changes ............................................................................................................... 54 

SmartCare Testing Strategy – August 2025 MSP ................................................................. 55 

How to Use This Strategy ................................................................................................. 55 

Testing Workflow by Module – Core Bugs Only .................................................................... 55 

Adhoc Reporting ............................................................................................................... 55 

Alerts ................................................................................................................................ 55 

Authorizations ................................................................................................................... 55 

Batch Eligibility .................................................................................................................. 55 



SmartCare Release Notes  

      

 

Batch Services .................................................................................................................. 55 

Bedboard .......................................................................................................................... 56 

Charges/Claims ................................................................................................................ 56 

Rx Application / Patient Summary ..................................................................................... 56 

Scanning ........................................................................................................................... 56 

Screens / UI Controls ........................................................................................................ 56 

Services from Claims ........................................................................................................ 56 

Services ............................................................................................................................ 56 

Services/Notes .................................................................................................................. 57 

SmartCare Improvements ................................................................................................. 57 

Staff/Users ........................................................................................................................ 57 

Revision History ....................................................................................................................... 58 

 



SmartCare Release Notes 

1 

Audience 

These release notes are for general SmartCare™ users trained in the basic workflow and use of 
SmartCare™.  

Applicable Releases 

The functionality documented these release notes supports SC.CORE.6.0_1.37.000.2508.001 and later.  

Permissions 

You can only access screens/items granted per your user login referred to as Permissions. Depending on 
your current level of permissions, you may need to contact your system administrator to have your 
permissions changed.  

Global Codes, Recodes, and Configuration Keys 

Refer to the Global Codes, Recodes, and Configuration Keys sections of these release notes for a list 
and definition of each code or key.  
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TASKS LIST-‘DEFECT FIXES’ (107) 
Note: Defect fixes address issues or errors in the system to restore expected functionality and improve 
overall performance. 

Sl. 
No 

Task No Summary Module Name 

4 Core Bugs # 
132752 

The saved reports are not displayed under 
the selected catalog Report section list. 

Adhoc Reporting 

5 Core Bugs # 
132561 

Error displayed when service note is 
accessed from Alerts screen and signed. 

Alerts 

7 Core Bugs # 
132763 

Service Request – Review/Approval Detail: 
The ‘Review Status’ is not updating to 
‘Completed’ status. 

Authorizations 

10 Core Bugs # 
132653 

The Batch Eligibility Configuration Id to be 
mapped with Existing Configuration Id of 
Clearing House. 

Batch Eligibility 

11 Core Bugs # 
132632 

Some of the services created from the Batch 
Service Entry were missing 

Batch Services 

 

12 Core Bugs # 
132890 

Batch service import is failing to upload the 
file 

Batch Services 

13 Core Bugs # 
132626 

Program still appeared on the ‘Programs’ list 
page even though both Bed Assignment 
Activity and Inpatient Activity records are 
deleted for a discharged client 

Bed Board 

14 Core Bugs # 
132816 

Bedboard: duplicating a bed assignment Bedboard 

16 Core Bugs # 
132145 

‘Allowed Amount Adjustment' column field 
was not defaulted from the template plan if 
not specified 

Charges/Claims 

17 Core Bugs # 
132234 

Adjustments in 835 process calculate 
rounding fix incorrectly 

Charges/Claims 

18 Core Bugs # 
132548 

Qualifying CCBHC Services not in Batch error 
not generating if one of the qualifying 
services has a Claims Generation Error 

Charges/Claims 

19 Core Bugs # 
132578 

The ‘Payer’ field incorrectly defaulted to 
‘Commercial’ instead of ‘Select Electronic 
Remittance sender’ in the Electronic 
Remittance pop-up screen 

Charges/Claims 

20 Core Bugs # 
132589 

Decimal Claim unit values are rounded off to 
integer 

Charges/Claims 
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21 Core Bugs # 
132824 

The 'Allowed Amount Adjustments' job step 
encountered a failure during the Nightly 
Billing job due to an issue with the length of 
the Place of Service value 

Charges/Claims 

22 Core Bugs # 
132501 

‘Problem Details’ diagnoses were not being 
saved to the ‘Most Common Problems’ 
dropdown 

Client Clinical Problems 

23 Core Bugs # 
130636 

Issues in the ‘Client Education Resources’ 
screen 

Client Education Resource 

25 Core Bugs # 
132557 

‘Address Type 0’ entries in tables 
‘ClientAddresses’ and ‘ClientAddressHistory’ 
being generated as Bad Data 

Client Information 

26 Core Bugs # 
132601 

Client Information (Admin): in the ‘Contacts’ 
tab, the phone numbers are not appearing 

Client Information 

27 Core Bugs # 
132684 

Incorrect Screen Name Displayed After 
Navigating from ‘My Documents (My Office)’ 
via Client Search 

Client Information 

28 Core Bugs # 
132789 

The word "Old" is added after the 
'MM/DD/YYYY <years/months>' format in the 
'Date of Birth' field of Client information tooltip 

Client Information 

29 Core Bugs # 
132736 

Client Information C screen: Irrelevant 
validation message is displayed when user 
tries to insert records into ‘List Of Releases' 
grid 

Client Information C Screen 

30 Core Bugs # 
132559 

The ‘Admin in Last 24 Hours’ field is updated 
with the dose value in the ‘Client MAR’ screen 
when the Medication is administered with 
statuses such as ‘Refuse’, ‘Not Given’, or 
‘Initial Refusal - Not Given’. 

Client MAR 

31 Core Bugs # 
132728 

Client Order Details: Error on clicking History 
of Administration tab 

Client MAR 

32 Core Bugs # 
132848 

Client MAR and Group MAR: Any changes to 
the dispense time will always create 
additional MAR records, and not remove the 
original dispense time. 

Client MAR 

37 Core Bugs # 
132583 

‘Clinic/Location’ selected from the drop-down 
in the ‘Order’ tab is not correctly displayed in 
the ‘Preference’ tab of the ‘Client Orders 
Details’ screen. 

Client Orders 

38 Core Bugs # 
132791 

Laboratory Details Fetching Logic Changes Client Orders 

39 Core Bugs # 
132799 

Service Not Being Created from Lab Order Client Orders 
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40 Core Bugs # 
132802 

MAT: Received an Error on MAT 
Management when attempting to create an 
order. 

Client Orders 

41 Core Bugs # 
132826 

Client Order PDF: Medication Instructions 
incorrectly showing on the Medication row 

Client Orders 

42 Core Bugs # 
132857 

lab results with wrong client information in the 
Lab Result PDF in the SmartCare 

Client Orders 

43 Core Bugs # 
132236 

To disable the barcode scanning functionality, 
a new System Configuration Key 
"EnableBarcodeScanning" is implemented. 

Client Search 

44 Core Bugs # 
132213 

Selected Program was getting cleared upon 
Refreshing the Browser 

Clinical Data Access Grouping 

49 Core Bugs # 
132792 

Assessment (C) : Error: Sub report could not 
be shown 

Core Assessment 

50 Core Bugs # 
132852 

Assessment ( C ): When the document is 
saved in the CATS tab and then navigated to 
the Needs tab, blank screen is displayed. 

Core Assessment 

51 Core Bugs # 
132696 

Crisis Call Log list Page: Duplicate records 
were displayed 

Crisis Call Log 

52 Core Bugs # 
132721 

Crisis Call Log Details screen: Treatment 
team member was blank in the Client 
Information (Potential) section 

Crisis Call Log 

53 Core Bugs # 
132628 

Widget column headers showing attribute 
name instead of display as Value 

Dashboard 

54 Core Bugs # 
132718 

Tracking Widget Radio Buttons Not Working 
Properly 

Dashboard 

60 Core Bugs # 
132537 

Documents: Reviewer Co-signer issue. Documents 

61 Core Bugs # 
132547 

Inactive staff were displayed in 
Acknowledgements and Comments section 
for “To Acknowledge” status. 

Documents 

62 Core Bugs # 
132581 

PHQ-9 and PHQ-A document – ‘Addition 
Questions’ section still displays even if the 
system configuration is turned off. 

Documents 

63 Core Bugs # 
132677 

The ‘Remain open’ programs are not 
displayed in the PDF of the 3rd and 4th 
versions of the ‘Agency/Program Discharge’ 
document. 

Documents 

64 Core Bugs # 
132724 

All the Documents are not listed in 
‘Attach/Review Documents’ and ‘Associate 
Documents’ popups. 

Documents 
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65 Core Bugs # 
132759 

When staff tried to add client to cosign, wrong 
staff name was populating in the cosigner list. 

Documents 

67 Core Bugs # 
132542 

The label-type Form Item in the ‘Custom’ tab 
did not display the ID value (ID field appeared 
blank). 

Dynamic Forms (DFA) 

68 Core Bugs # 
132555 

BQuIP - SUD Screening document radio 
button display issue. 

Dynamic Forms (DFA) 

69 Core Bugs # 
132646 

Documents: Errorlog issue Errorlog 

70 Core Bugs # 
132665 

Errorlog was getting logged when a user 
attempted to login to SmartCare application 

Errorlog 

71 Core Bugs # 
132692 

Flow sheet List Page: Health Data element 
description name does not fit in the column 

Flow Sheet 

73 Core Bugs # 
132595 

Recurring Group Services have old diagnosis 
attached to recurring services and do not 
update when diagnosis is updated. 

Group Services 

74 Core Bugs # 
132705 

Recurring Group Services have old diagnosis 
attached to recurring services and do not 
update when diagnosis is updated. 

Group Services 

75 Core Bugs # 
132715 

Groups: Duplicate services are created for 
the client. 

Group Services 

76 Core Bugs # 
132820 

Getting an error message when trying to open 
services from the ‘Document To Do’ widget. 

Group Services 

77 Core Bugs # 
132876 

Group Services – Mode of Delivery issues. Group Services 

78 Core Bugs # 
132350 

The ‘Ethnicity’, ‘Race’ and ‘Client declined to 
Provide’ field code names were sorted 
‘Alphabetically’ not based on ‘Sort Order’ 

Inquiry 

79 Core Bugs # 
132532 

Inquiry Save Restricted: Missing Staff or 
Workgroup error 

Inquiry 

82 Core Bugs # 
131825 

MAT: System is allowing Pre pour the future 
Face To Face dose and to be dispensed. 

Methadone 

84 Core Bugs # 
132415 

MAT: Client Column on ‘MAT Management’ 
List Page is too Narrow and ‘Bottle/Box ID’ 
Limited to 5 Characters on the 
‘Medication/Lot/Bottle Details’ Screen.  

Methadone 

85 Core Bugs # 
132488 

MAT: Incorrect status is displayed in MAT 
Management List page after a Take Home 
and Face to Face dispense. 

Methadone 

86 Core Bugs 
#132647 

Issues in the ‘MAT Management Details’ 
screen 

Methadone 



SmartCare Release Notes  

      

 

87 Core Bugs # 
132685 

MAT: ‘Units’ dropdown value is defaulted to 
'mg' in the ‘Medication/Lot/Bottle Details’ 
screen. 

Methadone 

88 Core Bugs # 
132726 

MAT - Dispense History Grid Cutting off Rows 
of Dat 

Methadone 

89 Core Bugs # 
132730 

MAT: Successful dispense is not displayed on 
the MAT Management list and details pages. 

Methadone 

90 Core Bugs # 
132731 

MAT: Stuck in infinite loop after Calibration 
process when saying 'No' to Unprime prompt 

Methadone 

91 Core Bugs # 
132755 

MAT - MAT Medication Mapping incorrect 
within Recode 
SetMedicationForMATMultiInventoryDispense 

Methadone 

92 Core Bugs # 
132764 

MAT: Program Filter on MAT Management 
List page is not working. 

Methadone 

93 Core Bugs # 
132821 

Med/lot/bottle bulk insert Methadone 

94 Core Bugs # 
132707 

The PDF incorrectly displayed the clinician’s 
signing suffix next to the client’s name when 
signed via the mobile WebApp. 

Mobile 

96 Core Bugs # 
132663 

3 Slowness in the Staff Calendar screen. My Calendar 

97 Core Bugs # 
132739 

My Calendar: Issue with using Quotation 
Mark in ‘Comments’ section while creating a 
Service 

My Calendar 

98 Core Bugs # 
132811 

New Calendar Entry items not synching with 
Outlook 

My Calendar 

111 Core Bugs # 
132321 

The ‘ClientWasPresent’ flag is not present in 
the ‘Services with Procedure Rate Errors’ 
Report. 

My Reports 

112 Core Bugs # 
132572 

Payment Receipt Report’ Issue. My Reports 

113 Core Bugs # 
132709 

Getting an error when generating ‘ER Claim 
Line Details’ or ‘ER Claim Line Details CSV’ 
reports. 

My Reports 

114 Core Bugs # 
132796  

Reports name not displayed correctly in 
search bar. 

My Reports 

115 Core Bugs # 
132847 

Some fields are removed from the XML files 
for some record types in the IPFQR List 
Page. 

My Reports 

116 Core Bugs # 
132858 

Incident Reports list page and widget not 
showing accurate number of incidents. 

My Reports 
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118 Core Bugs # 
132538 

Patient Portal login issue. Patient Portal 

119 Core Bugs # 
132437 

Coverage: Leading/trailing spaces are 
preventing the duplicate prevention validation 
message from triggering correctly. 

Plans 

121 Core Bugs # 
132551 

Expired ProcedureRateId are retrieving when 
service is created. 

Procedures/Rates 

122 Core Bugs # 
132617 

The ‘Assigned Staff’ dropdown excluded 
inactive staff for existing client program 
entries in the ‘Program Assignment Details’ 
page. 

Programs 

123 Core Bugs # 
132717 

The Contract Details screen was labeled with 
the same name in both the Provider 
Contracts and Contracts screens 

Provider Contract 

125 Core Bugs # 
132641 

The Appointment is duplicating when 
attempting to reschedule. 

Reception 

131 Core Bugs # 
132267 

Start page: Outbound Prescribers are 
displayed as blank when filtered by clinicians 
in the database while running the specific 
stored procedure. 

Rx Application 

132 Core Bugs # 
132592 

RX - Patient Summary - Medication list is not 
loading. 

Rx Application 

133 Core Bugs # 
132625 

Rx: duplicate instructions were displayed for 
existing client order under the Medication List 
section in the Patient Summary page 

Rx Application 

134 Core Bugs # 
132813 

Slowness when navigating from SmartCare to 
Rx 

Rx Application 

135 Core Bugs # 
132854 

The ‘X’ button was visible for SmartCare 
Orders in the Patient Summary screen, 
despite being non-functional. 

Rx Application 

136 Core Bugs # 
132855 

Inactive allergies are displayed in the ‘Current 
Allergies’ widget of SmartView. 

Rx Application 

137 Core Bugs # 
131096 

‘Acknowledgements’ and ‘Acknowledge with 
Comments/ Forward Acknowledgement’ icons 
are not showing as intent in Scanned and 
Uploaded Documents 

Scanning 

139 Core Bugs # 
132495 

The disabled delete (X)icon in Custom grid 
was getting activated for the restricted Staffs 
and Roles 

Screens 

140 Core Bugs # 
132476 

MCO-PM Transfer: Claim Count Did not 
match at the different steps in the process. 

Service from Claims 
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142 Core Bugs # 
132282 

The calculation of the procedure rate was not 
correct, when a service was created 

Services 

143 Core Bugs # 
132385 

Services: application allowed the users to 
change the service’s status from Complete to 
No Show across browsers. 

Services 

144 Core Bugs # 
132603 

Separate Dx code for Add On services in 
Primary Care 

Services 

145 Core Bugs # 
132635 

Individual services just "popped up" in the last 
5 hours. 

Services 

146 Core Bugs # 
132699 

Batch Service Import: Upload New Services 
pop up is displayed blank. 

Services 

147 Core Bugs # 
132765 

a “Timeout Expired” error is logged in the 
‘ErrorLog’ table. 

Services 

148 Core Bugs # 
132785 

‘Services (My Office) List’ page: Implemented 
a new ‘Failed Services’ pop-up for error and 
mass complete for services. 

Services 

150 Core Bugs # 
132531 

The client name is not displayed when 
opening a private window from the ‘Service 
Note’ page. 

Services/Notes 

151 Core Bugs # 
132582 

The system was not displaying all the 
available procedures in the dropdown, 
regardless of the selected program. 

Services/Notes 

152 Core Bugs # 
132620 

JavaScript error is logged on the 
‘ErrorLogViewer’. 

Services/Notes 

153 Core Bugs # 
132706 

The ‘GOALOBJECTIVESTATUS’ Global 
Code Sort Order is not being honored in the 
DFA note. 

Services/Notes 

154 Core Bugs # 
132535 

list pages: Export Button Fails to Generate 
Download 

SmartCare improvements 

155 Core Bugs # 
132834 

Unsupported Browser Warning for Microsoft 
Edge Mobile on SmartCare 

SmartCare improvements 

156 Core Bugs # 
132880 

The credentialing grid failed to load all 
existing details in the ‘Credentialing’ tab of 
the ‘Staff Details’ screen. 

Staff/Users 

157 Core Bugs # 
132727 

The ‘Export’ Functionality is not working in the 
‘Work Groups’ List Page 

Work Groups list screen 

Functionality Task Details 

Adhoc Reporting 
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Reference No Task No Description 

4 Core Bugs #132752 The saved reports are not displayed under the selected 
catalog Report section list. 

Core Bugs # 132752: The saved reports are not displayed under the selected catalog 
Report section list. 

What’s fixed: Saved reports were not appearing under the selected Catalog Report section in the Ad-
hoc Reporting screen when staff members without access to the Share Report – Adhoc screen 
changed the catalog from the dropdown. 

The system now correctly displays saved reports under the selected catalog, regardless of the user's 
access to the Share Report – Adhoc screen. 

Where to find it: 
My Office → Search Ad-hoc Reporting → Catalogs dropdown → Change catalog → Verify saved 
reports under selected catalog 

Alerts 

Reference No Task No Description 

5 Core Bugs # 132561 Error displayed when service note is accessed from 

Alerts screen and signed 

 

Core Bugs # 132561: Error displayed when service note is accessed from Alerts screen 

and signed 

 

What’s fixed: Previously, when staff accessed a service note with ‘In Progress’ status from the Alerts 
screen and attempted to Save or Sign, the system displayed an error message: 
“Saved Successfully. Error occurred while loading screen.” 

The error message no longer appears when signing or saving service notes accessed from the Alerts 
screen. 

Where to find it: 
My Office → Alerts → Access a service note with status “In Progress” → Save or Sign 

Authorizations 

Reference No Task No Description 

7 Core Bugs # 132763 Service Request – Review/Approval Detail: The ‘Review 
Status’ is not updating to ‘Completed’ status. 

Core Bugs # 132763: Service Request – Review/Approval Detail: The ‘Review Status’ is not 
updating to ‘Completed’ status. 

What’s fixed: In the Service Request – Review/Approval Detail screen, the Review Status was not 
updating to Completed after saving multiple entries in the Service Request Details grid. This caused 
confusion and incomplete tracking of review progress. 

The system now automatically updates the Review Status to Completed when multiple records are 
inserted and saved in the Service Request Details section, ensuring accurate status tracking. 

Where to find it: 
Client → Search → Select a Client → Service Request – Review/Approval List → New → Approval 
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tab → Service Request Details → Fill required fields → Check Generate Authorization → Insert → 
Save → Add another record → Insert → Save 

Batch Eligibility  

Reference No Task No Description 

10 Core Bugs # 132653 The Batch Eligibility Configuration Id to be mapped with 
Existing Configuration Id of Clearing House.   

Core Bugs # 132653: The Batch Eligibility Configuration Id to be mapped with Existing 
Configuration Id of Clearing House.   

What’s fixed: In the Batch Eligibility Configurator, new records were incorrectly creating duplicate 
entries in the ElectronicEligibilityVerificationConfigurations table, and several fields were not 
validating or mapping correctly. This caused issues with clearing house selection and batch record 
creation. 

The system now correctly maps new batch records to an existing 
ElectronicEligibilityVerificationConfigurationId based on the selected Clearing House, preventing 
duplication and improving configuration accuracy. 

Key Fixes: 

• New batch records no longer create duplicate entries in the 
ElectronicEligibilityVerificationConfigurations table. 

• Records are now created in the ElectronicEligibilityVerificationConfigurationFeatures table using 
the existing configuration ID. 

• Each Clearing House is limited to one configuration record. 

• The Electronic Eligibility Verification Payer field now updates the ElectronicPayerNameMCD 
with the correct value in the CharacterValue column. 

• The Stored Procedure to Customize Eligibility Clients Update and Final Result Set fields 
now only accept the underscore (_) symbol. 

• The Clearing House dropdown only displays records that exist in the 
ElectronicEligibilityVerificationConfigurations table. 

• If only one Clearing House exists, the dropdown defaults to blank, requiring manual selection. 
The system then correctly sets the configuration ID based on the selected Clearing House. 

Where to find it: 
Administration → Batch Eligibility Configurator List → New → Batch Eligibility Configurator 
Details → Fill required tabs → Save 

Batch Services 

Reference No Task No Description 

11 Core Bugs # 132632 Some of the services created from the Batch Service 

Entry were missing.   

12 Core Bugs # 132890 Batch service import is failing to upload the file. 

Core Bugs # 132632: Some of the services created from the Batch Service Entry were 

missing.   

What’s fixed: Some services created through Batch Service Entry were not appearing in the Services 
list for selected clients and dates. 

All services created via Batch Service Entry now display correctly in the Services list. 
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Where to find it: 

Option 1: Go to Batch Service Entry → Create services for multiple clients and dates → Save 

Option 2: Search for a client → Go to Services (Client) → Apply filters → Confirm all batch-created 
services are listed 

Core Bugs # 132890: Batch service import is failing to upload the file. 

What’s fixed: File uploads in the Batch Service Import screen were failing when the Time column in the 
file was formatted as Text, General, or any non-standard format. Users saw a blank popup and the 
following error message: 

Error Message: 
“Conversion failed when converting date and/or time from character string. The data for table-valued 
parameter "@BatchServiceDataTable" doesn't conform to the table type of the parameter. SQL Server 
error is: 241, state: 1. The statement has been terminated.” 

The system now successfully accepts files regardless of how the Time column is formatted (Text, 
General, or Time). No error messages are displayed, and the upload process works as expected. 

Where to find it: 
Batch Service Import Files → Select file → Click Upload → Services (My Office) 

Bedboard 

Reference No Task No Description 

13 Core Bugs # 132626 Program still appeared on the ‘Programs’ list page even 
though both Bed Assignment Activity and Inpatient Activity 
records are deleted for a discharged client. 

14 Core Bugs # 132816 Bedboard: duplicating a bed assignment 

Core Bugs # 132626: Program still appeared on the ‘Programs’ list page even though both 
Bed Assignment Activity and Inpatient Activity records are deleted for a discharged client. 

What’s fixed: In the Programs list page, a bed program continued to appear for discharged clients even 
after both the Bed Assignment Activity and Inpatient Activity records were deleted. This caused 
outdated program data to remain visible. 

The system now correctly removes the bed program from the Programs list once both related activity 
records are deleted for a discharged client, ensuring accurate program tracking. 

Where to find it: 

1. My Office → Bedboard → Bedboard list page → Select discharged bed 
→ Click Discharged status → Inpatient Activity Details → Delete 
→ Click Occupied status → Delete 

2. Client → Programs → Programs list page 

 

Core Bugs # 132816: Bedboard: duplicating a bed assignment 

What’s fixed: In Bedboard, duplicate bed assignments were being created when users admitted, 
transferred, or discharged clients. This led to inaccurate occupancy data and confusion in bed tracking. 
The system now prevents duplicate bed assignments during these actions, ensuring accurate and reliable 
bed status updates. 

Where to find it: 
My Office → Bedboard → Bedboard list page → Select Occupied from All Status dropdown → 
Apply Filter 
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Charges/Claims 

Reference No Task No Description 

16 Core Bugs #132145 ‘Allowed Amount Adjustment' column field was not 
defaulted from the template plan if not specified. 

17 Core Bugs # 132234 Adjustments in 835 process calculate rounding fix 
incorrectly 

18 Core Bugs # 132548 Qualifying CCBHC Services not in Batch error not 
generating if one of the qualifying services has a Claims 
Generation Error 

19 Core Bugs # 132578 The ‘Payer’ field incorrectly defaulted to ‘Commercial’ 
instead of ‘Select Electronic Remittance sender’ in the 
Electronic Remittance pop-up screen.  

20 Core Bugs # 132589 Decimal Claim unit values are rounded off to integer 

21 Core Bugs # 132824 The 'Allowed Amount Adjustments' job step encountered 
a failure during the Nightly Billing job due to an issue with 
the length of the Place of Service value 

Core Bugs # 132145: ‘Allowed Amount Adjustment' column field was not defaulted from 
the template plan if not specified. 

What’s fixed: The Allowed Amount Adjustment field was not defaulting from the template plan when 
the Client Coverage Plan was not configured with the On Charge Creation option. As a result, the 
adjustment job failed to apply default values, leaving charge balances unadjusted. 

The system now correctly defaults to values from the template plan during the Allowed Amount 
Adjustment job, even when On Charge Creation is not selected in the client plan. 

Where to find it:  

• Plan Setup: 
Go to Administration → Billing Setup → Plans → Select or create a plan → Plan Details 
screen → Payments and Adjustments tab. 

• Client Plan Association: 
Go to Client search → Finance → Coverage → Add a new plan → Set Start Date and COB 
Order → Confirm plan appears in Plans Time Span. 

• Charge Creation: 
Go to Client search → Services → Create and complete a service → Click Charge → Ledger 
Entries → Click Charge ID → Charge Details → General tab → Financial Information section. 

 

Core Bugs # 132234: Adjustments in 835 process calculate rounding fix incorrectly 

What’s fixed: Previously, when processing an 835 file containing both primary and secondary charge 
payments (with CLP02 = 2), the system incorrectly calculated and applied rounding adjustments. This 
caused inaccurate payment and transfer distributions across services grouped under the same 
claimLineItemGroupID. 

The system now correctly applies the total payment and adjustment amounts to primary services, and 
the total transfer amounts to secondary services, ensuring accurate financial posting. 
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Pre-requisites: 

• Process an 835 file with both primary and secondary charge payments 

• Multiple primary services grouped under the same claimLineItemGroupID 

Where to find it: 
My Office → Payments/Adjustments → Electronic Remittance 

• Click on Import File ID → Electronic Remittance File Details pop-up 

• Click Process File → Save → Close 

• Review Ledger Screen for each service in the claim line group → Confirm correct payment, 
adjustment, and transfer amounts 

 

Core Bugs # 132548: Qualifying CCBHC Services not in Batch error not generating if one 
of the qualifying services has a Claims Generation Error 

What’s fixed:  

Previously, during 837 Professional claim generation for clients with a CCBHC coverage plan, if one of 
the component services encountered a claims generation error, the system still billed other qualifying 
CCBHC services. This led to inconsistent claim batches and missing error messages. 

The system now correctly prevents billing of all qualifying CCBHC services if any component service has 
a charge error. A specific error message is displayed: 

“Qualify CCBHC service not in this batch” 

Pre-requisites: 

• Client must be associated with a CCBHC coverage plan 

• Component services must be created 

Where to find it: 

1. Client Search → Select Client with CCBHC Coverage Plan 

• Administration → Procedure/Rates → Add-on Codes tab → Select procedure 

• Client → Services → Complete the service 
2. My Office → Charges and Claims 

• Select Charges → Click Electronic Claim → Claims Processing pop-up → Click Process 
Now 

• Review error message for services with claim generation issues 

 

Core Bugs # 132578: Decimal Claim unit values are rounded off to integer 

What’s fixed: Previously, when users opened the Electronic Remittance pop-up screen from the 
Payments/Adjustments section, the Payer field incorrectly defaulted to Commercial instead of Select 
Electronic Remittance sender. 

The Payer field correctly defaults to Select Electronic Remittance sender when the pop-up screen is 
accessed. 

Where to find it: 
Go Search → Enter/Select Payments/Adjustments (My Office) → Click Electronic Remittance icon → 
View Electronic Remittance pop-up screen 

Core Bugs # 132589: Decimal Claim unit values are rounded off to integer 



SmartCare Release Notes  

      

 

What’s fixed: Previously, when processing claims, decimal charge unit values were incorrectly rounded 
to whole numbers. Specifically: 

• Units between 0.1 and 0.5 were rounded down to 0, triggering a billing error. 

• Units between 0.5 and 0.9 were rounded up to 1, leading to inaccurate billing. 

This caused the following error message: 
"Zero Claim units. Please check Procedure Rate/Billing Codes." 

With this release, the system now retains decimal charge units as entered, ensuring accurate billing. 
Services with units between 0.1 and 0.9 are processed correctly, and the zero-unit error no longer 
appears. 

Where to find it: 
My Office → Billing → Charges/Claims → Select a claim → Click E-claim → Click Process Now → 
Create Claim File 

Core Bugs # 132824: The 'Allowed Amount Adjustments' job step encountered a failure 
during the Nightly Billing job due to an issue with the length of the Place of Service value 

What’s fixed: The Allowed Amount Adjustments job step in the Nightly Billing process was failing 
due to a string length issue with the Place of Service value. Specifically, if the External Code 1 value 
under the PLACEOFSERVICE global code category exceeded two characters, the job step would fail 
with a truncation error. 

The system now supports External Code 1 values up to 25 characters under the PLACEOFSERVICE 
category. The job step executes successfully even when longer Place of Service values are used. 

Pre-requisite: 

• Update the External Code 1 value of the PLACEOFSERVICE global code category to more than 
2 characters 

• Select the Place of Service under the General Information section of the Location tab in the 
Location Details screen 

Where to find it: 
N/A (automated job step in Nightly Billing) 

Client Clinical Problems 

Reference No Task No Description 

22 Core Bugs # 132501 ‘Problem Details’ diagnoses were not being saved to the 
‘Most Common Problems’ dropdown   

Core Bugs # 132501: ‘Problem Details’ diagnoses were not being saved to the ‘Most 
Common Problems’ dropdown   

 

What’s fixed: Previously, when users selected a diagnosis in the Problem Details screen and checked 
the Include in Common List box, the selected diagnosis was not being saved to the Most Common 
Problems dropdown, even after saving the record. 

The system now correctly saves diagnoses marked as favorites using the Include in Common List 
checkbox, and they are displayed in the Most Common Problems dropdown. 

Where to find it: 

Client → Problem Detail screen 
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• Search and select a diagnosis 

• Check Include in Common List 

• Select Type of Problem → Click Insert → Click Save 

• Confirm diagnosis appears in Most Common Problems dropdown 

Client Education Resource 

Reference No Task No Description 

23 Core Bugs # 130636 Issues in the ‘Client Education Resources’ screen. 

Core Bugs # 130636: Issues in the ‘Client Education Resources’ screen. 

What’s fixed: Two issues were resolved in the Client Education Resource screen: 

Clicking the last page number previously showed a blank page. Now, all records are displayed on a single 
scrollable page. 

The pop-up header for Document Description was incorrectly labeled as “Custome Report Viewer.” It 
has been corrected to “Custom Report Viewer.” 

Where to find it: 
Go to Client search → Client Education Resource screen → Click on Document Description 
hyperlink → Custom Report Viewer popup will appear. 

Client Information 

Reference No Task No Description 

25 Core Bugs # 132557 ‘Address Type 0’ entries in tables ‘ClientAddresses’ and 
‘ClientAddressHistory’ being generated as Bad Data. 

26 Core Bugs # 132601 Client Information (Admin): in the ‘Contacts’ tab, the phone 
numbers are not appearing 

27 Core Bugs # 132684 Incorrect Screen Name Displayed After Navigating from 
‘My Documents (My Office)’ via Client Search 

28 Core Bugs # 132789 The word "Old" is added after the 'MM/DD/YYYY 
<years/months>' format in the 'Date of Birth' field of Client 
information tooltip 

29 Core Bugs # 132736 Client Information C screen: Irrelevant validation message 
is displayed when user tries to insert records into ‘List Of 
Releases' grid 

Core Bugs # 132557: ‘Address Type 0’ entries in tables ‘ClientAddresses’ and 
‘ClientAddressHistory’ being generated as Bad Data. 

What’s fixed: Bad data entries were being generated in the Address Type 0 column of the 
ClientAddresses and ClientAddressHistory tables when users added or deleted a client’s address 
from the Client Information (C) screen. 

The system now prevents the creation of invalid entries in the Address Type 0 column during address 
updates. Additionally, a cleanup script has been provided to mark existing bad records as deleted 
(Record Deleted = 'Y'). 

Where to find it: 

1. Client search → Client Information (C) → Add/Delete address in General tab 
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2. Database → ClientAddresses and ClientAddressHistory tables → Check entries under 
Address Type 0 

 

Core Bugs # 132601: Client Information (Admin): in the ‘Contacts’ tab, the phone numbers 
are not appearing 

What’s fixed: In the SmartCare application, the ‘Contacts’ tab on the Client Information (Admin) 
screen was not displaying phone numbers, even though the data existed. This created a gap in visibility 
for client contact details. 

Phone numbers now appear correctly in the ‘Contacts’ tab, ensuring users have access to complete 
client contact information. 

Where to find it: 
Go to Client Information (Admin) → Open the Contacts tab → Verify that phone numbers are now 
visible. 

Core Bugs # 132684: Incorrect Screen Name Displayed After Navigating from ‘My 
Documents (My Office)’ via Client Search 

What’s fixed: Previously, when My Documents (My Office) was set as the homepage, navigating to the 
Client Information screen—either by creating a new client or selecting one from the Client Search 
popup—did not update the screen name correctly. The top of the screen continued to display My 
Documents, causing confusion about the current view. 

The screen name now correctly updates to Client Information when navigating from My Documents 
(My Office) via Client Search. 

Where to find it: 

1. Set My Documents (My Office) as homepage in My Preferences (My Office) 
2. Navigate to: 

• Client Search → Create or select a client → View screen name at the top 

 

Core Bugs # 132789: The word "Old" is added after the 'MM/DD/YYYY <years/months>' 
format in the 'Date of Birth' field of Client information tooltip 

What’s fixed: In the Client Information tooltip, the Date of Birth field did not include the word “Old” 
after the formatted date and age (e.g., MM/DD/YYYY <years/months> or MM/DD/YYYY <days/months>), 
which could lead to unclear age representation. 

The system now appends the word “Old” after the age format in the Date of Birth field, improving clarity 
in client age display. 

Where to find it: 
Client → Search → Select Client → Hover over Client Information tooltip → View Date of Birth field 

Core Bugs # 132736: Client Information C screen: Irrelevant validation message is 
displayed when user tries to insert records into ‘List Of Releases' grid 

What’s fixed: An irrelevant validation message was being displayed when users attempted to insert 
records into the List of Releases grid on the Client Information C screen, even after entering valid data 
in the Release To field. 

The validation message no longer appears when the Release To field is properly filled, and users can 
insert records into the grid without interruption. 
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Pre-requisite: 
Ensure the Client Information C screen is configured and accessible. 

Where to find it: 
Client → Client Information C → Release of Information tab 

Client MAR 

Reference No Task No Description 

30 Core Bugs # 132559 The ‘Admin in Last 24 Hours’ field is updated with the 
dose value in the ‘Client MAR’ screen when the 
Medication is administered with statuses such as 
‘Refuse’, ‘Not Given’, or ‘Initial Refusal - Not Given’. 

31 Core Bugs # 132728 Client Order Details: Error on clicking History of 
Administration tab 

32 Core Bugs # 132848 Client MAR and Group MAR: Any changes to the 
dispense time will always create additional MAR records, 
and not remove the original dispense time. 

Core Bugs # 132559: The ‘Admin in Last 24 Hours’ field is updated with the dose value in 
the ‘Client MAR’ screen when the Medication is administered with statuses such as 
‘Refuse’, ‘Not Given’, or ‘Initial Refusal - Not Given’. 

 

What’s fixed: Previously, in the Client MAR screen, the ‘Admin in Last 24 Hours’ field was incorrectly 
updated with the dose value when a medication was administered with statuses like ‘Refuse’, ‘Not 
Given’, or ‘Initial Refusal - Not Given’. This led to inaccurate tracking of administered doses. 

The system now correctly prevents dose values from updating the ‘Admin in Last 24 Hours’ field when 
these specific statuses are selected. 

Where to find it: 

1. Administration → Orders → Orders list → New → Order Details → Select Order Type → Fill 
required fields → Options → Set “Add Order to MAR” to Yes → Save 

2. Client → Client Orders → New → Select Order from step 1 → Fill required fields → Set “Max 
Quantity Allowed in 24 Hours” → Insert → Save → Sign 

3. Client → Client MAR → Select client → Click date hyperlink → Set Administration Status to 
“Refused” → Save 

 

Core Bugs # 132728: Client Order Details: Error on clicking History of Administration tab 

What’s fixed: In the Client Orders Details screen, clicking the History of Administration tab triggered 
a red error message: 

Error message: 
8114*****Error converting data type varchar to 
float.*****ssp_SCClientOrderAdministration*****23*****16*****5 

Users can now access the History of Administration tab without encountering any errors. 

Where to find it: 
Select a client → Search → Client Orders → Click Medication Name hyperlink → Client Orders 
Details screen → History of Administration tab 
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Core Bugs # 132848: Client MAR and Group MAR: Any changes to the dispense time will 
always create additional MAR records, and not remove the original dispense time. 

What’s fixed: Previously, when users modified the dispense time in the Client MAR or Group MAR 
screens, the system created duplicate MAR records—one with the original time and one with the updated 
time—leading to confusion and cluttered records. 

The system now correctly updates the dispense time without creating additional MAR records. 

Pre-requisite: 
Client Orders must be signed with Frequency set to Use Start Time of Order as First Dispense Time. 

Where to find it: 

• Client → Client MAR 

• My Office → Group MAR 
→ Modify dispense time → Confirm only updated MAR record is retained 
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Client Orders  

Reference No Task No Description 

37 Core Bugs # 132583 ‘Clinic/Location’ selected from the drop-down in the 
‘Order’ tab is not correctly displayed in the ‘Preference’ 
tab of the ‘Client Orders Details’ screen.   

38 Core Bugs # 132791 Laboratory Details Fetching Logic Changes 

39 Core Bugs # 132799 Service Not Being Created from Lab Order 

40 Core Bugs # 132802 MAT: Received an Error on MAT Management when 
attempting to create an order. 

41 Core Bugs # 132826 Client Order PDF: Medication Instructions incorrectly 
showing on the Medication row 

42 Core Bugs # 132857 lab results with wrong client information in the Lab Result 
PDF in the SmartCare 

Core Bugs # 132583: ‘Clinic/Location’ selected from the drop-down in the ‘Order’ tab is 
not correctly displayed in the ‘Preference’ tab of the ‘Client Orders Details’ screen.   

What’s fixed: Previously, when users selected a Clinic/Location from the dropdown in the Order tab of 
the Client Orders Details screen, the selected value was not correctly reflected in the Preference tab. 
This caused inconsistencies when reviewing lab orders. 

The Clinic/Location selected in the Order tab now correctly displays in the Preference tab, ensuring 
accurate and consistent data across tabs. 

Where to find it: 
Client → Search and select a client → Go to Client Orders → Click New → In Order tab: 

• Select required Lab Order 

• Choose Clinic/Location from dropdown 

• Check Preference checkbox 

• Click Insert and Save 
→ Navigate to Preference tab → Select checkbox for same Lab Order 

 

Core Bugs # 132791: Laboratory Details Fetching Logic Changes 

What’s fixed: The logic used to fetch Laboratory Details when processing lab results from ORU HL7 
inbound messages was previously limited to mapping the Receiving Facility value in MSH.6 from the 
XML to vendor configuration details. This caused issues in accurately identifying the correct laboratory. 
The system now uses multiple mapping conditions to fetch laboratory details more reliably: 

• Laboratories.vendorID ↔ HL7CPQueueMessages.CPVendorConnectorID 

• HL7CPVendorConfigurations.SendingFacility ↔ Receiving Facility value in MSH.6 

• Laboratories.LaboratoryId ↔ LaboratoryFacilities.LaboratoryId 

Where to find it: 

• Select a Client → Go Search → Client Orders → Client Order Details → Lab Results and 
Attachments 

• Administration → Messages Interface → Messages Interface Detail 

• Client → Lab Result Review → View 
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Core Bugs # 132799: Service Not Being Created from Lab Order 

What’s fixed: Services were not being created from Lab Orders when the procedure category was set to 
Encounters or Days, and the order start date and end date were the same. 

Services are now successfully created with a duration of 1 unit when signing a client order that has the 
same start and end date. 

Pre-requisite: 

• Client must be enrolled in a Program and Procedure 

• Procedure must be a billable procedure code 

• Procedure category must be set to Encounters or Days 

Where to find it: 

• Client → Client Orders → Search and select a Lab Order → Enter required fields → Set Order 
Status to ‘Sent to Lab’ → Click ‘Insert’ → Click ‘Save/Sign’ 

• Client → Services → Open the created Service 

 

Core Bugs # 132802: MAT: Received an Error on MAT Management when attempting to 
create an order. 

What’s fixed: Previously, users received a red error message when attempting to create a MAT Client 
Order and add a schedule in the MAT Client Level pop-up. This occurred during the dataset merge 
process, preventing successful order creation. 

The system now allows users to create MAT Client Orders and add schedules without encountering the 
error message. 

Error message before fix: 
“Error occurred during dataset merge process at server side, please contact system administrator for 
further assistance.” 

Where to find it: 

1. Administration → Orders → Orders list page 

• Click on New → Order Details screen 

• Select Medication Order Type 

• Fill required fields 

• Under Medication Assisted Treatment, set: 
  Medication Assisted Treatment = Yes 
  Machine Connection Required = Yes 
  Take Home Allowed = Yes 
  Display Program = Yes 

• Click Save 
2. Client → Search → Client Orders → Client Orders list page 

• Click on New → Client Order Details screen 

• Select the Order created in step 1 

• Fill required fields 

• Select Take Home Days and Program 

• Click Insert, then Save and Sign Client Order 
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Core Bugs # 132826: Client Order PDF: Medication Instructions incorrectly showing on 
the Medication row 

What’s fixed: Medication instructions were incorrectly appearing within the medication row in the Client 
Order PDF. Additionally, the medication name format was incorrect, and the Dose field was missing. 

The system now correctly displays the medication name format and includes the Dose field in the Client 
Order PDF. The display logic has been updated as follows: 

• If Strength ≠ 'Other': (Order Name) + Medication Description (from MDMedications table) 

• If Strength = 'Other': (Order Name) + Medication Name 

Where to find it: 
Client → Client Orders → Select Medication Order → Fill required fields → Sign 

Core Bugs # 132857: lab results with wrong client information in the Lab Result PDF in 
the SmartCare 

What’s fixed: Lab results were displaying incorrect client information in the Lab Result PDF within 
SmartCare. This occurred when multiple lab results were received with the same MessageControlId in 
ORU HL7 inbound messages. 

The system now checks whether the MessageControlId already exists in the HL7CPQueueMessages 
table: 

• If it does not exist, a new record is inserted. 

• If it does exist, the system processes the existing record and displays the correct client 
information in the Lab Result PDF. 

Where to find it: 

• Administration → Messages Interface → Messages Interface Detail 

• Client → Client Orders → Client Order Details → Lab Results and Attachments 

• Client → Lab Result Review → View 
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Client Search 

Reference No Task No Description 

43 Core Bugs # 132236 To disable the barcode scanning functionality, a new 
System Configuration Key "EnableBarcodeScanning" is 
implemented. 

Core Bugs # 132236: To disable the barcode scanning functionality, a new System 
Configuration Key "EnableBarcodeScanning" is implemented. 

What’s fixed: Previously, when users typed or searched for a Client ID too quickly, the system 
mistakenly triggered barcode scanning logic, causing valid client records to not be found. 

A new system configuration key, EnableBarcodeScanning, has been introduced to prevent this issue. 
When this key is turned off, barcode scanning functionality is disabled, ensuring that rapid typing or 
multiple key presses do not activate barcode scanning. 

Where to find it: 
Client Search → Type or search for Client ID → Confirm barcode scanning is disabled when configuration 
key is set to No 

System Configuration Key Details: 

• Key Name: EnableBarcodeScanning 

• Read As: Enable Barcode Scanning 

• Allowed Values: Yes / No 

• Behavior: 

 Yes (default): Barcode scanning is enabled 

 No: Barcode scanning is disabled 

 Any other value or missing key: Defaults to Yes 

Pre-requisites: 

Set EnableBarcodeScanning = No in System Configuration 

Clinical Data Access Groups 

Reference No Task No Description 

44 Core Bugs # 132213 Selected Program was getting cleared upon Refreshing 
the Browser   

Core Bugs # 132213: Selected Program was getting cleared upon Refreshing the Browser   

What’s fixed: Previously, when users refreshed the browser while creating a new document, the selected 
program in the Document Control section was cleared, requiring re-selection and disrupting workflow. 

The system now retains the selected program even after a browser refresh, ensuring a smoother and 
more consistent document creation experience. 

Pre-requisites: 

• System configuration key DisplayCDAGSectionInStaffDetails = Yes 

• System configuration key EnableClinicalDataAccessGrouping = Yes 

Where to find it: 
Client Search → Documents → Create New Document 

• Program Selection pop-up → Select Program 
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• Ensure document is in New status 

• Refresh browser → Expand Document Control (+) → Confirm selected Program remains intact 

Core Assessment 

Reference No Task No Description 

49 Core Bugs # 132792 Assessment (C) : Error: Sub report could not be shown 

50 Core Bugs # 132852 Assessment ( C ): When the document is saved in the 
CATS tab and then navigated to the Needs tab, blank 
screen is displayed 

Core Bugs # 132792: Assessment (C) : Error: Sub report could not be shown 

What’s fixed: An error occurred in the Assessment (C) screen when special characters were added to 
the DFA form name mapped to a Core Assessment. The system displayed the following error: 

Error Message: 
Error: Subreport could not be shown. 

Users can now include special characters in the DFA form name without triggering errors, and the 
Mental Status tab loads correctly. 

Where to find it: 
Client → Assessment (C) → Select Classification, Population, Category, Type → View Mental 
Status tab 

Core Bugs # 132852: Assessment ( C ): When the document is saved in the CATS tab and 
then navigated to the Needs tab, blank screen is displayed 

What’s fixed: Previously, when users saved a document in the CATS tab of the Assessment (C) screen 
and then navigated to the Needs tab, the screen appeared blank, preventing further interaction. 

The system now correctly displays the Needs tab after saving data in the CATS 3–6 and CATS 7–17 
tabs, allowing users to continue their workflow without interruption. 

Where to find it: 
Client → Assessment (C) (Client) → Select Classification, Population, Category, Type → Access 
CATS 3–6 and CATS 7–17 tabs → Save document → Navigate to Needs tab → Confirm tab displays 
correctly 
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Crisis Call Log 

Reference No Task No Description 

51 Core Bugs # 132696 Crisis Call Log list Page: Duplicate records were 
displayed. 

52 Core Bugs # 132721 Crisis Call Log Details screen: Treatment team member 
was blank in the Client Information (Potential) section 

Core Bugs # 132696: Crisis Call Log list Page: Duplicate records were displayed. 

What’s fixed: Previously, when users created multiple records in the Follow Up tab of the Crisis Call 
Log Details screen, duplicate entries appeared on the Crisis Call Log List page after saving. This 
caused confusion and clutter in the log view. 

The Crisis Call Log List page now displays only the most recent Follow Up record, even when 
multiple entries are created, eliminating duplicate records and improving clarity. 

Where to find it: 
Client Search → Select client → Crisis Call Log (My Office) → View Crisis Call Log List page 

Core Bugs # 132721: Crisis Call Log Details screen: Treatment team member was blank 
in the Client Information (Potential) section 

What’s fixed: In the Crisis Call Log Details screen, the Treatment Team Member field in the Client 
Information (Potential) section was appearing blank, even when relevant data existed. 

The system now correctly initializes the Treatment Team Member field using data from the following 
sources: 

1. Primary Clinician and Primary Physician from the Client Information screen 
2. Assigned Staff from the Program Assignment screen 
3. Staff associated in the Treatment Episode screen 
4. Family Name and Foster Care Specialist from the Placement History Details screen 
5. Clinician and Physician from the Inpatient Activity Details screen 

Where to find it: 
Crisis Call Log (My Office) → Click New → Crisis Call Log Details screen → View Client Information 
(Potential) section 

Dashboard 

Reference No Task No Description 

53 Core Bugs # 132628 Widget column headers showing attribute name instead 

of display as Value 

54 Core Bugs # 132718 Tracking Widget Radio Buttons Not Working Properly 

Core Bugs # 132628: Widget column headers showing attribute name instead of display 

as Value 

 

What’s fixed: On the Client Dashboard, widget column headers were showing the default Attribute 
Name instead of the custom label entered in the Display As field. 

Column headers now correctly display the custom Display As value set during widget creation. 



SmartCare Release Notes  

      

 

Where to find it: 
Select a client → Open the Client Dashboard → Review widget column headers. 

Core Bugs # 132718: Tracking Widget Radio Buttons Not Working Properly 

What’s fixed: In the Tracking Widget, selecting a radio button would correctly update the grid, but the 
selection would reset to the wrong option. This issue occurred only when the "Service Requests for 
Review/Approval" widget was placed before the Tracking Widget on the dashboard. The radio button 
selection in the Tracking Widget remains accurate, regardless of the placement of other widgets. 

Where to find it: 
Go Search → Dashboard (My Office) → Tracking Widget 

Documents  

Reference No Task No Description 

60 Core Bugs # 132537 Documents: Reviewer Co-signer issue. 

61 Core Bugs # 132547 Inactive staff were displayed in Acknowledgements and 

Comments section for “To Acknowledge” status. 

62 Core Bugs # 132581 PHQ-9 and PHQ-A document – ‘Addition Questions’ 

section still displays even if the system configuration is 

turned off. 

63 Core Bugs # 132677 The ‘Remain open’ programs are not displayed in the PDF 

of the 3rd and 4th versions of the ‘Agency/Program 

Discharge’ document. 

64 Core Bugs # 132724 All the Documents are not listed in ‘Attach/Review 

Documents’ and ‘Associate Documents’ popups. 

65 Core Bugs # 132759 When staff tried to add client to cosign, wrong staff name 

was populating in the cosigner list. 

Core Bugs # 132537: Documents: Reviewer Co-signer issue. 

What’s fixed: The Reviewer Co-signer functionality was not working as intended in the Documents 
module. Reviewers were able to select themselves from the Co-signer list and sign the document even 
before the original author had signed it. 

Reviewers can no longer select themselves as co-signers for the current version of the document. A 
document can only be co-signed after it has been signed by the original author. 

Pre-requisite: 

In Document Codes Setup, ensure Requires Licensed Signature is set to Yes 

Where to find it: 
Client → Documents → Sign → Add Reviewer → Status: To Be Reviewed → Login as Reviewer → 
Documents → Decline Document → Status: In Progress → Select Reviewer from Co-sign list 

Core Bugs # 132547: Inactive staff were displayed in Acknowledgements and Comments 

section for “To Acknowledge” status. 
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What’s fixed: Previously, inactive staff members were still appearing in the Acknowledgements and 
Comments section of documents with the “To Acknowledge” status, even after being inactivated by an 
admin. 

The system now correctly excludes inactive staff from the “To Acknowledge” list in the 
Acknowledgements and Comments section. 

Pre-requisites: 

• Document Codes setup: 

 Enable Document Acknowledgement = Yes 

 Either Default Staff To Acknowledge or Default Role To Acknowledge is configured 

• Active staff exists for the configured role or staff 

Where to find it: 

1. SmartCare → Client → Documents 

• Select a document with the above pre-requisites 

• Fill in details → Sign the document 

• Click Document Control → Acknowledgements and Comments → Confirm staff listed under 
“To Acknowledge” 

2. Admin login 

• Inactivate one of the staff listed in the Acknowledgements and Comments section 
3. Re-login as normal user 

• Select same client and document 

• Click Document Control → Acknowledgements and Comments → Confirm inactivated staff 
no longer appear 

 

Core Bugs # 132581: PHQ-9 and PHQ-A document – ‘Addition Questions’ section still 

displays even if the system configuration is turned off. 

What’s fixed: Previously, the Additional Questions section continued to display in the PHQ-9 and PHQ-
A documents even when the system configuration keys were set to No. This caused confusion for users 
expecting the section to be hidden. 

When the configuration keys are set to No, the Additional Questions section no longer appears in either 
document, as expected. 

Where to find it: 

1. Set configuration key ShowAdditionalQuestionSectionOnCorePHQ9Document to No 
2. Set configuration key ShowAdditionalQuestionsSectionOnCorePHQADocument to No 
3. Navigate to: 

• SmartCare → Client → Documents → PHQ-9 document 

• SmartCare → Client → Documents → PHQ-A document 

 

Core Bugs # 132677: The ‘Remain open’ programs are not displayed in the PDF of the 3rd 

and 4th versions of the ‘Agency/Program Discharge’ document. 

What’s fixed: Previously, in the Agency/Program Discharge document (versions 3 and 4), the Remain 
Open programs were not displayed in the generated PDF. Only the discharged programs appeared, 
leading to incomplete documentation of the client’s active program status. 
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The PDF now correctly displays both Discharged and Remain Open programs in the 3rd and 4th 
versions of the document, ensuring a complete and accurate representation of the client’s program 
enrollment. 

Where to find it: 
Client → Agency/Program Discharge → Click New → Select Program Discharge radio button → 
Enter required dates → Click Save/Validate/Sign → Click Sign 
→ PDF displays → Click Edit → Second version appears → Discharge one program → Click Sign 
→ Click Edit → Third version appears → Edit/select required data → Click Sign 

Core Bugs # 132724: All the Documents are not listed in ‘Attach/Review Documents’ and 

‘Associate Documents’ popups. 

What’s fixed: Previously, not all documents were displayed in the ‘Attach/Review Documents’ and 
‘Associate Documents’ popups, even when they should have been available. All relevant documents 
are now correctly listed in both popups. 

Pre-requisite: 

• System configuration key DisplayCDAGSectionInStaffDetails must be set to Yes 

• System configuration key EnableClinicalDataAccessGrouping must be set to Yes 

Where to find it: 

• Client → Documents → Documents list page → Click ‘Add’ under Associated Documents → 
Associate Documents popup 

• My Office → My Documents → My Documents list page → Click ‘Add’ under Associated 
Documents → Associate Documents popup 

• Client → Disclosure/Requests → Disclosure/Requests list page → Click ‘New’ → 
Disclosure/Requests Details → Disclosure Details section → Click ‘Attach / Review Items 
Disclosed’ → Attach / Review Documents popup 

• Client → Service Request List → Service Request List page → Click ‘New’ → Service 
Request – Review/Approval Detail → Attachments tab → Click ‘Attach Documents’ → 
Attach / Review Documents popup 

 

 

Core Bugs # 132759: When staff tried to add client to cosign, wrong staff name was 

populating in the cosigner list. 

What’s fixed: When staff attempted to add a client as a co-signer in a document, the system incorrectly 
populated a staff name in the co-signer list instead of the correct client name. 

The correct client name is now displayed in the co-signer list when adding a client as a co-signer in a 
document. 

Where to find it: 
Client → Documents 

Dynamic Forms (DFA) 

Reference No Task No Description 

67 Core Bugs # 132542 The label-type Form Item in the ‘Custom’ tab did not 
display the ID value (ID field appeared blank). 
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68 Core Bugs # 132555 BQuIP - SUD Screening document radio button display 
issue.  

Core Bugs # 132542: The label-type Form Item in the ‘Custom’ tab did not display the ID 
value (ID field appeared blank). 

What’s fixed: Previously, label-type Form Items in the Custom tab of documents did not display their ID 
values when inspected using Developer Tools. The ID field appeared blank, making it difficult to identify 
or reference the control programmatically. 

The system now correctly displays the ID value for label-type Form Items in the Custom tab, ensuring 
visibility and traceability during inspection. 

Where to find it: 
Client Search → Documents → Open any document with a Custom tab → Locate a label-type Form Item 
→ Inspect using Developer Tools → Confirm ID value is visible 

Core Bugs # 132555: BQuIP - SUD Screening document radio button display issue. 

What’s fixed: Previously, in the BQuIP - SUD Screening document, radio button labels were incorrectly 
displayed below the radio buttons instead of beside them, affecting readability and layout. 

The system now correctly displays radio button labels next to the buttons, as intended. 

Note: This is a customer-specific issue fix. 

Where to find it: 
Client → BQuIP - SUD Screening document → Review radio button layout 

Error Log 

Reference No Task No Description 

69 Core Bugs # 132646 Documents: Errorlog issue 

70 Core Bugs # 132665 Errorlog was getting logged when a user attempted to 

login to SmartCare application 

Core Bugs # 132646: Documents: Errorlog issue 

What’s fixed: An error was being logged when users accessed Keyboard Shortcuts from the menu or 
attempted to print an InProgress document. The system recorded the following error in the ErrorLog 
table: 

Error Message: 
Exception: The remote host closed the connection. 

Users can now access Keyboard Shortcuts and print InProgress documents without triggering any 
error logs. 

Where to find it: 

• Click staff name (top-right corner) → Select Keyboard Shortcuts 

• Client → Documents → Create a new document → Save → Ensure status is InProgress 

 

Core Bugs # 132665: Errorlog was getting logged when a user attempted to login to 

SmartCare application 
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What’s fixed: An error was being logged when users attempted to log in to the SmartCare application. 
The system recorded the following error in the ErrorLog table: 

Error Message: 
The remote host closed the connection 

Users can now log in to SmartCare without triggering any error logs. 

Where to find it: 
Login to SmartCare application 

Flow Sheet 

Reference No Task No Description 

71 Core Bugs # 132692 Flow sheet List Page: Health Data element description 
name does not fit in the column 

Core Bugs # 132692: Flow sheet List Page: Health Data element description name does 
not fit in the column 

What’s fixed: In the Flow Sheet List page, long Health Data Element Descriptions were not fitting 
properly in the column, causing misalignment in the Vitals History tab. 

Descriptions now display correctly within the column without layout issues. 

Where to find it: 
Client → Flow Sheet → Vitals History tab → Verify Health Data Element Descriptions display properly. 

Group Services 

Reference No Task No Description 

73 Core Bugs # 132595 When services are created from ‘Group Services’, the 
‘Client was Present’ checkbox appears checked on the 
‘Service Detail’ screen. 

74 Core Bugs # 132705 Recurring Group Services have old diagnosis attached to 
recurring services and do not update when diagnosis is 
updated. 

75 Core Bugs # 132715 Groups: Duplicate services are created for the client. 

76 Core Bugs # 132820 Getting an error message when trying to open services 
from the ‘Document To Do’ widget. 

77 Core Bugs # 132876 Group Services – Mode of Delivery issues.  

Core Bugs # 132595: When services are created from ‘Group Services’, the ‘Client was 
Present’ checkbox appears checked on the ‘Service Detail’ screen. 

What’s fixed: 
When services were created from Group Services, the Client Was Present checkbox appeared 
checked on the Service Detail screen—even though the actual data value was null. This caused 
inaccurate representation of client attendance. 

This issue has been resolved. The checkbox now appears unchecked by default, accurately reflecting the 
underlying data. 

Where to find it: 
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Group Service Creation: 
Go to My Office → Groups → Click New → Fill in required fields in the General tab → Save → Go to 
Schedule tab → Click New Group Service → Select Date of Service and Clients → Click Select. 

Service Finalization: 
Navigate to Group Service Detail → Group Details tab → Fill in Service Information → Save → Go to 
Note tab → Enter required fields → Save → Click Sign → View PDF. 

Service Detail Verification: 
Go to My Office → Services → Locate the created service → Click on DOS hyperlink → Verify Client 
Was Present checkbox on the Service Detail screen. 

Core Bugs # 132705: Recurring Group Services have old diagnosis attached to recurring 
services and do not update when diagnosis is updated. 

What’s fixed: Recurring Group Services were retaining outdated diagnosis information. Updates to a 
client’s diagnosis were not reflected in future recurring service instances. 

Diagnosis is now dynamically populated when: 

• Service status is changed to Show 

• Date of Service is modified 

• Program is changed 

• Refresh Diagnosis is clicked 

Where to find it: 

• Create a recurring group service via Groups → Schedule → New Group Service 

• Update diagnosis via Client → Diagnosis Document 

• View and refresh diagnosis via Group Services → Service Detail → Billing Diagnosis tab 

 

Core Bugs # 132715: Groups: Duplicate services are created for the client. 

What’s fixed: Previously, when a user deleted and re-added a client after creating a recurring group 
service, the system would generate duplicate services for that client. 

Clients can be deleted and re-added without triggering duplicate service creation in recurring group 
services. 

Pre-requisite: 
Create a recurring group service, then delete and re-add a client within the group. 

Where to find it: 
My Office → Groups 

1. Go to the Groups list page 
2. Select a group and click the Save icon 
3. Navigate to the Schedule tab → Click New Group Service 
4. In the Group Service Client popup, select a client → Click Select 
5. On the Group Service Detail page → Go to Services tab → Enter/select data → Click Save 
6. Go to Group Details tab → Click Make Recurring → Select recurrence details → Click OK 
7. Delete the client → Click Save 
8. In the Group Service Recurrences Scheduler popup → Click Cancel 
9. Re-add the previously deleted client → Click Save 
10. In the scheduler popup → Select recurrence details → Click OK 
11. Return to the Schedule tab → Click the group’s Date hyperlink 
12. On the Group Service Detail page → Go to Services tab → Select the client 
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Core Bugs # 132820: Getting an error message when trying to open services from the 
‘Document To Do’ widget. 

What’s fixed: Users were encountering an error when trying to open services from the Document To Do 
widget. This occurred because some documents were still listed even after their associated recurring 
group services had been deleted. 

The system now includes defensive logic to automatically remove documents linked to deleted recurring 
group services, preventing the error from occurring. 

Error Message Previously Displayed: 
“TypeError: Cannot read properties of null (reading 'ObjectDocumentInformation')” 

Where to find it: 

1. My Office → Dashboard → Document To Do widget 
2. My Office → Groups → Groups List → New → Fill General tab → Save → Schedule tab → 

New Group Service → Select Date of Service and Clients → Select 
3. Group Service Details → Group tab → Group Details tab → Staff section → Fill required fields 

→ Recurrence icon → Recurring Group Services popup → Select dates and recurrence 
pattern → Create Immediately → OK 

 

Core Bugs # 132876: Group Services – Mode of Delivery issues. 

What’s fixed: The Mode of Delivery field in Group Services was not properly validated. If the field was 
left unselected, users could still proceed with actions in the Note tab and sign the service without 
receiving any validation message, leading to incomplete data entry. 

The system now displays a validation message both in the Note tab and during the signing process if the 
Mode of Delivery field is not selected, ensuring required fields are properly completed. 

Where to find it: 

1. My Office → Groups → Groups List → New → Fill General tab → Save → Schedule tab → 
New Group Service → Select Date of Service and Clients → Select 

2. Group Service Detail Screen → Group tab → Group Details tab → Services tab → Fill 
Service Information → Select Mode of Delivery → Save → Note tab → Fill Client Note → 
Save → Sign → Signature popup → PDF 

Inquiry  

Reference No Task No Description 

78 Core Bugs # 132350 The ‘Ethnicity’, ‘Race’ and ‘Client declined to Provide’ 
field code names were sorted ‘Alphabetically’ not based 
on ‘Sort Order’ 

79 Core Bugs # 132532 Inquiry Save Restricted: Missing Staff or Workgroup error 

Core Bugs # 132350: The ‘Ethnicity’, ‘Race’ and ‘Client declined to Provide’ field code 
names were sorted ‘Alphabetically’ not based on ‘Sort Order’ 
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What’s fixed: Previously, the checkbox options for Ethnicity, Race, and Client Declined to Provide 
were displayed in alphabetical order instead of the configured Sort Order, causing inconsistencies across 
demographic sections. 

The system now correctly sorts these fields based on the defined Sort Order. If multiple items share the 
same sort order, they will be sorted alphabetically within that group. 

Where to find it: 

• My Office → Inquiries → Click New → Inquiry Details screen 

• Client → Client Information (C) screen 

• Client → Agency/Program Discharge document 

• Client → Registration Document (C) 

 

Core Bugs # 132532: Inquiry Save Restricted: Missing Staff or Workgroup error 

What’s fixed: Previously, users were able to save an inquiry with a disposition value while leaving both 
the Assigned Staff and Assigned Workgroup fields blank. This caused an error when attempting to 
complete the inquiry later, displaying the message: 

“Select value in either Staff or Workgroup.” 
and preventing completion. 

The system now ensures that when the configuration key TurnOnCareCoordinationWorkflow is set to 
Yes, the Assigned Staff and Assigned Workgroup fields in the Disposition section are enabled if both 
are empty. This allows users to enter the required values and successfully complete the inquiry. 

Pre-requisite: 

• Set system configuration key TurnOnCareCoordinationWorkflow = Yes 

 Path: Administration → System Configuration → Select key → Set value to Yes 

Where to find it: 
My Office → Inquiries screen 

• Select an In Progress inquiry → Go to Disposition section 

• Confirm that either Staff or Workgroup must be selected before saving or completing the inquiry 

Methadone 

Reference No Task No Description 

82 Core Bugs #131825 MAT: System is allowing Pre pour the future Face To 
Face dose and to be dispensed. 

84 Core Bugs # 132415 MAT: Client Column on ‘MAT Management’ List Page is 
too Narrow and ‘Bottle/Box ID’ Limited to 5 Characters on 
the ‘Medication/Lot/Bottle Details’ Screen.  

85 Core Bugs # 132488 MAT: Incorrect status is displayed in MAT Management 
List page after a Take Home and Face to Face dispense. 

86 Core Bugs # 132647 Issues in the ‘MAT Management Details’ screen 

87 Core Bugs # 132685 MAT: ‘Units’ dropdown value is defaulted to 'mg' in the 
‘Medication/Lot/Bottle Details’ screen. 

88 Core Bugs # 132726 MAT - Dispense History Grid Cutting off Rows of Data 
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89 Core Bugs # 132730 MAT: Successful dispense is not displayed on the MAT 
Management list and details pages Core Bugs 

90 Core Bugs # 132731 MAT: Stuck in infinite loop after Calibration process when 
saying 'No' to Unprime prompt 

91 Core Bugs # 132755 MAT - MAT Medication Mapping incorrect within Recode 
SetMedicationForMATMultiInventoryDispense 

92 Core Bugs # 132764 MAT: Program Filter on MAT Management List page is 
not working. 

93 Core Bugs # 132821 Med/lot/bottle bulk insert 

Core Bugs # 131825: MAT: System is allowing Pre pour the future Face To Face dose and 
to be dispensed. 

What’s fixed: Previously, the system allowed users to pre-pour and dispense future Face-to-Face doses 
in the MAT Management Details screen, which was not intended behavior. 

The system now correctly restricts future Face-to-Face doses from being pre-poured and dispensed. If 
Commence Pre-pour is checked, the Face-to-Face (cup) icon is disabled, and users can edit the dose 
type from Face-to-Face to Take Home. 

Additionally, when No Pump is ON for past scheduled doses, the Dispense icon is now enabled and 
allows dispensing. 

Pre-requisites: 

• MAT Configuration: Allow Pre-Pours is checked 

• MAT Order is signed for the selected client 

Where to find it: 

1. Go Search → MAT Management (My Office) → MAT Management List Page 

• Filter for past date 

• Connect Machine/Inventory 

• Click No Pump Dispense → Select No Pump Dispense = Yes, Reason → Continue 

• Click No Show status → Change Current Status = Scheduled → Confirm warning → Change 

• Click Dispense icon → MAT Management Details → Sign → Dispense Face-to-Face/Take 
Home 

2. Go Search → MAT Management (My Office) → MAT Management List Page 

• Connect Machine/Inventory 

• Click Dispense icon → MAT Management Details → Sign 

• Check Commence Pre-pour → Attempt to dispense future Face-to-Face dose → Confirm 
cup icon is disabled 

 

 

Core Bugs # 132415: MAT: Client Column on ‘MAT Management’ List Page is too Narrow 
and ‘Bottle/Box ID’ Limited to 5 Characters on the ‘Medication/Lot/Bottle Details’ Screen. 

What’s fixed: Two UI issues were resolved: 

1. The Client Name column on the MAT Management list page was too narrow, making names 
difficult to read. It has now been widened to display full names without requiring hover. 

2. The Bottle/Box ID field on the Medication/Lot/Bottle Details screen was limited to 5 characters 
when starting with alphanumeric input. The limit has been increased to 6 characters. If more than 
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6 alphanumeric characters are entered, the following error is displayed: 
“Inventory Detail - Bottle/Box ID in alphanumeric format, allowing any number of letters and up to 
6 digits.” 

Where to find it: 

MAT Management List Page: 
Go to My Office → MAT Management → View the Client Name column. 

Medication/Lot/Bottle Details: 
Go to My Office → Medication/Lot/Bottle → Click New → On the Details screen, enter the Bottle/Box 
ID. 

Core Bugs # 132488: MAT: Incorrect status is displayed in MAT Management List page 
after a Take Home and Face to Face dispense. 

What’s fixed: Previously, after dispensing both Face-to-Face and Take-Home doses in the MAT 
Management Details screen, the MAT Management List page displayed incorrect status values for the 
respective records. 

The system now correctly updates and displays the appropriate status based on the dispensing activity. 

Where to find it: 

1. Administration → Orders → Orders list page 

• Click New → Order Details screen 

• Select Medication Order Type 

• Set MAT fields: Medication Assisted Treatment = Yes, Machine Connection Required = Yes, 
Take Home Allowed = Yes, Display Program = Yes 

• Click Save 
2. My Office → Medication/Lot/Bottle list page 

• Click New → Enter required fields → Enter Location → Insert → Save 
3. Client → Client Orders → Client Orders list page 

• Click New → Select Order from step 1 

• Enter required fields → Select Take Home Days and Program → Do not select End Date → 
Insert → Save → Sign 

4. My Office → MAT Management list page 

• Click Connect User icon → Fill Connection Details → Select Machine/Inventory → Check 
Verified → Click Connect 

5. MAT Management list page 

• Select the Order → Click Dispense icon → Dispense Face-to-Face and Take-Home doses 
→ Verify status updates in MAT Management List 

Status Behavior Examples: 

• Face-to-Face with pending Take-Home: Status = In Progress until all Take-Home doses are 
dispensed, then changes to Completed 

• All Take-Home doses: Status = Completed after dispensing; if reverted, status changes to 
Scheduled 

• All Face-to-Face doses: Status = Completed after dispensing; if reverted, status changes to 
Scheduled 

 

Core Bugs # 132647: Issues in the ‘MAT Management Details’ screen 

What’s fixed: In MAT Management, two issues were resolved: 

• The first Take Home label was not printing immediately. 
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• Dispensing a week of Take Homes was slow. 

Now, the Print Label popup appears right after dispensing, and performance during multi-day dispensing 
has been improved. Additionally, the MAT Client Level Setup icon has been removed from the list 
screen to reduce load time. 

Where to find it: 
Go to My Office → MAT Management → Open the MAT Management List → Click Connect 
Machine/Inventory → Select the Dispense icon → On the MAT Management Details screen, click Sign 
→ Click Dispense under the Face-to-Face/Take Home section in the dispensing grid. 

Pre-requisites: 

• MAT Medication Inventory Details added to the Medication/Lot/Bottle Details screen 

• MAT Order signed 

• MAT Medication dispensed for the client 

 

Core Bugs # 132685: MAT: ‘Units’ dropdown value is defaulted to 'mg' in the 
‘Medication/Lot/Bottle Details’ screen. 

What’s fixed: In the Medication/Lot/Bottle Details screen, the Units dropdown previously had no 
default value. 

The Units dropdown now defaults to 'mg', improving data entry consistency. 

Where to find it: 
My Office → Medication/Lot/Bottle → Click New → On the Details screen, verify the Units field 
defaults to 'mg'. 

Core Bugs # 132726: MAT - Dispense History Grid Cutting off Rows of Data 

What’s fixed: In the MAT Management Details screen, the Dispense & No Show History grid was 
cutting off rows of data. This happened because the grid’s page size was limited to 30, even though the 
configuration allowed for viewing dispense history for the past 30 days. The grid no longer limits the 
number of rows based on page size and now displays all records according to the MAT Configuration 
setting. 

Pre-requisite: 

1. Set Show Dispense History for Past X Days to 30 in MAT Configuration. 
2. A MAT Order must be signed for the selected client. 
3. MAT Medication must be dispensed for the client. 

Where to find it: 

• MAT Management List Page → Connect Machine/Inventory → Click Dispense Icon → MAT  

• Management Details screen → Sign → Dispense via Face-Face/Take Home icon → Click 
‘See Complete History’ hyperlink 

 

Core Bugs # 132730: MAT: Successful dispense is not displayed on the MAT 
Management list and details pages Core Bugs 

What’s fixed: In MAT Management, successful dispenses were not appearing on the MAT 
Management list and details pages, even after the medication was properly dispensed and signed. 
Additionally, validation was missing when modifying dispensed orders. 

The system now correctly displays successful dispenses in both the list and details views. It also triggers 
a validation message when: 
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• A dispensed client order is modified and signed with overlapping dates. 

• A new client order is created for a date range where the same medication has already been 
dispensed. 

Validation Message: 
“Client order exists for the selected range (Date range) and medication has already been dispensed. 
Please change the Start Date of the new Client Order.” 

Where to find it: 

1. Administration → Orders → New → Select Medication Order Type → Fill required fields → 
Enable MAT options → Save 

2. My Office → Medication/Lot/Bottle → New → Fill required fields → Save 
3. Client → Client Orders → New → Select MAT Order → Fill required fields → Save and Sign 
4. My Office → MAT Management → Click Connect User → Fill Connection Details → Connect 
5. My Office → MAT Management → Select Order → Click Dispense icon → Dispense dose 
6. Client → Client Orders → New → Select Order → Update Dose → Modify → Save 

 

Core Bugs # 132731: MAT: Stuck in infinite loop after Calibration process when saying 
'No' to Unprime prompt 

What’s fixed: Users were getting stuck in an infinite loop during the Calibration process in MAT when 
selecting "No" on the Unprime prompt. Additionally, the Medication radio button was incorrectly set as 
the default filter in the Medication/Lot/Bottle list page. 

The Unprime operation has been removed from the calibration flow. The "Ok to empty pipe lines?" 
warning will no longer appear. Instead, users will directly see the "Unit closed. Would you like a printed 
report of this test?" prompt. 

The default filter in the Medication/Lot/Bottle list page is now set to Bottle ID, unless the user selects 
another option and clicks Apply Filter. 

Where to find it: 

• My Office → MAT Management → MAT Management list page → Click ‘Connect user’ icon → 
Select and connect machine → Click ‘Calibrate’ icon 

• My Office → MAT Dispenser → MAT Dispenser list page → Click ‘Machine Name’ hyperlink 
→ MAT Dispenser Detail → Click ‘Calibrate’ icon 

• My Office → Medication/Lot/Bottle → Medication/Lot/Bottle list page 

 

Core Bugs # 132755: MAT - MAT Medication Mapping incorrect within Recode 
SetMedicationForMATMultiInventoryDispense 

What’s fixed: The MAT Medication Mapping was incorrect in the 
SetMedicationForMATMultiInventoryDispense recode category. Specifically, the mappings for the 
following medications were wrong: 

• Suboxone 4 mg-1 mg sublingual film 

• Suboxone 12 mg-3 mg sublingual film 

The medications are now correctly mapped with the following IDs: 

• 91149 for Suboxone 4 mg-1 mg sublingual film 

• 91151 for Suboxone 12 mg-3 mg sublingual film 
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Where to find it: 
Administration → Recodes → SetMedicationForMATMultiInventoryDispense 

Core Bugs # 132764: MAT: Program Filter on MAT Management List page is not working. 

What’s fixed: Previously, when users selected a Program in the Program filter on the MAT 
Management List page, then navigated to another screen and returned, the Program filter reset to ‘All 
Programs’, causing users to lose their filter selections. 

The system now retains the selected filters for Program, Orders, and Flag Type when navigating away 
and returning to the MAT Management List page, improving usability and consistency. 

Note: Filter selections for Date and Status fields are not retained. 

Where to find it: 
Go Search → MAT Management → MAT Management List page → Apply filters (Program, Orders, 
Flag Type) → Navigate away → Return to page → Confirm filters are retained 

Core Bugs # 132821: Med/lot/bottle bulk insert 

What’s fixed: When entering bulk inventory in Medication/Lot/Bottle, bottle number sequencing was 
incorrect. Additionally, in the Generate Bottles popup, users were able to save invalid Bottle/BoxId 
values (e.g., A1234567) despite error messages being displayed. 

The system now ensures: 

• Bottle numbers follow the correct sequence during bulk inventory entry. 

• Invalid Bottle/BoxId values cannot be saved. An error is shown, and saving is blocked until 
corrected. 

Where to find it: 

1. My Office → Medication/Lot/Bottle → New 
2. My Office → Medication/Lot/Bottle → Click Generate Bottles icon 

Mobile  

Reference No Task No Description 

94 Core Bugs # 132707 The PDF incorrectly displayed the clinician’s signing suffix 

next to the client’s name when signed via the mobile 

WebApp. 

Core Bugs # 132707: The PDF incorrectly displayed the clinician’s signing suffix next to 

the client’s name when signed via the mobile WebApp. 

What’s fixed: When a clinician signed a document via the Mobile WebApp, the resulting PDF incorrectly 
displayed the clinician’s signing suffix next to the client’s name, leading to confusion and 
misidentification. 

The client’s name now appears correctly in the PDF without the clinician’s suffix, ensuring accurate 
representation of signers. 

Where to find it: 

• Login to Mobile WebApp → Enter SmartKey → Home → Documents → Create Document → 
Select Client → Fill required fields → Sign → Enter SmartKey → Sign → Client Sign → Sign in 
signature canvas 

• Select Client → Search for Documents → Open signed document → View PDF 
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My Calendar 

Reference No Task No Description 

96 Core Bugs # 132663 Slowness in the Staff Calendar screen.   

97 Core Bugs # 132739 My Calendar: Issue with using Quotation Mark in 
‘Comments’ section while creating a Service 

98 Core Bugs # 132811 New Calendar Entry items not synching with Outlook 

Core Bugs # 132663: Slowness in the Staff Calendar screen.   

What’s fixed: Previously, users experienced slowness on the Staff Calendar screen when attempting to 
schedule appointments. A processing indicator would appear, and the screen would continue loading, 
preventing users from completing the scheduling process. 

The Calendar screen now loads promptly, allowing users to schedule appointments without delay. 

Where to find it: 
My Office → New Calendar Entry → Select date → Click time slot → In New Entry popup: 

• Select New Calendar Entry radio button → Click OK 

• In Scheduler Event popup: Enter required fields 

• In Add Additional Staff section: Enter required fields → Click OK 

 

Core Bugs # 132739: My Calendar: Issue with using Quotation Mark in ‘Comments’ 
section while creating a Service 

What’s fixed: When creating a Service with comments containing special characters—especially 
quotation marks (“)—the service entry was not appearing on the My Calendar page. 

Services created with comments that include quotation marks or other special characters are now 
correctly displayed on the My Calendar page. 

Where to find it: 

• Client → Services → Services list page → Click ‘New’ → Service Detail → Enter required 
fields and comments (including special characters) → Save 

• Client → Services/Notes → Services/Notes list page → Click ‘New’ → Service Note → Enter 
required fields and comments → Save 

• My Office → My Calendar → Hover over the created service entry 

 

Core Bugs # 132811: New Calendar Entry items not synching with Outlook 

What’s fixed: New calendar entries created in SmartCare were not syncing with Outlook, resulting in 
scheduled appointments not appearing in the Outlook calendar. 

The system now successfully syncs new calendar appointments with Outlook, ensuring scheduled 
events are properly reflected. 

Where to find it: 
My Office → New Calendar Entry → Select date → Click time slot → New Entry pop-up → Select 
New Calendar Entry → OK → Scheduler Event pop-up → Fill required fields → OK 

My Reports/UDS Reports 
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Reference No Task No Description 

111 Core Bugs # 132321 The ‘ClientWasPresent’ flag is not present in the 
‘Services with Procedure Rate Errors’ Report 

112 Core Bugs # 132572 ‘Payment Receipt Report’ Issue. 

113  Core Bugs # 132709 Getting an error when generating ‘ER Claim Line Details’ 
or ‘ER Claim Line Details CSV’ reports. 

114 Core Bugs # 132796 Reports name not displayed correctly in search bar. 

115 Core Bugs # 132847 Some fields are removed from the XML files for some 
record types in the IPFQR List Page. 

116 Core Bugs # 132858 Incident Reports list page and widget not showing 
accurate number of incidents. 

Core Bugs # 132321: The ‘ClientWasPresent’ flag is not present in the ‘Services with 
Procedure Rate Errors’ Report 

What’s fixed: The ClientWasPresent flag was missing from the Services with Procedure Rate Errors 
report. This has been resolved. A new column, Client Was Present, has been added to the report with a 
Y/N flag: 

Y = Rate meets the Client Was Present criteria 

N = Rate does not meet the criteria 

Where to find it: 

Service Creation: 
Go to Search → Services → Click New → Create a service that triggers the “Unable to find matching 
rate for the selected procedure” validation. 

Report Access: 
Go to Search → My Reports → Services with Procedure Rate Errors → Enter Date of Service Start 
and Date of Service End → Click View Report. 

Core Bugs # 132572: ‘Payment Receipt Report’ Issue. 

What’s fixed: Previously, the Payment Receipts Report did not include payment records that were 
entered without a value in the Location field on the Payments/Adjustments screen. This caused 
discrepancies between the report totals and the data exported from the Payments/Adjustments list page. 

With this release, the report now includes all payment records—regardless of whether the Location field 
was filled—ensuring accurate totals that align with the Payments/Adjustments list data. 

Where to find it: 

1. My Office → Payments/Adjustments → Enter ‘Received From’ and ‘Received To’ dates → 
Apply Filter 

2. My Office → My Reports → Search “Payment Receipts Report” → Click report name → Enter 
parameters and matching date range 

 

 

Core Bugs # 132709: Getting an error when generating ‘ER Claim Line Details’ or ‘ER 
Claim Line Details CSV’ reports. 
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What’s fixed: Users were receiving an error when generating the ER Claim Line Details or ER Claim 
Line Details CSV reports if the selected ERFileId included multiple services grouped under the same 
ClaimLineItemId. 

Reports now generate successfully and display the correct data, even when multiple services are 
grouped under the same claim line. 

Pre-requisite: 
Process an 835 file that includes multiple services under the same ClaimLineItemId and note the 
corresponding ERFileId. 

Where to find it: 

• My Office → My Reports 

 Search for ER Claim Line Details or ER Claim Line Details CSV 

 Click the report name → Enter the ERFileId → Click View Report 

 

Core Bugs # 132796: Reports name not displayed correctly in search bar. 

What’s fixed: When users searched for reports or QuickLinks associated with My Office in the Search 
Bar, the system incorrectly displayed a generic QuickLink labeled “View Report” instead of the actual 
report name. The search results now correctly display the actual report names, and GoSearch results 
return the expected output. 

Pre-requisite: 
Set all QuickLinks associated with My Office to Deny in the Roles/Permissions tab of the Staff Details 
screen. 

Where to find it: 
Click Search Bar → Type and search for QuickLinks/Reports associated with My Office 

Core Bugs # 132847: Some fields are removed from the XML files for some record types 
in the IPFQR List Page. 

What’s fixed: Certain fields were incorrectly included in the XML files for specific record types in the 
IPFQR List Page, due to custom logic in the customer's environment. 

The following fields have been removed from the XML files for the respective record types: 

• IMM: Removed Header and Sex field 

• SMD, SUB, TOB, TR: Removed <file-audit-data>, <abstraction-audit-data>, and Sex field 

Note: This fix is specific to environments with customized logic for IPFQR XML generation. 

Where to find it: 
My Office → IPFQR List Page 

 

Core Bugs # 132858: Incident Reports list page and widget not showing accurate number 
of incidents. 

What’s fixed: The Incident Reports list page and the Incident Reports (C) widget on the Dashboard 
were not displaying the correct number of incidents, leading to discrepancies in reporting. The system 
now accurately reflects the total number of incidents in both the list page and the dashboard widget, 
ensuring reliable incident tracking. 

Where to find it: 
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1. Search and select Incident Reports (My Office) → Confirm the newly saved incident appears in 
the total count 

2. Go to Dashboard (My Office) → View the Incident Reports (C) widget 

Patient Portal 

Reference No Task No Description 

118 Core Bugs # 132538 Patient Portal login issue 

Core Bugs # 132538: Patient Portal login issue 

What’s fixed: Previously, when a Patient Portal ID was deleted and then recreated from the Client 
Information (C) screen or Contacts tab, the system failed to populate the temporary Username and 
Password in the Change Password PDF after clicking Reset. This prevented clients from logging into the 
Patient Portal. 

The system now correctly generates and displays the temporary credentials in the Change Password 
PDF, allowing successful login after resetting the Patient Portal ID. 

Where to find it: 

1. Client → Client Information (C) 

• Click Patient Portal ID hyperlink → Navigate to Non-staff User Details 

• Click Delete → Click Create → Click Reset → Confirm credentials appear in Change 
Password PDF 

2. Client → Client Information (C) → Contacts tab 

• Select a Client Contact → Click Patient Portal ID hyperlink 

• Click Delete → Click Create → Click Reset → Confirm credentials appear in Change 
Password PDF 

Plans 

Reference No Task No Description 

119 Core Bugs # 132437 Coverage: Leading/trailing spaces are preventing the 
duplicate prevention validation message from triggering 
correctly. 

Core Bugs # 132437: Coverage: Leading/trailing spaces are preventing the duplicate 
prevention validation message from triggering correctly. 

What’s fixed: The system previously failed to detect duplicate Coverage records when the Insured ID 
field included leading or trailing spaces (e.g., " 123" or "123 "), allowing unintended duplicates. 

The Insured ID field is now automatically trimmed, and if a duplicate exists, the system displays the 
following validation message: 
“Plan with Insured ID already exist.” 

Where to find it: 
Go to Client → Coverage → Coverage list page → Click on any Plan Name hyperlink → Client Plans 
screen → Insured ID field. 

Pre-condition: 
A coverage record exists with a specific plan and Insured ID (e.g., "123"). 

Procedures/Rates 
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Reference No Task No Description 

121 Core Bugs # 132551 expired ProcedureRateId are retrieving when service is 
created. 

Core Bugs # 132551: expired ProcedureRateId are retrieving when service is created. 

What’s fixed: Previously, when creating a service, the system was incorrectly retrieving expired 
ProcedureRateId values if the procedure’s ToDate had passed (e.g., '2025-08-04 23:59:59.000'). This 
caused outdated rates to be applied during charge generation. 

The system now correctly retrieves only unexpired ProcedureRateId values when creating services, 
ensuring accurate billing and rate assignment. 

Where to find it: 

1. Client → Services → Services list page 

• Click New → Enter required fields → Complete the service 

• Click on Charge amount hyperlink → Charge Details screen → Billing Code section → Click 
Rate ID hyperlink 

2. My Office → Charges/Claims → Charges/Claims list page 

• Select Charge ID → Click E Claims → Claims Processing pop-up → Enter details → Click 
Process Now → Click Create Claim File 

• Confirm correct amount in SV segment 

Programs 

Reference No Task No Description 

122 Core Bugs # 132617 The ‘Assigned Staff’ dropdown excluded inactive staff for 

existing client program entries in the ‘Program 

Assignment Details’ page. 

Core Bugs # 132617: The ‘Assigned Staff’ dropdown excluded inactive staff for existing 

client program entries in the ‘Program Assignment Details’ page. 

What’s fixed: The ‘Assigned Staff’ dropdown on the Program Assignment Details page did not 
display inactive staff for existing program entries, causing the field to appear blank if the assigned staff 
member was no longer active. 

Inactive staff now appear in the dropdown for existing assignments, preserving historical accuracy. 
Note: Inactive staff are still excluded when creating new program entries. 

Where to find it: 

Option 1: Program → Program Assignments → Open an existing assignment → Check Assigned 
Staff dropdown 

Option 2: Client → Programs → Open an existing program → Check Assigned Staff dropdown 

Provider Contract  

Reference No Task No Description 

123 Core Bugs # 132717 The Contract Details screen was labeled with the same 
name in both the Provider Contracts and Contracts 
screens. 
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Core Bugs # 132717: The Contract Details screen was labeled with the same name in 
both the Provider Contracts and Contracts screens. 

What’s fixed: The Contract Details screen previously displayed the same label in both the Provider 
Contracts and Contracts sections, which caused confusion. In Provider Contracts, the screen is labeled 
"Contract Details (Provider)" 

In Contracts, it is labeled "Contract Details (My Office)" 

Where to find it: 

My Office → Provider Contract → Provider hyperlink → Provider → Provider Contract 
My Office → Contracts → Contract ID hyperlink 

Reception 

Reference No Task No Description 

125 Core Bugs # 132641 The Appointment is duplicating when attempting to 
reschedule. 

Core Bugs # 132641: The Appointment is duplicating when attempting to reschedule. 

What’s fixed: Rescheduling a Service Appointment was causing duplicate entries to appear on the 
Calendar screen. 

Rescheduling now cancels the original appointment and creates a single updated entry, ensuring 
accurate scheduling. 

Where to find it: 
Create a New Service → Save → Go to Reception screen → Filter by date → Click Number of Times 
Rescheduled → Select time and reschedule → Confirm only one appointment appears on the Calendar. 

Rx Application 

Reference No Task No Description 

131 Core Bugs # 132267 Start page: Outbound Prescribers are displayed as blank 
when filtered by clinicians in the database while running 
the specific stored procedure. 

132 Core Bugs # 132592 RX - Patient Summary - Medication list is not loading. 

133 Core Bugs # 132625 Rx: duplicate instructions were displayed for existing 
client order under the Medication List section in the 
Patient Summary page. 

134 Core Bugs # 132813 Slowness when navigating from SmartCare to Rx. 

135 Core Bugs # 132854 The ‘X’ button was visible for SmartCare Orders in the 
Patient Summary screen, despite being non-functional. 

136 Core Bugs # 132855 Inactive allergies are displayed in the ‘Current Allergies’ 
widget of SmartView.. 

Core Bugs # 132267: Start page: Outbound Prescribers are displayed as blank when 
filtered by clinicians in the database while running the specific stored procedure. 
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What’s fixed: The stored procedure ssp_SCGetSureScriptOutboundPrescription was returning no results 
and had long execution times when filtering Outbound Prescribers by clinicians. 

The procedure logic has been optimized, and results are now retrieved successfully within 7 seconds. 

Where to find it: 
Not applicable (backend stored procedure execution). 

Core Bugs # 132592: RX - Patient Summary - Medication list is not loading. 

What’s fixed: Previously, when a client had a large number of diagnosis codes listed in the Patient 
Overview tab, the Medication List section on the Patient Summary screen (Rx Application) would 
shrink unexpectedly. This was due to the absence of a scrollbar to manage overflow content, resulting in 
limited visibility and a poor user experience. 

With this release, a scrollbar has been added to the Patient Overview tab. This ensures that overflow 
content is properly handled and the Medication List section remains fully visible, regardless of the 
number of diagnosis codes. 

Where to find it: 
Search and select a client → Medication Management (Client) → Patient Summary screen (Rx 
Application) 

Core Bugs # 132625: Rx: duplicate instructions were displayed for existing client order 
under the Medication List section in the Patient Summary page. 

What’s fixed: The Patient Summary page in the Rx application was showing duplicate instructions for 
existing client orders under the Medication List section. 

Instructions now display correctly without duplication. 

Where to find it: 
Search for a client → Create a New Client Order → Select medications and complete required fields → 
Sign the order → Go to Medication Management (Rx) → Open the Patient Summary page → Review 
the Medication List section. 

Core Bugs # 132813: Slowness when navigating from SmartCare to Rx. 

What’s fixed: Previously, users experienced slowness when navigating from the SmartCare application 
to the Rx application via the Patient Summary screen, impacting performance and workflow efficiency. 

The system now loads the Rx application smoothly without delays when accessed from SmartCare. 

Where to find it: 
Select a client → Medication Management (Client) → Patient Summary screen (Rx Application) 

Core Bugs # 132854: The ‘X’ button was visible for SmartCare Orders in the Patient 
Summary screen, despite being non-functional. 

What’s fixed: The ‘X’ (Discontinue) button was incorrectly visible for SmartCare Orders in the Patient 
Summary screen of the Rx Application, even though it was non-functional. This caused confusion for 
users attempting to manage orders. 

The system now hides the ‘X’ button for SmartCare Orders until the order is completed within the Rx 
Application, ensuring a clearer and more intuitive user experience. 

Where to find it: 
Search and select a client → Go to Medication Management (Client) → Patient Summary screen (Rx 
Application) → View Medication list 
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Core Bugs # 132855: Inactive allergies are displayed in the ‘Current Allergies’ widget of 
SmartView.. 

What’s fixed: Inactive allergies were incorrectly appearing in the Current Allergies widget within 
SmartView, leading to inaccurate patient data being displayed. 

The system now correctly filters out inactive allergies, ensuring that only active allergies are shown in the 
Current Allergies widget for accurate and relevant clinical information. 

Where to find it: 
Client → Client Allergies → Client Allergies screen → Click SmartView icon → Navigate to Current 
Allergies widget 

Scanning 

Reference No Task No Description 

137 Core Bugs # 131096 ‘Acknowledgements’ and ‘Acknowledge with Comments/ 

Forward Acknowledgement’ icons are not showing as 

intent in Scanned and Uploaded Documents 

Core Bugs # 131096: ‘Acknowledgements’ and ‘Acknowledge with Comments/ Forward 

Acknowledgement’ icons are not showing as intent in Scanned and Uploaded Documents 

What’s fixed: The ‘Acknowledgements’ and ‘Acknowledge with Comments / Forward 
Acknowledgement’ icons were not functioning as intended in the Scanned Medical Record Detail and 
Upload File Detail screens. These icons did not reflect the setup configured in the Document Code 
Details screen. 

The icons now behave correctly based on the ‘Enable Document Acknowledgement’ setting in the 
associated Document Code. When users select the appropriate Record Type and save the document, 
the icons are enabled or disabled as expected. 

Pre-requisite: 

• In Administration → Document Codes, open the relevant Scanned Document Code 

• Set Enable Document Acknowledgement to Yes 

• Select either Default Staff to Acknowledge or Default Role to Acknowledge 

• Click Save 

Where to find it: 

• My Office → Scanning → Scanned Medical Records → Scan New Images → Scanned 
Medical Record Detail → Select Record Type → Save 

• My Office → Scanning → Scanned Medical Records → Upload New Images → Upload File 
Detail → Select Record Type → Save 

Screens 

Reference No Task No Description 

139 Core Bugs # 132495 The disabled delete (X)icon in Custom grid was getting 
activated for the restricted Staffs and Roles   

Core Bugs # 132495: The disabled delete (X)icon in Custom grid was getting activated for 
the restricted Staffs and Roles   
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What’s fixed: Previously, the Delete (X) icon in custom grids was incorrectly activated for staff and roles 
that were restricted from using it. This allowed unauthorized users to trigger a delete confirmation pop-up, 
despite the control being disabled. 

The system now correctly enforces permission restrictions. When the delete icon is disabled for restricted 
staff, it no longer responds to user interaction or displays the confirmation pop-up. 

Pre-requisites: 

• Login to SmartCare as Admin Staff 

• Use hotkey CTRL + ALT + M to insert the delete control on a custom grid 

• Confirm the control is subject to permission management 

• Ensure permission for Delete Button is disabled for non-admin staff 

Where to find it: 
Login to SmartCare as Non-admin Staff → Navigate to a screen with a configured custom grid → Hover 
over the Delete (X) icon → Confirm it remains disabled and does not trigger any action 

Services from Claims 

Reference No Task No Description 

140 Core Bugs # 132476 MCO-PM Transfer: Claim Count Did not match at the 
different steps in the process. 

Core Bugs # 132476: MCO-PM Transfer: Claim Count Did not match at the different steps 
in the process. 

What’s fixed: Previously, when processing claims through the MCO-PM Transfer workflow, multiple 
services were incorrectly created from a single claim line if it included multiple locations for the filed Place 
of Service. This caused mismatched claim counts across different steps in the process. 

The system now includes a defensive condition to prevent duplicate processing of ClaimLineIds, 
ensuring that only one service is created per claim line. 

Where to find it: 
My Office → Services From Claims → Select claim lines → Click Create Service icon → Confirm only 
one service is created per claim line 

Services 

Reference No Task No Description 

142 Core Bugs # 132282 The calculation of the procedure rate was not correct, 
when a service was created 

143 Core Bugs # 132385 Services: application allowed the users to change the 
service’s status from Complete to No Show across 
browsers. 

144 Core Bugs # 132603 Separate Dx code for Add On services in Primary Care 

145 Core Bugs # 132635 Individual services just "popped up" in the last 5 hours. 

146 Core Bugs # 132699 Batch Service Import: Upload New Services pop up is 
displayed blank. 
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147 Core Bugs # 132765 a “Timeout Expired” error is logged in the ‘ErrorLog’ 
table. 

148 Core Bugs # 132785 ‘Services (My Office) List’ page: Implemented a new 
‘Failed Services’ pop-up for error and mass complete for 
services. 

Core Bugs # 132282: The calculation of the procedure rate was not correct, when a 
service was created 

What’s fixed: Procedure rates were being calculated incorrectly when the associated service area was 
mapped to the XSPENDOWN recode. This issue has been resolved. Now, if a procedure rate uses a 
service area linked to XSPENDOWN, that rate is excluded during service creation, ensuring accurate 
calculations. 

Where to find it: 

Recode Setup: 
Go to Administration → Recodes → Search for XSPENDOWN → Add the Service Area ID in the 
Integer Code Id field. 

Procedure Rate Setup: 
Create a procedure rate using the service area mapped above. 

Service Creation: 
Go to Client → Services → New → Create a service using the procedure code tied to the configured 
service area. 

Core Bugs # 132385: Services: application allowed the users to change the service’s 
status from Complete to No Show across browsers. 

What’s fixed: 

Previously, users could change a service’s status from Complete to No Show across different browsers, 
leading to inconsistent behavior. Now, once a service is marked as Complete in one browser (e.g., 
Chrome), its status cannot be changed from another browser (e.g., Edge), ensuring consistent status 
handling and data integrity. 

Where to find it: 

Step 1 (Edge): 
Go to Client Search → Select a client with a coverage plan → Navigate to Services → Create and save 
a service with Scheduled status. 

Step 2 (Chrome): 
Go to Client Search → Select the same client → Locate the scheduled service → Change status to 
Complete → Click Save. 

Step 3 (Edge): 
Open the same service → Attempt to change status to No Show → Status change is now restricted. 

Core Bugs # 132603: Separate Dx code for Add On services in Primary Care 

What’s fixed: In Primary Care, add-on services were incorrectly displaying all diagnosis (Dx) codes in 
the service detail, instead of only showing the Dx code selected during the signing of the Medical 
Progress Note. 

The system now correctly displays only the Dx code added in the Add-On Code tab at the time of signing 
the Medical Progress Note, ensuring accurate billing and documentation. 
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Where to find it: 
Client → Medical Progress Note → New → Select Abdominal Pain template → Order Problem List 
→ Enter values → OK → Sign 
→ Services (Client) → Select created service → Mark as Complete 
→ Services → Select Add-On service → Billing Procedure 

 

Core Bugs # 132635: Individual services just "popped up" in the last 5 hours. 

What’s fixed: Recurring services unexpectedly appeared for past dates due to system behavior tied to a 
configuration setting. 

This has been resolved by introducing a new configuration key: 
CreateRecurringServicesForPastDates. 

• When set to Yes (default), recurrences are created for both past and future dates. 

• When set to No, only future recurrences are created. 

• Any other value defaults to Yes behavior. 

Where to find it: 

• Go to Administration → Configuration Keys → Open 
CreateRecurringServicesForPastDates → Update value as needed 

• View recurrence behavior in: 

 Client → Services → Service Detail → Edit Recurring 

 Client → Services/Notes → Service Note → Edit Recurring 

 My Office → Groups → Group Details → Schedule → Edit Recurring 

 

Core Bugs # 132699: Batch Service Import: Upload New Services pop up is displayed 
blank. 

What’s fixed: The Upload New Services popup in Batch Service Import was appearing blank when 
users clicked the Upload Import File icon. 

The popup now displays correctly with all required options to select and upload a file. 

Where to find it: 
My Office → Batch Service Import Files → Click Upload Import File → Confirm the Upload New 

Services popup displays as expected. 

Core Bugs # 132765: a “Timeout Expired” error is logged in the ‘ErrorLog’ table. 

What’s fixed: Users encountered a “Timeout Expired” error when attempting to export a large volume 
of data from the Services List page. The error was logged in the ErrorLog table, and the export operation 
failed. 

Users can successfully export large volumes of Services data to Excel without errors, and no timeout 
entries are logged in the ErrorLog table. 

Where to find it: 
My Office → Services → Enter filter values → Select Date range → Apply filter → Click Export icon 

Core Bugs # 132785: ‘Services (My Office) List’ page: Implemented a new ‘Failed 
Services’ pop-up for error and mass complete for services. 
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What’s changed: A new Failed Services pop-up has been implemented on the Services (My Office) 
List page to display error messages when attempting to mass complete or error services that do not meet 
payment criteria. 

When users attempt to error a completed service where the balance payment is not zero, the system now 
displays an error message with the Service ID: 

Error Message: “Service ID: XXXX - Service cannot be deleted since the balance of the payment is not 
zero.” 

This pop-up also appears during mass completion of services, showing exception messages for any 
failed services. 

Where to find it: 

1. Configuration Setup: 
Administration → Configuration Keys → Search for 
ALLOWSERVICEERRORWITHPAYMENT → Apply Filter → Click on Configuration Key → 
Ensure value is set to N 

2. To trigger error message: 
Client Search → Select Client → Services → Click on New → Fill in Service Details with 
Charge → Save → Complete Service → Make Payment → 
My Office → Services List → Select Service → Select Action: Error → Confirm → View 
Failed Services pop-up 

3. To trigger mass complete error message: 
My Office → Services List → Filter for services in ‘Show’ status → Select multiple services → 
Select Action: Complete → Confirm → View Failed Services pop-up 

Note: Only services with a zero balance can be errored. 

Services/Notes 

Reference No Task No Description 

150 Core Bugs # 132531 The client name is not displayed when opening a private 
window from the ‘Service Note’ page. 

151 Core Bugs # 132582 The system was not displaying all the available 
procedures in the dropdown, regardless of the selected 
program. 

152 Core Bugs # 132620 JavaScript error is logged on the ‘ErrorLogViewer’. 

153 Core Bugs # 132706 The ‘GOALOBJECTIVESTATUS’ Global Code Sort 
Order is not being honored in the DFA note. 

Core Bugs # 132531: The client name is not displayed when opening a private window 
from the ‘Service Note’ page. 

What’s fixed: Previously, when users opened a Private Window from the Service Note page, the 
client’s name was not displayed in the new window, causing confusion and lack of context. 

The system now correctly displays the client’s name when the Private Window is launched from the 
Service Note page. 

Where to find it: 
Client → Services/Notes → Services/Notes list page → Click on DOS hyperlink → Service Note page → 
Click Private Window icon → Confirm client name is displayed in the new window 
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Core Bugs # 132582: The client name is not displayed when opening a private window 
from the ‘Service Note’ page. 

What’s fixed:  

Previously, the system did not display all available procedures in the Procedure dropdown when a 
specific program or the All Programs option was selected. This caused incomplete data in the Service 
Note PDF output, as the dropdown only showed procedures mapped to the selected program and did not 
account for the AllowAllPrograms configuration. 

With this release, the AllowAllPrograms logic has been implemented. The system now displays all 
available procedures in the dropdown, regardless of the selected program, ensuring complete and 
consistent Service Note PDF generation. 

Where to find it: 
Client → Search Services Note Reviewer (Client) → Select Date → Select Previous No. of Days → 
Select Program(s) → Select Procedure(s) → Select Status(s) → Click View PDF 

Core Bugs # 132620: JavaScript error is logged on the ‘ErrorLogViewer’. 

What’s fixed: Previously, when users attempted to create or modify a Service Note (e.g., CPST Note), a 
JavaScript error was logged in the ErrorLogViewer list page. This disrupted the workflow and indicated 
a backend issue with screen record handling. 

The system no longer logs JavaScript errors in the ErrorLogViewer when users create or modify Service 
Notes. 

Where to find it: 

1. Client → Services/Notes → Click New → Select Program, Procedure, and Location → Enter 
required data → Click Save 

2. Administration → ErrorLogViewer → View log entries 

 

Core Bugs # 132706: The ‘GOALOBJECTIVESTATUS’ Global Code Sort Order is not 
being honored in the DFA note. 

What’s fixed: In DFA Notes, the Objective Status dropdown was ignoring the custom sort order defined 
in the GOALOBJECTIVESTATUS Global Code and defaulting to alphabetical order. 

If a Sort Order is defined in the Global Code, the dropdown now respects it. If not, it continues to sort 
alphabetically. 

Where to find it: 

• Set sort order: Go to Global Codes → Filter by category GOALOBJECTIVESTATUS → Open 
the category → Set and save the desired Sort Order for each code. 

• Use in note: Go to Client → Services/Notes → Create a new DFA Note using a procedure code 
that includes the Objectives Addressed by this Service section → In the Note tab, verify that 
the Goal Status dropdown reflects the configured sort order → Sign the note. 

SmartCare improvements 

Reference No Task No Description 

154 Core Bugs # 132535 list pages: Export Button Fails to Generate Download   

155 Core Bugs # 132834 Unsupported Browser Warning for Microsoft Edge Mobile 
on SmartCare 
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Core Bugs # 132535: list pages: Export Button Fails to Generate Download   

What’s fixed: Previously, the Export button on list pages failed to generate a downloadable file when the 
search criteria included special characters. This issue was first identified on the Document Validations 
screen, where using symbols like “+” in filters prevented the export from working. 

The system now correctly handles special characters in search criteria, allowing users to export filtered 
results to Excel without any issues. 

Where to find it: 
Navigate to any list page → Apply filters with special characters → Click Export → Confirm file is 
downloaded successfully 

Core Bugs # 132834 

What’s fixed: Users accessing SmartCare via the Microsoft Edge mobile browser on iPhone or iPad 
were incorrectly shown an “unsupported browser” error message, instructing them to use Google 
Chrome. 

The system now correctly supports Microsoft Edge on iOS devices. Users can access the SmartCare 
login screen without encountering browser compatibility warnings. 

Where to find it: 
Open the SmartCare application link on iPhone or iPad using one of the following browsers: 

• Chrome 

• Edge 

• Safari 

• Firefox 
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Staff/Users 

Reference No Task No Description 

156 Core Bugs # 132880 The credentialing grid failed to load all existing details in 

the ‘Credentialing’ tab of the ‘Staff Details’ screen. 

Core Bugs # 132880: The credentialing grid failed to load all existing details in the 

‘Credentialing’ tab of the ‘Staff Details’ screen. 

What’s fixed: Previously, the credentialing grid in the Staff Details screen failed to load all existing entries 
when either the CoveragePlanId or PayerId was missing due to backend uploads or table editor 
changes. This caused incomplete data to appear in the Credentialing tab. 

The system now includes defensive UI logic to handle missing CoveragePlanId or PayerId values, 
ensuring the credentialing grid loads all existing details reliably. 

Where to find it: 

1. Administration → Staff/Users → Staff/Users list page 

• Click New → Staff Details → Credentialing tab 

• Select Coverage radio button → Choose Plan → Enter required values → Click Insert → 
Click Save 

2. Administration → Staff/Users → Staff/Users list page 

• Click New → Staff Details → Credentialing tab 

• Select Payer radio button → Choose Plan → Enter required values → Click Insert → Click 
Save 

Work Groups list screen 

Reference No Task No Description 

157 Core Bugs # 132727 The ‘Export’ Functionality is not working in the ‘Work 
Groups’ List Page   

Core Bugs # 132727: The ‘Export’ Functionality is not working in the ‘Work Groups’ List 
Page   

What’s fixed: The Export functionality was not working on the Work Groups list page, preventing users 
from exporting data as expected. The Export feature is now functioning correctly and allows data to be 
exported from the Work Groups list screen. 

Where to find it: 
Administration → Work Groups → Work Groups list page 
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Global Codes 
Global Codes are the individual entries or options assigned to a Global Code Category. Global Codes can 
be core or custom. For example, a Global Code Category and the associated Global Codes are the 
options you will select from a dropdown list.  

Review and configure the following Global Code Categories and Global Codes that belong to each 
category before performing the workflows documented in these release notes.  

Ref No. Category Name 

10 ClearingHouse 

21 PLACEOFSERVICE 

78 Ethnicity 

78 RACE 

78 ClientConsents 

153 ‘GOALOBJECTIVESTATUS’ 

Recodes 
A Recode is a subset of other system codes that populate a list for a specific reporting purpose. Recodes 
create an allowed list of entries from multiple larger lists.  

Review and configure the following before performing the workflows documented in these release notes.  

Ref No. Category Code 

91 SetMedicationForMATMultiInventoryDispense 

142 'XSPENDOWN' 

Configuration Keys 
Configuration keys are settings that instruct the system (or a particular module or page) to behave in a 
desired way. Each Key has a set of values that correspond to particular behaviors. The organization 
should determine Configuration Key settings and adjust them as needed.  

Review and configure the following before performing the workflows documented in these release notes.  

bookmark://_Core_Bugs_/#_2
bookmark://_Core_Bugs_/#_2
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Ref No. Key Name 

43 EnableBarcodeScanning 

44 DisplayCDAGSectionInStaffDetails 

44 EnableClinicalDataAccessGrouping 

62 ShowAdditionalQuestionSectionOnCorePHQ9Document 

62 ShowAdditionalQuestionsSectionOnCorePHQADocument 

64 DisplayCDAGSectionInStaffDetails 

64 EnableClinicalDataAccessGrouping 

79 TurnOnCareCoordinationWorkflow 

145 CreateRecurringServicesForPastDates 

148 ALLOWSERVICEERRORWITHPAYMENT 

Data Model Changes  

Ref No. Data Model Change 

32 A new column 'ClientOrderId is added to the OrderTemplateFrequencyOverRides 
table 
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SmartCare Testing Strategy – August 2025 MSP  

Purpose: 
To confirm that key workflows in each module function correctly after the release, focusing on high-impact 
defect fixes (Core Bugs) to ensure resolved issues work as expected. 

How to Use This Strategy 

1. Start with modules you use most often in daily operations. 
2. Within each module, test workflows tied to defect fixes. 
3. Follow the navigation paths in the release notes for each task. 
4. Document: 

a. Pass / Fail outcome 
b. Unexpected behaviors 
c. Follow-up questions or concerns 

Note: The   orange icon indicates an active change, meaning the update requires customer setup or 

direct action (such as enabling a new field, adjusting a configuration, or testing a newly introduced 
workflow) rather than being applied automatically in the system 

These testing workflows may vary depending on your organization’s specific SmartCare configuration, so 
be sure to adjust steps as needed to align with your local settings and processes. 

Testing Workflow by Module – Core Bugs Only 

Adhoc Reporting 

•   Core Bugs #132752 – Verify saved reports correctly display under the selected catalog report 

section list. 

Alerts 

• Core Bugs #132561 – Confirm no error occurs when accessing and signing a service note from 
the Alerts screen. 

Authorizations 

• Core Bugs #132763 – Ensure “Review Status” updates properly to Completed in Service Request 
– Review/Approval Detail. 

Batch Eligibility 

• Core Bugs #132653 – Validate mapping between Batch Eligibility Configuration ID and Clearing 
House ID. 

Batch Services 

• Core Bugs #132632 – Confirm all services created from Batch Service Entry are present. 

•   Core Bugs #132890 – Test batch service import to ensure files upload without failure. 
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Bedboard 

• Core Bugs #132626 – Ensure discharged clients no longer appear on Programs list when both 
Bed Assignment Activity and Inpatient Activity are deleted. 

• Core Bugs #132816 – Test duplicating a bed assignment to confirm expected results. 

Charges/Claims 

• Core Bugs #132145 – Verify “Allowed Amount Adjustment” defaults from template plan when not 
specified. 

• Core Bugs #132234 – Validate rounding calculation for adjustments in 835 process. 

Rx Application / Patient Summary 

•   Core Bugs #132625 – Confirm duplicate instructions no longer display under Medication List. 

• Core Bugs #132813 – Validate navigation performance from SmartCare to Rx. 

• Core Bugs #132854 – Ensure “X” (Discontinue) button is hidden for SmartCare Orders until 
completion. 

• Core Bugs #132855 – Confirm inactive allergies no longer appear in SmartView “Current 
Allergies” widget. 

Scanning 

• Core Bugs #131096 – Verify Acknowledgement icons function correctly in Scanned and 
Uploaded Documents. 

 

Screens / UI Controls 

• Core Bugs #132495 – Confirm disabled delete (X) icon in custom grids does not activate for 
restricted staff/roles. 

Services from Claims 

• Core Bugs #132476 – Ensure claim counts remain consistent across MCO-PM Transfer workflow 
steps. 

Services 

• Core Bugs #132282 – Verify accurate procedure rate calculation during service creation. 

• Core Bugs #132385 – Confirm status cannot be changed from Complete to No Show once 
finalized. 

• Core Bugs #132603 – Validate separate Dx code for Add-On services in Primary Care. 

• Core Bugs #132635 – Monitor for unexpected “pop-up” of individual services. 

• Core Bugs #132699 – Ensure “Upload New Services” pop-up is populated correctly. 

•   Core Bugs #132765 – Test for absence of “Timeout Expired” errors in ErrorLog table. 

• Core Bugs #132785 – Confirm “Failed Services” pop-up works correctly for errors and mass 
completion. 
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Services/Notes 

• Core Bugs #132531 – Ensure client name displays when opening a private window from Service 
Note. 

• Core Bugs #132582 – Validate consistent display of client name in private window. 

• Core Bugs #132620 – Confirm no JavaScript errors appear in ErrorLogViewer. 

• Core Bugs #132706 – Verify GOALOBJECTIVESTATUS Global Code sort order is honored in 
DFA note. 

SmartCare Improvements 

• Core Bugs #132535 – Ensure Export button generates downloads successfully on list pages. 

• Core Bugs #132834 – Confirm improvements behave as documented (refer to detail instructions). 

 

Staff/Users 

• Core Bugs #132880 – Validate credentialing grid loads all details in Staff Details screen. 

• Core Bugs #132727 – Ensure Export functionality works in Work Groups List Page. 

If a Test Fails:  
Create a Zendesk ticket with the module name, task number, detailed steps to reproduce, expected vs. 

actual results, and attach any relevant screenshots or error messages. 
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Version Description MSP Version 

1.0 Initial Release August 2025 MSP 

 


